Forum Linux.debian/ubuntu j'ai supprimé par erreur xserver-xorg (apt-get remove xserver-xorg)

Posté par . Licence CC by-sa.
Tags : aucun
1
17
août
2018

Salut,

Pour régler le problème de webgl qui n'est pas supporté dans les navigateur sous linux antix debian stretch j'ai supprimé par erreur xserver-xorg (apt-get remove xserver-xorg)

Maintenant quand je démarre l'écran est noir et me demande de saisir mon user et mon mot de passe après la confirmation aucune fenêtre ne s'ouvre et même l'accès à internet est impossible

j'ai essayé d"installer xserver-xorg à partir d'un fichier .deb mais sans solution.

Pourriez vous m"aider à résoudre ce problème

Merci d'avance pour votre réponse.

  • # A tout PT

    Posté par (page perso) . Évalué à 2.

    Et apt install xserver-xorg donne quoi ?

    • [^] # Re: A tout PT

      Posté par . Évalué à 3. Dernière modification le 17/08/18 à 10:07.

      Il dit qu'il n'a pas l'accés a internet.
      Pour l'accés à internet, le plus simple est si tu est connecté avec un cable ethernet à un modem/routeur, tu as juste à faire
      dhclient eth0 (ou eth1)

  • # Avec un peu de chance

    Posté par (page perso) . Évalué à 4.

    Salut

    Si tu es sur une "veille" version il se peux que tu ai tout ce qui va bien dans le cache d'apt si tu ne tapes pas souvent apt-get clean. Tu trouveras les paquets téléchargés lors des opérations de mise à jour ou installation dans /var/cache/apt/archives. Avec un peu de chance xserver-xorg est encore là et il n'y a plus qu'à faire un dpkg -i

    Petite question au passage :

    j'ai essayé d"installer xserver-xorg à partir d'un fichier .deb mais sans solution

    Tu veux dire que dpkg -i ./xserver-xorg.deb t'envois ballader ?

    Fuse : j'en Use et Abuse !

  • # Mode console

    Posté par (page perso) . Évalué à 1. Dernière modification le 17/08/18 à 17:58.

    Et si tu passes en mode console (CTRL+ALT+F1), est-ce que tu peux te connecter à une session et donc avoir accès à internet ?

    • [^] # Re: Mode console

      Posté par (page perso) . Évalué à 2.

      Pour ouvrir une console avec CTRL+ALT+F1, le serveur graphique doit, au préalable, avoir démarré.

      Mais dans ce cas, le serveur graphique a été désinstallé, et la seule chose qui s’affiche sur son écran est une console en mode texte.

      Oups, je viens de me rendre compte que ma dernière version Ubuntu + Gnome ne permet plus de basculer sur une console texte avec CTRL+ALT+F1 (pareil avec F2, F3, F4…) !
      J’ai du désactiver cela dans une options… :-(

      Commentaire sous licence Creative Commons Zero CC0 1.0 Universal (Public Domain Dedication)

  • # une possibilite

    Posté par . Évalué à 1.

    Bonjour.
    Si ton bootloader est Grub, tu peux editer la commande de demarrage pour ajouter l'option single (pas sur que ca marche avec systemd, auquel cas tu peux aussi essayer de mettre init=/bin/bash). Une fois en ligne de commande, tu devrais pouvoir monter les partitions necessaires puis lancer ton "apt-get install xserver-xorg".
    Sinon, utilise un SystemRescueCD ou autre pour ensuite faire un chroot dans ton systeme et installer le paquet.
    Dans les 2 cas, tu devrais ensuite pouvoir redemarrer normalement.

    ++
    Gi)

    • [^] # Re: une possibilite

      Posté par . Évalué à 1.

      Salut,

      Merci pour vos réponses et je m'excuse du retard

      j'ai demarré avec un cd d'installation et j'ai monter le system avec chroot j'ai installé xserver-xorg-core mais le problème existe encore.

      j'ai cette erreur dans le fichier /var/log/Xorg.0.log quand je saisi startx

      Parse error on line 152 of section Screen in file /etc/X11/xorg.conf
      "@@MODES@@" is not a valid keyword in this section

      la 152 ligne dans mon fichier /etc/X11/xorg.conf

      SubSection "Display"
      Depth 8
      @@MODES@@
      EndSubSection

      Merci pour votre aide

      • [^] # Re: une possibilite

        Posté par . Évalué à 1. Dernière modification le 23/08/18 à 18:34.

        Merci à vous tous j'ai pu résoudre mon problème en supprimant ou déplaçant le fichier xorg.conf
        et j'ai installé xorg.

        Merci infiniment.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.