Forum Linux.debian/ubuntu Lancer Tomcat depuis Eclipse sans etre Root

Posté par  .
Étiquettes : aucune
0
11
jan.
2007
impossible de lancer tomcat depuis eclipse lorsque je ne suis pas en root.

de plus j'ai besoin de cela pour faire du debug.

J'ai eclipse 3.1 et le plugin sysdeo

je peut lancer mon tomcat en ligne de commande comme cela :
/usr/local/tomcat4/bin/catalina.sh run
mais en etant root !

celle ci lance la veritable commande suivante :
/usr/lib/jvm/java-1.5.0-sun/bin/java -Djava.endorsed.dirs=/usr/local/tomcat4/common/endorsed -classpath /usr/lib/jvm/java-1.5.0-sun/lib/tools.jar:/usr/local/tomcat4/bin/bootstrap.jar -Dcatalina.base=/usr/local/tomcat4 -Dcatalina.home=/usr/local/tomcat4 -Djava.io.tmpdir=/usr/local/tomcat4/temp org.apache.catalina.startup.Bootstrap start



Si je lance en root mon eclipse, je peut alors lancer Tomcat...
pas du tout terrible ....


J'ai bien trouver dans differents forum mentionnant que aucun serveur ne peut etre lancer sans etre root

J'ai donc tenté un visudo et j'ai ajouté cela :

# User alias specification
User_Alias FULLTIMERS = seb

# Cmnd alias specification
Cmnd_Alias TOMCATRUN=/usr/local/tomcat4/bin/catalina.sh

# full time sysadmins can restart Apache:
FULLTIMERS ALL = NOPASSWD: TOMCATRUN

Bon j'ai pas vu la différence....
j'ai surement raté qq chose !

Détails de la config : Ubuntu 6.06
Eclipse : 3.1
Plugins : sysdeo
Tomcat : 4.1.34

Merci d'avance pour votre aide.
  • # port 80 - 8080

    Posté par  . Évalué à 2.

    Si ton tomcat est configuré sur le port 80, c'est normal: seul root peut ouvrir des ports en dessous de 1024. Reconfigure tomcat sur le port 8080.
    • [^] # Re: port 80 - 8080

      Posté par  . Évalué à 1.

      Heu... par défaut Tomcat est sur le port 8080...

      Donc supérieur a 1024 !

      L'erreur que j'obtient est celle ci :

      Catalina.start: LifecycleException: Erreur de démarrage du contexte suite aux erreurs précédentes
      LifecycleException: Erreur de démarrage du contexte suite aux erreurs précédentes
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:3700)
  • # Autre solution

    Posté par  . Évalué à 1.

    Je ne saurais pas vraiment aider sur la façon de faire tourner Eclipse et son plugin Sysdeo à partir d'un Tomcat packagé Debian.

    Par contre ce que tu peux faire si vraiment ça ne marche pas, et vu que le Tomcat en local est utilisé pour du dev, c'est installer une instance de Tomcat custom avec le même compte que celui qui exécute Eclipse.

    Aucune difficulté à installer localement (il n'y a qu'à dézipper le package dans un répertoire et changer le port).
    Il n'y a même pas besoin des variables d'environnement habituelles (JAVA_HOME...), puisque l'on peut lier un JDK a un tomcat via Eclipse.
    Même chose pour le JDK qui peut être installé avec ce user courant.
    Ca n'est ensuite plus qu'une question de paramètrage dans les préférences d'Eclipse pour lier un JDK (Java -> Installed JREs) avec Tomcat (Tomcat -> JVM Settings).

    L'avantage de la chose, c'est que l'on peut avoir plusieurs Tomcat sur différents ports bien sur (ex: un Tomcat 4 et un Tomcat 5, faut en avoir l'utilité bien sur, et c'est mon cas en l'occurrence) ainsi que plusieurs JDK, et switcher si besoin entre ces différents Tomcat sous Eclipse sans aucun soucis (et si on veut pas switcher, rien n'empêche d'avoir un Eclipse bien configuré par Tomcat), etc...

    Je suis surement hors sujet par rapport à ce que tu souhaites faire, mais si ça peut aider au cas ou...
  • # Alleluia !

    Posté par  . Évalué à 1.

    OK cela fonctionne !!

    Comme quoi rien ne sert de .. enfin si.. parfois.. il FAUT chercher des heures durant :-)


    Bon voila le souci qui se posait... c'était un bêêêête droit d'accès sur le système de fichier

    Car je confirme .. si je met un port en dessous de 1024 cela ne fonctionne pas.. mais avec 8080 pas de souci !


    J'ai simplement fait un
    chmod -R g+w /usr/local/tomcat4/*

    mon user (seb) faisant parti du groupe tomcat

    Je l'avais ajouté au préalable avec la commande :

    gpasswd -a seb tomcat

    ca va faire sourire.. mais je l'ai cherché un moment car avec l'éditeur graphique ( users-admin ) je pensais que cela ne fonctionnais pas..

    en effet je faisais une commande
    groups
    apres m'etre ajouté dans le groupe tomcat et RIEN.. je ne voyais pas le groupe tomcat dans la liste de mes groupes.. et meme apres avoir ouvert un nouveau terminal.

    En fait il faut se reconnecter pour cela... donc un
    su nomDuUser dans le terminal a réglé le pb...

    Et voila.. je peux lancer mon tomcat depuis Eclipse


    *********************************

    A signaler en passant : peut etre es-ce arrivé a qq1 de vouloir lancer tomcat en DEBUG avec le plugin Sysdeo... et bien moi perso je n'y suis pas arrivé.

    En effet il semblerait que l'icone de lancement qui est ajoutée dans la barre d'outils, lance tomcat en 'RUN' et pas en 'DEBUG' !

    Bon qu'a cela ne tienne je prend dans le menu contextuel
    Debug as -> Debug... et la je choisis mon Tomcat :-)

    Il m'est ainsi possible de débugger à la fois la partie serveur et la partie cliente de mon application


    Bien à vous

    sgamier

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.