Forum Linux.debian/ubuntu Mystère sur un debian

Posté par  .
Étiquettes : aucune
0
24
oct.
2004
Bonjour !

J'ai fait un dist-upgrade cet après-midi, et j'ai répondu oui quand on m'a demandé s'il fallait utiliser le fichier de conf d'un packager pour remplacer le mien (je crois que le paquet avait "font" dans son nom).

J'ai maintenant deux problèmes, dont je ne sais pas s'ils sont liés :
1) Mon clavier ne marche plus sous X : quand on tape sur une touche, le système se bloque complètement pendant environ une seconde et demi, et rien d'autre ne se passe.
2) Les fontes sont maintenant dégueulasses, sans anti-aliasing (à la limite, je m'en tape à court terme, mais tout de même...)

Ce qui est étrange, c'est que si je fait "startx" en mode console, avec l'utilisateur root, et bien mon clavier marche.

Je ne comprend pas très bien ce qui se passe.....
  • # Sous KDE ?

    Posté par  (site Web personnel) . Évalué à 2.

    J'ai eu le même problème de clavier que toi suite à une mise à jour de KDE.
    Je ne sais pas si tu utilises KDM, mais au cas où, j'ai pu le résoudre en éditant mon fichier /etc/kde3/kdm/Xservers :

    Remplacer la ligne :
    :0 local@tty1 /usr/X11R6/bin/X -nolisten tcp

    Par :
    :0 local@tty1 /usr/X11R6/bin/X -nolisten tcp vt7

    Puis relancer KDM par un /etc/init.d/kdm restart.


    En ce qui concerne ton problème de polices de caractères, c'est un grand classique sous Debian (hélas !), et il y a rarement une solution miracle.
    A tout hasard, le dernier problème que j'ai rencontré était lié au fait que certaines des polices de caractères que j'avais définies dans le panneau de contrôle de KDE n'existaient plus ...

    Si tel n'est pas le cas, Google est ton ami :
    http://groups.google.com/groups?hl=fr&lr=&ie=ISO-8859-1&(...)

    Bon courage ... ;-)
    • [^] # Re: Sous KDE ?

      Posté par  . Évalué à 1.

      Merci beaucoup ! Je peux déjà me connecter.

      Ca fait un petit peu chamanique, dans la medure où je ne sais pas ce que ça veut dire, ce "vt7"...
      • [^] # Re: Sous KDE ?

        Posté par  (site Web personnel) . Évalué à 2.

        Ca fait un petit peu chamanique, dans la medure où je ne sais pas ce que ça veut dire, ce "vt7"...

        Ça veut dire virtual terminal 7, celui que tu obtiens avec un (CTRL+) ALT+F7, et ça force KDM à démarrer sur ce fameux terminal n°7.

        Pour les curieux, l'explication se trouve ici : http://lists.debian.org/debian-qt-kde/2004/08/msg00549.html(...)
        Grosso-merdo, ça serait lié au fait que sans cette option, kdm cherche à obtenir le premier terminal virtuel disponible (à savoir un qui n'est pas attribué à getty), et que dans certaines circonstances, au moment du boot, il attraperait le vt2 avant getty. Du coup il s'appropierait le clavier du vt2 alors qu'il démarre effectivement sur le vt7. Avec l'option, on lui demande explicitement de s'accrocher sur le vt7.

        Vala, vala ...
        • [^] # Re: Sous KDE ?

          Posté par  (site Web personnel) . Évalué à 1.

          Pour le problème de polices de caractères, je constate que la police Helvetica n'existe plus sur mon système suite au dernier dist-upgrade.
          Ça mérite un petit tour par le panneau de configuration de KDE pour faire le point sur les polices utilisées ...
  • # La même

    Posté par  (site Web personnel) . Évalué à 1.

    La même chose, j'utilise plus mon portable depuis hier et me garde bien de mettre à jour l'autre PC tellement les fontes sont à chier depuis l'upgrade.

    En cherchant le coupable, j'ai vu que font-config avait été mis à jour, j'ai downgradé, nada :(

    Vu aussi que libgnomeui avait été mis à jour, ou plutôt renvoyé d'une version 2.8 à 2.6.1, c'est étrange et ça m'étonnerai pas que ça vienne de là.

    Bref, ça me les casse et ça me les casse encore plus de pas savoir d'où ça vient.
    • [^] # Re: La même

      Posté par  (site Web personnel) . Évalué à 2.

      Pas de problemes de police ici.

      Debian Sid à jours + Kde.
    • [^] # Re: La même

      Posté par  . Évalué à 1.

      Question HS : serait tu l'ancienne baderne du lycée du Parc ?
      • [^] # Re: La même

        Posté par  (site Web personnel) . Évalué à 1.

        C'est qui cette bête là ? En même temps, pas tombé loin, j'ai fait mon lycée à Bron (ça a tout de suite une autre classe je sais ;)
        • [^] # Re: La même

          Posté par  . Évalué à 1.

          C'est une vieille coutume des prépas lettres. Le gars avait le même nom que toi...
  • # moi aussi

    Posté par  . Évalué à 3.

    je sais, c'est pas sympa, mais l'occasion est trop belle.
    Moi aussi parfois mon clavier se blo
  • # pas pour les tapettes..

    Posté par  (site Web personnel) . Évalué à 0.

    ben Debian Unstable, c'est Debian Unstable.

    La première chose à faire est d'aller jeter un oeil dans le BTS. Et si ce genre de trucs t'embêtent, reste en Sarge ou sur Ubuntu.
    • [^] # Re: pas pour les tapettes..

      Posté par  . Évalué à 1.

      Je dois dire que jusqu'ici, j'ai très peu de problèmes en unstable. Je trouve ça très stable dans l'ensemble...
  • # fontes

    Posté par  . Évalué à 2.

    Pour le pb 2), il suffit de remplacer le mot "true" par "false" dans /etc/fonts/local.conf, puis rebooter. Voir http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=277883(...)
    • [^] # Re: fontes

      Posté par  . Évalué à 2.

      dpkg-reconfigure fontconfig

      auto hinter -> no

      pas besoin de rebooter, juste redémarrer les applis laides, voire tout X.
      • [^] # Re: fontes

        Posté par  . Évalué à 1.

        Merci ! Tout marche bien, maintenant.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.