Forum Linux.debian/ubuntu Pas d'image HDMI moniteur externe

Posté par  . Licence CC By‑SA.
1
11
sept.
2020

Bonjour à tous,

J'ai récemment installé la distribution Kali Linux. Tout d'abord voici ma configuration :

CPU : AMD Ryzen 5 avec GPU AMD Radeon Vega 8 Graphics

Carte graphique NVIDIA GTX 1050 3Go

Une fois après avoir installé l'OS, je branche mon câble HDMI sur le port pour connecter mon 2ème écran, et là catastrophe : ça ne marche pas, aucun signal. Reboot, toujours rien. J'ai consulté plusieurs forums dans lesquels était dit d'installer les pilotes propriétaires NVIDIA, ce que j'ai fait. Seuleùment ça ne marchait toujours pas mieux, et donc après pas mal de temps à bidouiller, installer des paquets, j'ai décidé de réinstaller la distribution.

J'ai donc réinstallé la distribution, brancher mon écran,bien évidemment ça ne marchait pas. J'ai trouvé une solution qui marche "vraiment qu'à moitié". En fait quand je connecte mon écran je peux choisir la sortie audio de celui-ci ! Alors qu'avant je ne pouvais pas ! Mais toujours pas d'image.

Ce que j'ai fait jusque là c'est ajouter

idle=nomwait

dans la ligne de commande du GRUB, J'ai également crée un fichier xorg.conf dans lequel j'ai inséré le code suivant :

Section "Device"
    Identifier "Device0"
    Driver "amdgpu"
    BusID "PCI:5:5.0"
EndSection

Voilà ce qui m'a permis de ne plus avoir "no signal" ainsi que la sortie son sur mon 2ème écran. Mais pas d'image.

Je vais vous montrer le retour des différentes commandes :

xrandr

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080    120.00*+  48.00 
   1680x1050    120.00 
   1280x1024    120.00 
   1440x900     120.00 
   1280x800     120.00 
   1280x720     120.00 
   1024x768     120.00 
   800x600      120.00 
   640x480      120.00     

Comme vous pouvez le voir, pas de HDMI detecté

lspci -s 01:0.0 -v

01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 3 GB Max-Q] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. GP107M [GeForce GTX 1050 3 GB Max-Q]
        Flags: bus master, fast devsel, latency 0, IRQ 77, IOMMU group 9
        Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at d0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at f000 [size=128]
        Expansion ROM at f7000000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nouveau
        Kernel modules: nouveau

Voilà, merci d'avance pour vos réponses

Bien cordialement,

Lucas

  • # voir la config de la machine

    Posté par  . Évalué à 3.

    tu as une carte graphique intégrée (AMD RADEON VEGA8)
    tu as une carte additionnelle (Nvidia 1050)

    parfois la machine va désactiver l'une des cartes en fonction des réglages dans le bios avant meme que l'OS ne s'active.

    ton lspci -v indique bien que la carte Nvidia est trouvé, et que le pilote "nouveau" est chargé

    xrandr devrait trouver les 2 cartes et les deux ecrans
    arandr doit te fournir une interface graphique pour configurer cela.

    ta modification du Xorg force l'activation de la carte AMD, et empêche l'activation de la carte NVIDIA, cela ne doit plus etre nécessaire, sauf cas très particulier, ce dont je doute dans le cas present

    • [^] # Re: voir la config de la machine

      Posté par  . Évalué à 1.

      Merci de ta réponse,

      J'ai donc enlevé le contenu du xorg.conf, celà n'a pas résolu mon problème, toujours pas d'image. Il n'est plus possible de configurer la sortie audio vers le 2ème écran.

      Malheuresement dans arandr je n'ai que mon écran de pc portable (Edp), pas de possibilité de configurer l'autre écran.

      Je pense qu'il faudrait trouver un moyen pour activer les deux cartes graphiques car je pense que du coup la carte nvdia n'est pas activée.

      Je vais réflechir à ça

      • [^] # Re: voir la config de la machine

        Posté par  . Évalué à 1. Dernière modification le 15/09/20 à 09:50.

        D'après cette commande qui affiche les drivers chargés, on peut voir qu'il n'y a pas de driver "nouveau"…Peut-être qu'il ne s'active pas. Il faut voir pour le forcer à s'activer peut-être…hypothèse

          grep "drivers" /var/log/Xorg.0.log
            [    52.739] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
            [    52.783] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
            [    52.817] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
            [    52.838] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
            [    52.839] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
        
      • [^] # Re: voir la config de la machine

        Posté par  . Évalué à 2.

        Je pense qu'il faudrait trouver un moyen pour activer les deux cartes graphiques car je pense que du coup la carte nvdia n'est pas activée.

        regarde dans le bios, il est peut-être réglé sur "iGPU" seulement (le ryzen)
        mais ton lspci semble montrer les 2 cartes, et le fait que "nouveau" est chargé.

        lsmod | grep nouveau devrait le confirmer

        si c'est le cas, alors les deux cartes sont activent, et c'est juste X11/Wayland qui ne veut pas gérer du multiécran sur 2 cartes différentes sans faire de manip spéciale

        • [^] # Re: voir la config de la machine

          Posté par  . Évalué à 1. Dernière modification le 12/09/20 à 11:41.

          J'ai regardé sans le bios, je ne vois pas de trace de 'iGPU'

          Je pense en effet que nouveau est chargé car quand je tape lsmod | grep nouveau, j'ai bien un résultat. Donc ça doit certainement être X11/Wayland qui gère pas le multiécran sans faire de manip. Je vais chercher là dessus maintenant.

          Ah j'ai oublié de préciser, quand je démarre linux j'ai ça pendant le chargement…
          Image

          Cependant j'ai un autre problème maintenant, je n'ai rien changé depuis hier, et quand je me connecte à ma session via l'interface graphique, je tape username et mot de passe, eh bien ecran noir puis ça revient sur l'interface de connexion…Et ça a chaque fois que j'essaye de me connecter. Je ne sais pas comment ça se fait.

  • # Edit :solution à moitié

    Posté par  . Évalué à 2.

    Edit : j'ai une solution qui marche à moitié, en fait j'arrive à faire en sorte d'avoir une image sur mon écran externe mais cependant plus d'image sur le pc portable. En fait, c'est soit l'un soit l'autre. Je ferai un script qui me permet de choisir entre les 2 (en fait c'est juste une modif du xorg.conf) puis qui reboot.

    En tout cas merci de ton aide NeoX

    • [^] # Re: Edit :solution à moitié

      Posté par  . Évalué à 3.

      mais cependant plus d'image sur le pc portable.

      voila qui est interessant je ne crois pas avoir vu cette info dans le post initial

      sur les ordi portable, il est possible que la sortie externe ne s'activent qu'avec une combinaison de touche Fn+F1 à F12
      sur la touche, il doit y avoir un symbole d'écran, et permet d'activer la sortie externe, voire les deux en meme temps puis de revenir à l'écran interne seul.

      de plus sur un ordinateur portable avec iGPU + carte externe,
      il faut parfois un interrupteur logiciel (switcheroo, bumblebee) pour forcer l'usage de la carte additionnel qui ne s'active que dans certains cas d'usage

      • [^] # Re: Edit :solution à moitié

        Posté par  . Évalué à 2.

        Pourtant il a évoqué que c'est un portable dans ce commentaire.
        Pas vraiment étonnant qu'il ne trouve pas l'option dans le bios.

        Sinon oui, si une config xorg avec les deux écrans et GPU ne fonctionne pas malgré la présence des deux pilotes, c'est probablement la faute à un interrupteur logiciel et dans ce cas il n'y a pas grand chose à faire.

        • [^] # Re: Edit :solution à moitié

          Posté par  . Évalué à 1.

          Merci pour vos réponses,

          J'essaierai avec les touches fn.
          j'avais aussi essayer de créer un fichier pour "activer" les 2 cartes graphique puis les associer à leur écran, pour "forcer la chose", mais ça n'avait marché. Peut être que je l'avais mal fait.

          J'avais regardé un petit peu bumblebee, mais pas dans les détails. J'avais eu l'impression que ça me semblait assez complexe.

          • [^] # Re: Edit :solution à moitié

            Posté par  . Évalué à 3.

            J'avais regardé un petit peu bumblebee, mais pas dans les détails. J'avais eu l'impression que ça me semblait assez complexe.

            il faut trouver des infos sur la marque/modele de ton ordi pour savoir si c'est 2 cartes distinctes, ou une carte qui remplace l'autre lors des sollicitations 3D

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.