Forum Linux.debian/ubuntu PC portable et Xubuntu - Fermeture de couvercle = Pas possible de déverrouiller

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes :
2
12
jan.
2020

Bonjour à tous.

Je débute avec Xubuntu 19.10 tout neuf (je viens de Windows 10).

Avec mon PC portable (MSI GS75 Sealth 85F), j'ai un problème lors de la mise en veille en fermant le couvercle :

Tout d'abord quand je ferme le couvercle de mon PC portable, mon PC se met bien en veille et l'écran se verrouille bien (afin d'être "protégé" par mot de passe). Je veux ceci, et c'est ce qui est configuré dans mes paramètres.
Mais quand j'ouvre le couvercle de mon PC portable, l'écran se bloque souvent…
Je vois le fond d'écran de mon bureau, je vois mes onglets de ma barre des taches ouverts, je peux bouger la souris, mais je ne peux cliquer nul part… Et l'écran de déverrouillage (pour que je puisse me logger) ne s'affiche même pas…
Pour sortir de cette situation je suis obligé d’appuyer longtemps sur le bouton power afin d'éteindre mon PC et de le rallumer…
Bref, ceci est ennuyant pour un PC de travail.

PS : Si je avec ma souris je vais dans le menu démarrer -> mise en veille. Là je n'ai pas ce problème (c'est ce dont j'ai l'impression pour le moment).

Y a t-il une solution SVP ?

Merci beaucoup.

  • # Bogue du serveur X ou du gestionnaire de verrouillage ?

    Posté par  (site Web personnel) . Évalué à 1.

    Tu peux essayer de basculer vers une console texte avec Ctrl+Alt+Fx, x variant de 1 à 8 disons.

    Si cela ne provoque pas une bascule vers une console texte, c'est probablement que le serveur X est planté (la souris peut continuer à bouger pour autant).

    Si cela provoque une bascule vers une console texte, c'est peut-être que le gestionnaire de verrouillage – voire le système de fenêtrage — est planté. Dans ce cas, on peut parfois s'en sortir en se connectant en console texte, en localisant le processus impliqué et en le terminant manuellement (ps faux|grep lock peut être un bon début). Dans ce cas, bien penser à se déloguer de la console texte une fois le bureau « libéré ».

    Debian Consultant @ DEBAMAX

  • # Presque réslolu

    Posté par  (site Web personnel) . Évalué à 3. Dernière modification le 12/01/20 à 12:51.

    Merci pour ta réponses.

    Du coup après quelques heures de recherche, j'ai fais ceci :
    J'ai ajouté dans /etc/UPower/UPower.conf ceci : IgnoreLid=true
    Puis j'ai redémarré mon PC.
    Et visiblement ça marche (pourvu que ça dure).

    Par contre il me reste un problème :
    Lorsque mon écran est en veille, si je bouge (même légèrement) ma souris, le mode veille disparaît…
    Je souhaiterai pouvoir désactiver ce comportement.
    Comment résoudre ce problème SVP ?

    J'ai testé de faire ceci :
    grep . /sys/bus/usb/devices/*/power/wakeup
    Ce qui me retourne ceci :
    /sys/bus/usb/devices/1-5/power/wakeup:enabled
    /sys/bus/usb/devices/usb1/power/wakeup:disabled
    /sys/bus/usb/devices/usb2/power/wakeup:disabled

    Et quand je regarde le fichier /sys/bus/usb/devices/1-5/power/wakeup effectivement c'est écris enabled (c'est d'ailleurs la seule chose qui est écrite dans ce fichier).

    Et quand je fais ceci (j'ai lu ceci dans quelques sujets en cherchant dans Goole) :
    sudo echo disabled > /sys/bus/usb/devices/1-5/power/wakeup

    J'ai ce retour :
    bash: /sys/bus/usb/devices/1-5/power/wakeup: Permission non accordée

    Une idée SVP ?

    Merci.

    • [^] # Re: Presque réslolu

      Posté par  . Évalué à 1.

      sudo sh -c 'echo disabled > /sys/bus/usb/devices/1-5/power/wakeup'
      
  • # Résolu

    Posté par  (site Web personnel) . Évalué à 5. Dernière modification le 13/01/20 à 08:55.

    Merci.

    J'ai ajouté un script SH que j'appelle dans "Session de démarrage" > "Démarrage automatique d'application" avec le déclencheur "on login".

    Voici mon script sh que s’exécute automatiquement lors du login :

    #!/bin/bash
    
    # Disable wake computer from mouse movement
    for f in /sys/bus/usb/devices/*/power/wakeup
    do
       echo "disabled" > $f
    done

    Ps : il aurait été + logique de mettre le déclencheur "on restart", mais ça ne fonctionnait pas… Donc j'ai mis "on login", et là ça marche nickel.

    Sujet résolu.

    • [^] # Re: Résolu

      Posté par  . Évalué à 3.

      tu es sur que tu débute ? sous linux ? :-D

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.