Forum Linux.debian/ubuntu Problème avec KMS

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
24
oct.
2016

Bonjour à tous,
j'ai, depuis l'achat d'une nouvelle carte graphique (gtx 980), un problème avec ma Debian(testing/stretch) :
Impossible de booter avec la gestion d’affichage KMS activée sur une version du noyau supérieure à la 4.4.0 sans avoir un écran noir. Je suis donc contraint de passer le paramètre 'nomodeset' au noyau dans l''objectif de désactiver KMS, ce qui est assez désagréable au vu de tous les avantages que celui-ci procure.

D'autres personnes ici ont eu un problème similaire ?
Une idée de la procédure à effectuer pour y mettre fin (j'ai déjà fait quelques recherches et essais infructueux) ?

Merci d'avance pour vos réponses.

ps: je ne veux pas installer le pilote proprio ;)
pps: j'ai déjà tenté une réinstallation afin d'écarter des causes probables toute mauvaise configuration de ma part

  • # Re Problème avec KMS

    Posté par  . Évalué à 1.

    Bonjour,

    Le mieux serait d'avoir un dmesg complet pour pouvoir t'aider.

    Tu peux toujours essayer de lancer le KMS après c'est possible suivant la conf de ton noyau

    Référence
    Référence 2

    Example :
    echo 1 > /sys/class/vtconsole/TON_FRAME_BUFFER_DEVICE/bind
    /etc/init.d/consolefont restart

    Mais je le redit le mieux serait d'avoir un dmesg complet pour pouvoir t'aider.

    • [^] # Re: Re Problème avec KMS

      Posté par  . Évalué à 1.

      Merci pour ta réponse.
      Je pense que copier un rapport dmesg complet sur un forum est nocif pour la sécurité de mon système (tu excuseras ma paranoïa).
      J'ai cependant examiné les logs de la manière suivante:
      - J'ai examiné les logs de démarrage du système (noyau 4.4 et 4.7)
      - j'ai copié ces logs dans un fichier
      - j'ai supprimé l'horodatage et les autres parties variables du fichier avec sed
      - j'ai copié les doublons dans un autres fichier avec uniq

      Je n'ai pas rencontré d'erreur significative (juste un problème avec mon clavier)…
      Tu peux toujours me demander de copier certaines parties ciblées de mes logs. Encore désolé….

  • # nvidia, **** ***!

    Posté par  (site Web personnel) . Évalué à 1.

    Alala pourquoi avoir acheté une nvidia :(

    Malheureusement si ça ne fonctionne pas avec je ne vois pas de solution, à part rajouter nomodeset en permanence dans le grub (ou systemd-boot).

    Peut-être tu pourrais tester avec une version plus récente de xf86-video-nouveau ?

    l'azerty est aux dispositions ce que subversion est aux SCMs

    • [^] # Re: nvidia, **** ***!

      Posté par  . Évalué à 1.

      Bah en fait je joue également à des jeux vidéo (c'est mon plaisir coupable en dual-boot ;( ) et les benchmarks penchaient clairement en faveur de nvidia pour cette génération (sans compter les jeux optimisés pour physX etc…).
      De plus je n'ai jamais essayé AMD et ai donc préféré rester dans ma zone de confort (raison alakon)…
      Linus avait raison, je vais sans doute devoir vendre ma carte graphique et acheter chez AMD.

      • [^] # Re: nvidia, **** ***!

        Posté par  . Évalué à 1.

        Sapristi! Je ne peux plus éditer mon message.
        Trois nouvelles versions du kernel me sont interdites…Je suppose qu'il y a eu quelques modifications dans la gestion de KMS et que mettre à jour nouveau (ce que j'ai déjà fait) ne résoudra malheureusement pas le problème (les noyaux futurs comporteront sans doutes cette modification) .

        • [^] # Re: nvidia, **** ***!

          Posté par  . Évalué à 1. Dernière modification le 26/10/16 à 01:17.

          Si tu te restreins aux pilotes libres et que tu veux jouer sur ton linux, il n'y a clairement pas photo entre amd, nvidia et intel, c'est du amd et puis c'est tout :)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.