Forum Linux.debian/ubuntu Problème de son en entrée echo en sortie

Posté par  . Licence CC By‑SA.
0
6
oct.
2014

Bonjour,
j'ai un problème sur un vieux PC sur une debian:
les micro que je branche à chaque fois sur cette machine, font que ce qui est capté au micro est envoyé en sortie audio (sortie son du moniteur). Ce qui est encore particulier c'est que le micro marche (mumble ex), mais le son envoyé en sortie audio n'est pas complet. En effet, il faut tapoter le micro, ou parler vraiment à côté du micro pour que cela fasse echo (le micro n'est pas défectueux, car le micro capte bien tout les sons dans l'environnement - j'en suis sûr grâce à mumble) - et bien sûr j'aimerai que ça ne le fasse pas du tout. Pour que cet 'echo' cesse, je dois couper le micro tout simplement.
Cette machine a comme pilote son : alsa, et en surcouche comme serveur son : pulseaudio. J'ai déjà tenté de supprimer pulseaudio, mais même sans celui ci, l'echo est toujours existant.
Donc j'ai un peut tout tester grâce à l'interface de pavucontrol et alsamixer, et rien n'y fait. Et heureusement que désactiver le 'micro boost', sinon c'était pire…
Merci d'avance.

  • # dans les reglages du mixeur audio

    Posté par  . Évalué à 3.

    il faut desactiver l'ecoute du micro dans le mixeur audio.
    donc il faut aller dans l'onglet de "lecture audio" et virer l'entrée micro (rendre MUTE)
    par contre si tu veux que le micro enregistre, il faut evidemment laisser actif dans l'onglet "enregistrement audio"

    • [^] # Re: dans les reglages du mixeur audio

      Posté par  . Évalué à 1.

      Finalement c'est pas ça. J'avais mute tout les périphériques d'entrées, et ça continuait à me le faire. En tapotant le micro, le son sortait.
      Bref j'ai trouvé par hasard.
      Sur alsamixer, il y a l'option 'Surround Jack Mode' qui était à la valeur : share, je l'ai changé à Independ. Et ça marche, c'est bon. Enfin!

      Merci.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.