Forum Linux.debian/ubuntu Problème écran externe Ubuntu 20.04

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
4
nov.
2020

Bonjour à tous,

J'ai un soucis avec mon ordinateur portable. Celui-ci est sous Ubuntu 20.04, il tourne sans soucis. Cependant j'essaie de connecter un écran externe à mon ordinateur et cela produit une erreur : l'écran se duplique parfaitement lorsque je le connecte à l'ordinateur, mais ensuite l'écran externe freeze totalement.

J'ai testé sur 2 écrans différents, en HDMI et VGA.

Auriez-vous une solution ?

Merci beaucoup !

  • # Nope

    Posté par  . Évalué à 3 (+1/-0).

    Pas vraiment de solution, mais pour approfondir le diagnostique, j'essaierais avec un autre environnement de bureau.

    Aussi, as-tu une carte graphique dédiée, intégrée au CPU ou les deux ? Je suppose que ça peut avoir un impact.

    • [^] # Re: Nope

      Posté par  . Évalué à 1 (+0/-0).

      Bonjour, merci de ta réponse.

      Effectivement j'ai une carte intégrée au cpu et une dédiée :

      NVIDIA Turing GeForce GTX 1650 4 Go GDDR5 dédiés, Intel UHD 630 intégrée au processeur et Optimus.

      Que me suggères-tu ? Merci

      • [^] # Re: Nope

        Posté par  . Évalué à 2 (+0/-0).

        Salut,

        Au vu de la première piste et de tes informations complémentaires, je tenterai :

        • ouvrir un terminal avant de brancher l'écran externe,
        • brancher l'écran,
        • attendre que ça freeze,
        • regarder la fin des logs. Probablement dmesg déjà.

        C'est peut-être un driver qui vient mettre le bazar en se chargeant…

        • [^] # Re: Nope

          Posté par  . Évalué à 1 (+0/-0).

          Merci mais j'avoue que tu me parles un peu chinois là …Peux-tu m'expliquer différemment ? Merci

          • [^] # Re: Nope

            Posté par  . Évalué à 2 (+0/-0).

            Salut,

            j'avoue que tu me parles un peu chinois là

            Ah, euh. Oui, effectivement, j'ai fait court.

            Donc, je suppose que tu sais ouvrir un terminal (sinon, suffit de demander). Et on y va, si j'ai bien compris la situation :

            • avant de brancher l'écran, tu ouvre un terminal (ça peut se faire après, mais peu importe),
            • tu branche ton écran,
            • tu attend que ça freeze,
            • sauf erreur de compréhension, tu peux toujours utiliser l'écran principal, donc dans le terminal ouvert, tu tape sudo dmesg. Et tu copie disons les 10 dernières lignes pour nous les montrer

            Il y a peut-être d'autres fichiers de logs à inspecter, mais en y allant pas à pas…

            • [^] # Re: Nope

              Posté par  . Évalué à 1 (+0/-0).

              Merci beaucoup à toi. Grâce à la réponse de Bruno (juste après), j'ai réussi à résoudre mon soucis, merci beaucoup !

              Une autre question, j'ai un 3eme écran à ma disposition … Y a t-il un moyen de le relier également ? Merci encore.

      • [^] # Re: Nope

        Posté par  (site Web personnel) . Évalué à 2 (+1/-0).

        NVIDIA Turing GeForce GTX 1650 4 Go GDDR5 dédiés, Intel UHD 630 intégrée au processeur et Optimus.

        Est-ce le pilote libre Nouveau ou le pilote propriétaire Nvidia qui est installé ?

        Malheureusement la société Nvidia ne fournit pas de pilotes libres, mais juste un gros BLOB. Ce pilote propriétaire est généralement plus performant et supporte mieux la carte graphique que le pilote libre Nouveau. On peut pas en vouloir aux développeurs de Nouveau qui développent sans documentation et en faisant de la rétro-ingénierie.

        Le pilote propriétaire Nvidia peut être installé en ligne de commande :
        sudo ubuntu-drivers autoinstall

        • [^] # Re: Nope

          Posté par  . Évalué à 3 (+2/-0).

          Mille fois merci : avec " sudo ubuntu-drivers autoinstall" ça a résolu mon soucis !

  • # ça ne marche plus ...

    Posté par  . Évalué à 1 (+0/-0). Dernière modification le 11/01/21 à 11:16.

    Bonjour,

    Depuis ce matin, la connexion a un écran externe ne fonctionne plus, sans raison apparente, je n'ai rien modifié pourtant.

    De même, lorsque j'essaie de faire "sudo apt-get update", j'ai le message suivant:

    "Err :9 http://ppa.launchpad.net/fingerprint/fprint/ubuntu focal Release
    404 Not Found [IP : 91.189.95.85 80]
    Lecture des listes de paquets… Fait

    E: Le dépôt http://ppa.launchpad.net/fingerprint/fprint/ubuntu focal Release n'a pas de fichier Release.
    N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
    N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
    "

    Pourriez-vous m'aider ? Merci beaucoup

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.