Forum Linux.debian/ubuntu UPS (AC) usb non reconnu

Posté par .
Tags : aucun
0
9
juin
2007
Bonjour,

J'ai connecté un UPS (APC) sur ma debian 2.6.8-2-386 en USB, mais il n'est pas reconnu par le système.

lsusb donne :


Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000


et cat /proc/bus/usb/devices donne :


T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 4
B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 2.06
S: Manufacturer=Linux 2.6.8-2-386 ehci_hcd
S: Product=Intel Corp. 6300ESB USB2 Enhanced Host Controller
S: SerialNumber=0000:00:1d.7
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=256ms

T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 2.06
S: Manufacturer=Linux 2.6.8-2-386 uhci_hcd
S: Product=Intel Corp. 6300ESB USB Universal Host Controller
S: SerialNumber=0000:00:1d.1
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 2.06
S: Manufacturer=Linux 2.6.8-2-386 uhci_hcd
S: Product=Intel Corp. 6300ESB USB Universal Host Controller
S: SerialNumber=0000:00:1d.0
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms


voilà les erreurs (dmesg | grep 'usb') :


usb 2-1: control timeout on ep0out
usb 2-1: device not accepting address 3, error -110
usb usb3: USB disconnect, address 1
usb 2-1: new low speed USB device using address 4
usb 2-1: control timeout on ep0out
usb 2-1: control timeout on ep0out
usb 2-1: device not accepting address 4, error -110
usb 2-1: new low speed USB device using address 5
usb 2-1: control timeout on ep0out
usb 2-1: control timeout on ep0out
usb 2-1: device not accepting address 5, error -110
usb usb3: USB disconnect, address 1


Si je branche une clé USB, ça marche très bien. Mais rien à faire avec un UPC (qui marche très bien en USB par ailleurs).

Une idée?? Merci
  • # .

    Posté par . Évalué à 1.

    Me demandant ce qu'etait un UPS j'ai decouvert ça :
    http://linux.developpez.com/cours/upsusb/

    A premiere vue il faut charger le module usbhid qui n'est pas charger par defaut :

    modprobe usbhid
  • # http://www.apcupsd.org/

    Posté par . Évalué à 1.

    Pour tout ce qui concerne la gestion des onduleurs APC, ça se pas là :
    http://www.apcupsd.org/

    Les explications sont extrêmement claires et le logiciel fonctionne très bien.
    • [^] # Re: http://www.apcupsd.org/

      Posté par . Évalué à 1.

      Héhé, merci pour vos réponses... mais tout ça était déjà fait (mon but étant biensûr d'installer apcupsd).

      Dans toute l'aide, notamment sur l'USB. Il me reste à appliquer un patch qui est proposé (linux-2.6.0-USB-queue-overflow.patch), mais je ne suis pas sûr que cela me concerne (j'ai un 2.6.8) et je ne sais pas comment l'appliquer...

      Vous pouvez me dire ce que vous en pensez ?

      merci

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.