Forum Linux.debian/ubuntu virgule avec pavé numérique : lancement de la configuration

Posté par  (site Web personnel) . Licence CC By‑SA.
4
29
mar.
2021

Salut,
Quand on utilise le pavé numérique en standard le caractère . génère un point : même si cela peut paraître logique, cela ne l'est pas quand on l'utilise en Français. Le séparateur décimal est la virgule (et non pas le point) en Français.
C'est particulièrement pénible dans un tableur (comme dans LibreOffice) quand on tape de nombreux chiffres à décimale (la Calculatrice a "l'intelligence" de prendre aussi bien le point que la virgule comme séparateur décimal).
J'ai vu différents posts sur internet indiquant qu'on pouvait modifier des préférences de LibreOffice pour obtenir une virgule … mais cela ne fonctionne pas pour moi (LibreOffice+Ubuntu).

J'ai trouvé un moyen d'obtenir la virgule depuis un moment : avec la commande xmodmap -e 'keycode 91 = KP_Delete KP_Decimal' .

Cependant, je coince pour lancer cette commande automatiquement :

  • Je l'ai mise dans le fichier .profile : cela ne fait rien ? ! ?
  • je l'ai mise dans le fichier .bashrc : cela ne fonctionne que si je lance LibreOffice depuis un terminal (pas top)
  • j'ai créé un fichier 46x11-xmodmap_pave_numerique (contenant la fameuse commande) dans le répertoire /etc/X11/Xsession.d/ : cela ne fait rien !

Si quelqu'un a une solution, je suis preneur !

  • # agencement

    Posté par  . Évalué à 5.

    Il y a au moins un agencement pour le français dans lequel le point du pavé numérique est bien interprété comme une virgule. N'ayant pas de pavé numérique sur mon portable, je ne sais plus lequel c'est.

    C'est vraiment un boulet qu'on traîne depuis des décennies cette histoire, et quoi qu'on fasse, il y a toujours des utilisateurs pour réclamer la solution inverse. Beaucoup de gens se sont habitués depuis les débuts du traitement de texte à utiliser le point du pavé numérique pour saisir le point de fin de phrase parce que cela leur évite d'appuyer sur la touche Shift avec la main gauche.

    • [^] # Re: agencement

      Posté par  (site Web personnel) . Évalué à 2.

      C'est aussi un héritage de Microsoft qui implémente la virgule dans Excel mais pas dans Word … donc beaucoup voudrait conserver ceci en passant sur Linux ! :(

      Mais bon ma question n'est pas celle-ci.

      Je vais ré-essayer les agencements de clavier mais à l'époque cela n'avait pas fonctionné. Merci pour le rappel (sans piqûre) ! ;-)

    • [^] # Re: agencement

      Posté par  . Évalué à 4.

      Je suis sous Ubuntu 20.04.2 LTS et Gnome 3.36.8.
      Effectivement sous LibreOffice, je n'arrivais pas à faire reconnaître la touche point du pavé numérique comme une virgule.
      J'ai finalement trouvé qu'il fallait changer l'agencement de clavier dans les préférences de Gnome (dans "Pays et Langue" puis "source de saisie").
      J'avais l'agencement "Français (variante)" que j'ai remplacé par "Français". Et là, cette fameuse touche a bien été reconnue comme une virgule dans libreOffice Calc. Dans le reste des logiciels, c'est un point.

      • [^] # Re: agencement

        Posté par  (site Web personnel) . Évalué à 2.

        Ah moi aussi je suis en agencement "Français (variante)" … je comprends pourquoi ça ne fonctionnait pas maintenant.
        Ceci étant, je ne veux pas changer d'agencement car c'est un choix délibéré.
        Mais ça fonctionne maintenant.

  • # ~/.Xmodmap

    Posté par  . Évalué à 5. Dernière modification le 29/03/21 à 12:07.

    Bonjour

    Les lignes de commande(s) contenues dans le fichier ~/.bashrc
    ne seront exécutées que quand tu ouvriras une fenêtre de terminal.

    Tout dépend de l'environnement de bureau que tu utilises :
    Si tu utilises Xfce, il suffit de renommer ton fichier 46x11-xmodmap_pave_numerique en ~/.Xmodmap
    et il sera pris en compte à l'ouverture de ta session.

    Sinon, il faudra en plus créer un fichier nommé ~/.config/autostart/mavirgule.desktop
    dans lequel tu mettras :

    [Desktop Entry]
    Name=pour ma Virgule sur le pavé numérique
    GenericName=pour Ma Virgule
    Comment=pour lancer xmodmap ~/.Xmodmap
    Exec=xmopdmap $HOME/.Xmodmap
    Terminal=false
    Type=Application
    X-GNOME-Autostart-enabled=true
    Hidden=true
    
    • [^] # Re: ~/.Xmodmap

      Posté par  . Évalué à 4. Dernière modification le 29/03/21 à 12:13.

      Précision :

      Dans le fichier ~/.Xmodmap
      tu mettras seulement :

      keycode 91 = KP_Delete KP_Decimal
      
  • # Bépo

    Posté par  (site Web personnel) . Évalué à 3. Dernière modification le 29/03/21 à 17:04.

    Pour info, la virgule est en "niveau 3" sur le point du pavé numérique.
    On peut donc la rentrer avec Alt-gr+. (du pavé numérique).
    (Ou n'importe quel sélecteur de niveau 3).

    Sous gnome, avec "Ajustement" (ou "Tweak tools" en anglais), il est possible de changer ce comportement (le sélecteur de niveau 3 et le placement de la virgule sur le niveau 3), sans aller toucher au fichier de config.

    Testé avec la disposition bépo (latin-9 only) et français (variante).

    Matthieu Gautier|irc:starmad

  • # Déjà prévu dans Xkb

    Posté par  (site Web personnel) . Évalué à 5. Dernière modification le 29/03/21 à 18:41.

    Parmi les nombreuses options de Xkb¹ dont malheureusement les environnements graphiques ne proposent qu’une petite partie, il y en a une qui fait ce que tu veux. En ligne de commande :

    setxkbmap -option kpdl:kposs

    Évidemment, il reste la nécessité de lancer cette commande à l’ouverture de session²… à moins de configurer l’environnement graphique pour conserver le réglage clavier du système³ et de configurer le clavier dans /etc/X11/xorg.conf.d.

    En créant dans ce répertoire par exemple un fichier nommé 90-keyboard_layout.conf contenant :

    Section "InputClass"
        Identifier      "Clavier Azerty"
        MatchIsKeyboard "True"
        Option          "XkbLayout"  "fr"
        Option          "XkbVariant" "oss"
        Option          "XkbOptions" "kpdl:kposs"
    EndSection
    

    1. Pour avoir l’ensemble des options proposées par Xkb : man xkeyboard-config (puis /kpdl pour voir les possibilités concernant la touche point du pavé numérique).
      Les définitions des touches se trouvent dans /usr/share/X11/xkb/symbols (et plus précisément concernant les options de cette touche dans /usr/share/X11/xkb/symbols/kpdl).

    2. Certains environnements graphiques lancent le fichier .xprofile à l’ouverture de session et pour les autres, il faut chercher une autre solution.

    3. Il y a les environnements graphiques arrangeants et il y a Gnome, pour lequel je n’ai trouvé comme solution que de remplacer l’exécutable de son service de configuration du clavier par un lien vers /bin/true (ça fait un certain temps et je n’ai pas vérifié si ça a évolué)…

    Prendre une bonne disposition : beop.free.fr

    • [^] # Re: Déjà prévu dans Xkb

      Posté par  (site Web personnel) . Évalué à 2.

      Il est possible de modifier les options XKB dans GNOME, mais ça demande quelques clics de plus que les paramètres (en direct ou via gnome-tweaks).

      Via dconf (e.g. via l'interface graphique dconf-editor) → org.gnome.desktop.input-sources.xkb-options

      Ici, en étant configuré en fr/oss, j'ai cette liste de une option par défault, que je peux faire évoluer à ma guise : ['lv3:ralt_switch']

      Debian Consultant @ DEBAMAX

  • # OK

    Posté par  (site Web personnel) . Évalué à 1.

    Ça fonctionne maintenant : pourquoi ? Je n'en suis pas vraiment sûr.

    Je suspecte que mes essais de changement d'agencement de clavier (suggéré par JB F) ont débloqué quelque chose.
    Pourtant, j'ai toujours "Français (variante)" comme agencement de clavier, mais maintenant j'ai la virgule dans LibreOffice et le point partout ailleurs : j'aurai été content avec la virgule partout, mais comme ça, c'est bon aussi.

    Ça reste encore très mystérieux, mais bon ça fonctionne … jusqu'à mon prochain changement d'OS! ;)

    Au fait, je tourne avec Budgie 20.04 !

    Merci à tous et bon week-end Pascal.

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.