Forum Linux.débutant carte reseau qui passe de eth1 a eth2 de temps en temps

Posté par .
Tags : aucun
0
1
mai
2006
je ne comprends pas pourquoi mais ma carte reseau wifi passe de eth1 a eth2 de temps en temps, resultat je doit modifier mes parametres reseau et redemarrer c'est ultra-chiant:

ma carte est une :Intel® PRO/Wireless 2200BG sous debian 2.6.15-1-686

voici mon /etc/network/interfaces:

# The loopback network interface
auto lo
iface lo inet loopback

# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping eth2
script grep
map eth2

# The primary network interface
allow-hotplug eth2
iface eth2 inet static
address 192.168.0.103
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.254
wireless-key ###########################
wireless-essid Mon_reseau
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 212.27.32.5

adrien@X31:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

eth2 IEEE 802.11b ESSID:"Mon_reseau"
Mode:Managed Frequency:2.462 GHz Access Point: 00:07:CB:50:A7:E1
Bit Rate=11 Mb/s Tx-Power=20 dBm
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:0123-4567-8998-7654-3210-0123-45 Security mode:open
Power Management:off
Link Quality=86/100 Signal level=-44 dBm Noise level=-86 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:10

sit0 no wireless extensions.

je ne comprends pas pourquoi !!!
Y-a-t-il un truc qui m'echappe ?

aswat
  • # udev

    Posté par . Évalué à 4.

    Le problème est udev. Les interfaces n'ont plus la garantie d'avoir le même nom d'un démarrage à l'autre. Il faut configurer udev pour qu'il attibue un nom stable pour chaque interface.
    • [^] # Re: udev

      Posté par . Évalué à 1.

      /etc/iftab et man iftab sont tes amis
      ;)
  • # Redémarrer ?

    Posté par (page perso) . Évalué à 1.

    Sais-tu que tu n'est pas obligé de redémarrer pour ça ... si tu veux dire "redémarrer" mon interface ok mais si tu veux dire redémarrer mon laptop, lis la suite.

    Si tes interfaces sont "bien" configurées (je veux dire avec les paramètres qui vont bien), tu pourras faire u truc du genre :

    ifdown eth2 ; ifup eth1=wifi


    Pour ce faire modifie ton fichier interfaces

    ...
    allow-hotplug eth2=wifi
    iface wifi inet static
    ...


    Je sais que ce n'est pas complet comme réponse mais ça te permet de ne pas redémarrer ...

    PiT qui n'aime pas voir que l'on redémarre inutilement un PC :-)
    • [^] # Re: Redémarrer ?

      Posté par . Évalué à 1.

      merci PIT pour ta remarque, en effet je parlais bien de redemarrer le laptop, meme si je me doutais qu'il etait possible de redemarer juste la carte reseau ;)

      j'ai dejas les lignes:

      allow-hotplug eth1
      iface eth1 inet static

      mais si je fait ifdown eth2 ; ifup eth1=wifi
      en gros ca ve dire que je ferme eth2 que je lance eth1, mais pourquoi ton eth1=wifi ?
      tu veus dire que je fais ma config pour eth2=wifi, en d'autres thermes wifi est un alias de eth2 et si au demarrage la carte a basculée de eth2 a eth1, alors je saisie :

      ifdown eth2 ; ifup eth1=wifi pour que eth1 prenne les parametres de wifi, ie les anciens parametres de eth2 .......

      j'espere avoir compris ce que tu voulais dire.....

      Si je modifie mon fichier interfaces comme tu me le sugere, comment faire pour que KWifiManager prenne en compte mes modifes ? Je doit mettre wifi et non (eth1 ou eth2) dans
      Configuration/Editer La Configuration

      je coche Interface: detection automatique ?


      Pour "finir", serait-il possible de suprimer definitivement eth1 ou eth2, bref la carte ethernet qui n'en ais pas une du systeme, ca devrais aussi eviter les embiguitées non ? Ca ce fait ? Je me demande si il ne s'agit pas de mon port firewire qu'il avait detecte comme ca lors de l'installe de debian, tu en pense quoi ?

      merci pour votre aide

      aswat
      • [^] # Re: Redémarrer ?

        Posté par . Évalué à 1.

        j'ai modifié le fichier /interfaces en

        allow-hotplug eth1=wifi
        iface wifi inet static,

        du coup le wifi ne ce lance plus au demarrage, mais au moins,
        quand je fait :

        sudo ifup eth1=wifi ca marche du premier coup ! il y a pas moyen d'automatiser tout ca ?(je sais que c'est faisable, mais je ne sais pas le faire ;) )

        aswat

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.