Forum Linux.débutant J'ai besoin d'aide pour installer debian avec les drivers de ma CG

Posté par . Licence CC by-sa.
Tags : aucun
0
10
oct.
2015

Bonjour tout le monde,

J'ai besoin d'installer une distribution UNIX pour la fac. j'ai décidé d'installer le dernier debian.

Je souhaite l'installer en dual boot avec windows, j'ai préparé mes partition et je sais l'installer.

Mon problème c'est que je n'arrive pas du tout a installer les drivers pour ma carte graphique, au mieux je perd toute interface graphique au pire je détruis mon OS.

J'aimerais tout reprendre depuis le début avec quelqu'un capable de m'aider a le faire.
J'ai une Nvidia Geforce GTX 980.

J'ai un autre problème moins important, ma souris ne fonctionne pas bien non plus.
C'est une RAT 7 de mad catz. (mais je pense pouvoir régler le problème tout seul).

Merci d'avance.

(PS : Je ne suis pas totalement débutant non plus, et je suis capable d'utiliser un shell)

  • # Oups

    Posté par (page perso) . Évalué à 2.

    Je n'ai pas encore réussi à faire fonctionner correctement la Nvidia Geforce GTX 980. Mais si tu y arrives, ça m'intéresse. Donc peut-être : essayer de récupérer les drivers proprio de Nvidia ici http://www.nvidia.fr/Download/index.aspx?lang=fr et essayer d'installer le fichier téléchargé (c'est un .run normalement)

    • [^] # Re: Oups

      Posté par . Évalué à 2.

      J'ai réussi à faire fonctionner une GTX 980 sur une Debian Jessie GNOME pas plus tard que hier ! Ca juste marche de base avec le pilote "nouveau" et une fresh install GNOME. J'ai ensuite tenté avec le driver proprio depuis le dépôt experimental: ok aussi (à mon grand étonnement)! La seule chose que j'ai eu à faire est de rajouter le user "Debian-gdm" au groupe "video" sinon GDM plante au démarrage (et pas de façon très clair en plus). Après je n'ai pas fait de test pour pousser la carte dans ces retranchements en lançant des jeux sous Steam ou équivalent. Ca n'a été tout au plus que lire des vidéao en 1080p pour l'instant.

      Pour info j'ai l'UEFI d'activé, je ne sais pas si ça peut jouer ou pas, puisque j' n'ai pas essayer de la désactiver pour voir si ça foire plus avec nouveau ou le driver proprio. Je vais tenter de conserver une double conf, pour switcher au démarrage sur nouveau ou nvidia, pour comparer les bugs/perfos le plus souvent possible.

      Prochaine étape essayer d'utiliser ses capacités OpenCL avec DarkTable, pour accélerer le développement de mes raws.

  • # Version ?

    Posté par . Évalué à 2. Dernière modification le 10/10/15 à 20:52.

    Quelle version de Debian ?

    Pour Jessie, je ne voit pas de meilleures explications que celle du Wiki https://wiki.debian.org/fr/NvidiaGraphicsDrivers et https://wiki.debian.org/fr/DebianExperimental

    En gros ajouter au fichier /etc/apt/sources.list la ligne suivante :
    deb http://ftp.debian.org/debian experimental main contrib non-free

    Ensuite exécuter les commandes :

    apt-get update
    apt-get -t experimental install nvidia-driver
    • [^] # Re: Version ?

      Posté par . Évalué à 1.

      La dernière sortie ; La 8.2, donc je crois que c'est bien Jessie.

      J'vais essayer ça, je réinstalle tout du début parce que je l'avais explosé sur le dernier fofo que j'avais suivi.

      Je reviens d'ici une heure si ça marche pas je pense '

    • [^] # Re: Version ?

      Posté par . Évalué à 1.

      Me revoilà, j'ai fait comme demandé (je pense).
      J'ai planté a la dernière commande :

      http://puu.sh/kFtzS/fcf4ef13a6.png
      à gauche l'erreur | a droite mon sources.list

      • [^] # Re: Version ?

        Posté par . Évalué à 2.

        Pas sur, mais ça doit être le -t experimental qui se propage pas aux dépendances, essaye rajoutant tout ces paquets à la ligne de commande.

        • [^] # Re: Version ?

          Posté par . Évalué à 1.

          Je fait ça comment ?
          (désolé j'suis pas très bon ')

          • [^] # Re: Version ?

            Posté par . Évalué à 2.

            apt-get -t experimental install nvidia-driver nvidia-kernel-dkms libgl1-nvidia-glx libgl1-nvidia nvidia-driver-bin xserver-xorg-video-nvidia nvidia-vdpau-driver nvidia-alternative nvidia-support nvidia-installer-cleanup nvidia-settings libgl1-nvidia-glx-i386 libgles1-nvidia libgles2-nvidia

            J'ai copié à la main, y'a peut-être des erreurs.

            Pour rendre ça permanent regarde la section APT Pinning du lien que j'ai donné dans mon premier post.

            • [^] # Re: Version ?

              Posté par . Évalué à 2.

              EDIT: Pour moins de dépendances tu peux tenter une installation minimale puis rajouter nvidia-settings et l'acceleration vidéo qu'au besoin : apt-get --no-install-recommends -t experimental install nvidia-kernel-dkms libgl1-nvidia-glx xserver-xorg-video-nvidia nvidia-alternative

              Et y'a certain paquets qui sont dans stable donc faut rajouter contrib non-free aux autres ligne de ton /etc/apt/sources.list

              • [^] # Re: Version ?

                Posté par . Évalué à 1.

                La seconde solution ne marche pas.
                La troisième non plus.
                Mais après avoir rajouté les contrib non-free dans les sources la première solution fonctionne.
                On le dit de configurer xorg puis de reboot, ne sachant pas comment faire j'ai d'abord essayé
                sudo nvidia-xconfig
                Que j'ai trouvé la http://doc.ubuntu-fr.org/xorg
                J'ai eu une erreur me disant que la commande n'existait pas
                Donc je l'ai fait avec
                sudo dpkg-reconfigure -phigh xserver-xorg
                La il n'y a pas d'erreur mais quand je reboot l'interface plante et met juste une fenêtre avec écrit 'an error as occured try to logout'

                • [^] # Re: Version ?

                  Posté par . Évalué à 2.

                  Ça le fait au lancement du serveur graphique ou après l'écran de connexion ?

                  Y'a des erreurs dans les logs (/var/log/Xorg.0.log) ?

                  • [^] # Re: Version ?

                    Posté par . Évalué à 1.

                    Aw j'avais pas vu ce message désolé '

                    Là je saurais pas trop comment expliquer.
                    J'ai repris du début en essayant la solution

                    EDIT: Pour moins de dépendances tu peux tenter une installation minimale puis rajouter nvidia-settings et l'acceleration vidéo qu'au besoin : apt-get --no-install-recommends -t experimental install nvidia-kernel-dkms libgl1-nvidia-glx xserver-xorg-video-nvidia nvidia-alternative

                    j'ai reboot et ça a marché.
                    J'ai rereboot et ça marchais plus et j'avais de nouveau un plantage au démarrage.

                    Et je pense que ça viens du serveur graphique puisque je ne vois pas l'écran de connexion.

                    Sinon pour les log,

                    Quand ça avait l'air de fonctionner je l'avais quand même récupéré au cas ou que ça replante :
                    http://puu.sh/kGfd5/e93a4ff104.txt

                    Et une fois que c'étais planté ça m'a donné ça :
                    http://puu.sh/kGfdR/820d3e6411.txt

                    • [^] # Re: Version ?

                      Posté par . Évalué à 2.

                      Dans le deuxième il essaye de charger le pilote nouveau, pas nvidia.

                      Essaye de créer un fichier /etc/X11/xorg.conf.d/99-device.conf avec ce contenu :

                      Section "Device"
                          Identifier "nVidia GTX260+"
                          Driver "nvidia"
                      EndSection
                      
                      Section "Module"
                          Disable "nouveau"
                      EndSection
                      
                      • [^] # Re: Version ?

                        Posté par . Évalué à 1.

                        Ce chemin :

                        /etc/X11/xorg.conf.d/
                        N'existe pas.

                        Sur internet j'ai trouvé celui ci ;

                        /usr/share/X11/xorg.conf.d

                        Où j'ai créé le fichier 99-device.conf avec le contenu que tu m'as dit de mettre.

                        Maintenant ça boot sans interface.

                        J'ai essayé de faire startx puis j'ai eu 4 nouveau log, je ne sais pas trop si c'est utile mais les voilà ;
                        http://puu.sh/kGgZO/5a5c193190.log
                        http://puu.sh/kGh0Y/f3f1c677f3.log
                        http://puu.sh/kGh1l/03b8855091.log
                        http://puu.sh/kGh2c/d9a977a22e.log

                        (a moins que d'avoir loupé un truc il me semble que c'est sensiblement les mêmes ')

                        • [^] # Re: Version ?

                          Posté par . Évalué à 2.

                          Si le dossier /etc/X11/xorg.conf.d/ n'existe pas il faut le créer.

                          Sinon il se plain d'une erreur de syntaxe dans le fichier que tu a crée :

                          Parse error on line 8 of section Module in file /usr/share/X11/xorg.conf.d/99-device.conf
                          The Disable keyword requires a quoted string to follow it.

                          • [^] # Re: Version ?

                            Posté par . Évalué à 1.

                            Désolé j'étais entrain de travailler.

                            J'vais essayer ça tout de suite et du coup a la volée je supprime celui que j'avais créé.

                          • [^] # Re: Version ?

                            Posté par . Évalué à 1.

                            Maintenant je boot avec la même erreur qu'avant, mais lorsque je fait startx ça fonctionne.

                            J'ai fait trois fois le test, à chaque fois j'ai le même plantage qu'avant ;

                            an error as occured try to logout

                            Et je suis allé voir dans les log, lors de ma dernière session j'étais arrivé au Xorg.5.log et là il n'y en a pas de nouveau, c'est normal ?

                            • [^] # Re: Version ?

                              Posté par . Évalué à 2.

                              Le numéro correspond au port du serveur X, il s'incrémente quand on lance manuellement plusieurs fois startx par exemple.

                              Les logs du premier serveur lancé au démarrage doivent toujour être dans Xorg.0.log

                              Pour l’erreur elle apparaît avant ou après l'écran de login ?

                              • [^] # Re: Version ?

                                Posté par . Évalué à 1.

                                Elle apparait avant.
                                A priori il n'ya pas d'erreur dans Xorg.0.log

                                • [^] # Re: Version ?

                                  Posté par . Évalué à 2.

                                  C'est donc un plantage de l’environnement de bureau, Gnome ?

                                  Les logs doivent être accessibles via journalctl --boot _UID=1000 remplace 100 par l'UID de l’utilisateur sous lequel tu essaye d'ouvrir une session.

                                  • [^] # Re: Version ?

                                    Posté par . Évalué à 1.

                                    Je ne saurais pas dire ce qui plante.

                                    J'ai rm tous les Xorg.*.log

                                    Quand je fais startx je n'ai pas d'erreur.

                                    Et demain je verrais quand je démarre pour la première fois le log qu'il va m'ajouter, je te l'enverrais.

                                    (merci déjà pour toute l'aide, maintenant ça marche suffisement pour pouvoir travailler, je ne peux pas installer skype je ne sais pas pourquoi mais ça devrais pouvoir s'arranger et j'ai réussi a faire marcher ma souris)

                                    • [^] # Re: Version ?

                                      Posté par . Évalué à 2.

                                      Je sait que c'est l’environnement de bureau qui plante, je demande si c'est Gnome.

                                      Déjà un truc a voir, ton utilisateur est bien dans le groupe video ? C'est nécessaire avec les drivers nvidia.

                                      • [^] # Re: Version ?

                                        Posté par . Évalué à 1.

                                        Et le user "Debian-gdm" aussi !

                                      • [^] # Re: Version ?

                                        Posté par . Évalué à 1.

                                        La je ne suis pas chez moi, je verrais en rentrant.

                                        Mais déjà je fait comment pour recuperer l'uid ddd'un utilisateur, et pour savoir s'il est dans le groupe vidéo.

                                        Et pour savoir si c'est GNOME qui plante ça se verra sur les log non ?
                                        Ou je dois faire un truc ?

                                        • [^] # Re: Version ?

                                          Posté par . Évalué à 2.

                                          • Pour récupérer l'id d'un utilisateur id -u <nom de l'utilisateur>

                                          • Pour lister les groupes d'un utilisateur : groups <nom de l'utilisateur>

                                          • Pour ajouter un utilisateur à un groupe (en root) : usermod -a -G video <nom de l'utilisateur>

                                          • [^] # Re: Version ?

                                            Posté par . Évalué à 1.

                                            Sur mon debian y a un seul utilisateur en plus du root, et il est dans el groupe vidéo ;

                                            root@irevoire:/var/log# groups irevoire
                                            irevoire : irevoire cdrom floppy audio dip video plugdev netdev lpadmin scanner bluetooth

                                            Par contre le root n'y est pas, je pense que c'est normal mais bon ;

                                            root@irevoire:/var/log# groups root
                                            root : root

                                          • [^] # Re: Version ?

                                            Posté par . Évalué à 2.

                                            En essayant d'installer skype je me suis rendu compte qu'en fait il me manquait des lib graphiques.

                                            c'est probablement dû au fait que j'avais installé la version minimale.

                                            Et puis dans ma grande intelligence j'ai fait un

                                            chmod -R 777 /
                                            "pour voir"

                                            ça lui a pas vraiment plus et c'est bourré d'erreur a chaque fois que je doit faire un sudo maintenant.

                                            Donc j'vais reprendre sur une base plus saine avec la première méthode que tu m'avais donné, et en faisant tout bien dans l'ordre, avec de la chance j'aurais plus le problème.

                                          • [^] # Re: Version ?

                                            Posté par . Évalué à 1.

                                            J'ai tout réinstallé bien comme il faut, j'ai toujours le même problème avec skype.

                                            Il me dit qu'il manque libgl.so.1 , je pensais qu'en reprenant une installation complête de mes drivers il y serait.

                                            Et il démarre toujours en plantant, mais quand il est lent et qu'il n'a pas encore commencé a voir l'interface se charger j'ai le temps de voir qu'il me demande mon login (dans un shell du coup), puis ça disparait et il plante.
                                            je ne sais pas trop si ça peut aider

                                            • [^] # Re: Version ?

                                              Posté par . Évalué à 2.

                                              Tu a ajouté l’user Debian-gdm au groupe vidéo ?

                                              Les derniers logs peuvent être instructifs, tapes journalctl --boot --no-pager juste après le plantage.

                                              Pour skype, ça doit être une application 32bits, il nécessite donc la version 32bits de la libgl, essayes :

                                              dpkg --add-architecture i386
                                              apt-get update
                                              apt-get --no-install-recommends -t experimental install libgl1-nvidia-glx:i386
                                              
    • [^] # Re: Version ?

      Posté par (page perso) . Évalué à 3. Dernière modification le 11/10/15 à 09:30.

      Mais pourquoi lui proposer le dépôt experimental puisqu'il est sous Jessie ?

      Je rajouterai cette ligne à la place de celle proposée :

      deb http://ftp.debian.org/debian jessie main contrib non-free

      Comme ça, il n'y aura pas de problèmes de dépendances entre les paquets experimental et ceux de Jessie (comme "experimental" n'est pas une distribution complète, il manque certains paquets qui sont sûrement disponible dans unstable ou testing).

      Ensuite, il faut exécuter

      apt-get install nvidia-driver
      

      PS: Pour info, les mots de cette ligne signifient:

      • deb : la source contient des paquets pré-compilés (si la valeur est deb-src, ce sera des sources à compiler)
      • http://ftp.debian.org/debian : l'url où aller chercher les paquets
      • jessie : la version de Debian à utiliser : un nom de version particulier (comme "Jessie") ou alors les noms génériques "stable", "testing", "unstable" ou "experimental"
      • main contrib non-free : ça permet de filtrer les licences des paquets: main ne contient que du libre, contrib contient des paquets libre en soit mais qui ne sont inutilisables sans une partie non-libre (par exemple le paquet flash est libre, mais il doit télécharger le binaire non-libre sur le site d'adobe) et non-free les paquets non-libres.
      • [^] # Re: Version ?

        Posté par . Évalué à 3. Dernière modification le 11/10/15 à 12:06.

        Mais pourquoi lui proposer le dépôt experimental puisqu'il est sous Jessie ?

        Parce-qu'il à une GTX serie 900, supportée uniquement par les derniers pilotes. Ceux de Jessie sont trop vieux.

        S'il avait une une carte plus ancienne, il n'aurait même pas besoin d'installer les pilotes nVidia, elles marchent très bien avec nouveau.

        • [^] # Re: Version ?

          Posté par . Évalué à 1.

          Du coup je fais quoi maintenant ?

          En attendant je vais de nouveau réinstaller Jessie et réessayer la troisième solution que tu à proposé.

          Et je me demandais pourquoi ne pas utiliser le .run qu'nvidia fournit ?

          • [^] # Re: Version ?

            Posté par . Évalué à 2.

            Du coup je fais quoi maintenant ?
            En attendant je vais de nouveau réinstaller Jessie et réessayer la troisième solution que tu à proposé.

            Installer ubuntu qui detectera qu'il faut des pilotes proprietaires et les installera et configurera pour toi.

          • [^] # Re: Version ?

            Posté par . Évalué à 2.

            La version des pilotes d’expérimental est assez récente, elle.

            J'ai répondu plus haut, faut voir les logs pour identifier le problème.

  • # Ubuntu ou virtualbox

    Posté par (page perso) . Évalué à 2.

    Si tu as autant de mal avec Debian, ça risque de te dégoûter de Linux.

    Installe la dernière Ubuntu, tu verras, c'est 14 fois + simple.

    Et si tu veux vraiment une Debian, installe la dans ton Windows via une machine virtuelle Virtualbox ou autre.

    Le matériel virtualisé est beaucoup mieux supporté avec Debian, car bougeant peu.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.