Forum Linux.débutant probleme montage dd externe

Posté par .
Tags : aucun
0
26
mai
2005
bonjour,
j'ai "récupéré" un DD externe usb2 et je n'arrive pas à le monter. j'ai fedora2 usb1. Normalement je monte les cles usb sans probleme.
Je ne connais pas le type du DD (fat,ntfs...), et j'ai essayé:
[root@localhost /]# mount -t vfat /dev/sda1 /mnt/externe
mount: type de sys. de fichiers erroné, option erronée, super bloc erroné sur /dev/sda1,
ou trop de systèmes de fichiers montés

comment faire??
  • # Infos supplémentaires

    Posté par (page perso) . Évalué à 1.

    Tu peux essayer de taper dmesg après mount, pour avoir les messages du kernel. Tu peux aussi lancer fdisk -l /dev/sda en root, pour avoir des infos sur tes partitions (savoir laquelle monter).
  • # /proc/partitions

    Posté par (page perso) . Évalué à 1.

    essaye un cat /proc/partitions (c'est a dire tape cette commande dans une console, cela affiche le contenu d'un pseudo-fichier (donc en fait demande au kernel de renvoyer certaines informations) qui contient la liste des partitions actuellement detectees par le kernel). Ton disque dur USB doit apparaitre comme un disque SCSI, contenant une ou plusieurs partitions (si il n'en contient qu'une, cela peut etre /dev/sda et c'est tout -> essaye de monter /dev/sda).

    Mathias
  • # re

    Posté par . Évalué à 1.

    voila les differentes reponses:
    $dmesg
    usb 1-1: new full speed USB device using address 3
    scsi1 : SCSI emulation for USB Mass Storage devices
    Vendor: Genesys Model: USB to IDE Disk Rev: 0002
    Type: Direct-Access ANSI SCSI revision: 02
    SCSI device sda: 390721968 512-byte hdwr sectors (200050 MB)
    sda: assuming Write Enabled
    sda: assuming drive cache: write through
    sda: sda1
    Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
    USB Mass Storage device found at 3

    et
    $cat /proc/partitions
    major minor #blocks name

    3 0 13282416 hda
    3 1 104391 hda1
    3 2 12916260 hda2
    3 3 257040 hda3
    3 64 40146624 hdb
    3 65 40146623 hdb1
    8 0 195360984 sda
    8 1 195352920 sda1

    donc si je comprends bien il ny a qu'une partition sur le disque.

    # mount -t vfat /dev/sda /mnt/externe/
    mount: type de sys. de fichiers erroné, option erronée, super bloc erroné sur /dev/sda,
    ou trop de systèmes de fichiers montés
    • [^] # Re: re

      Posté par . Évalué à 1.

      # ./sfdisk -l /dev/sda

      Disque /dev/sda: 24321 cylindres, 255 têtes, 63 secteurs/piste
      Unités= cylindres de 8225280 octets, blocs de 1024 octets, décompte à partir de 0

      Périph Amor Début Fin #cyls #blocs Id Système
      /dev/sda1 0+ 24320- 24321- 195352920 c W95 FAT32 (LBA)
      /dev/sda2 0 - 0 0 0 Vide
      /dev/sda3 0 - 0 0 0 Vide
      /dev/sda4 0 - 0 0 0 Vide
      • [^] # Re: re

        Posté par . Évalué à 1.

        a priori c'est bien sda1 qu'il faut utiliser.

        je pense a ces possibilités:
        - la partition ou le disque est effectivement foiré
        - le disque est partitioné en NTFS (bien que fdisk rapporte FAT32 ca peut arriver)
        - un probleme de transmission des données

        des pistes:
        au fait, ce disque marche t-il sur un autre OS?
        aussi, les disques doivent en general etre configurés en master dans les boitiers USB.
        • [^] # Re: re

          Posté par . Évalué à 1.

          ce disque marche sous windows sans probleme(enfin je crois:)
          il est possible que ce soit du ntfs
          et là je crois quil faut des modules speciaux et faire des coquineries avec le noyau...

          pourquoi est ce que windows complique-t-il la vie à tout le monde??
    • [^] # Les chipset Genesys sont-ils fiables ?

      Posté par (page perso) . Évalué à 1.

      J'ai moi aussi des problèmes avec des disques durs externes USB. D'aprés ce document ( http://openlab-mu-internal.web.cern.ch/openlab-mu-internal/Document(...) ) il semble que les chipsets Genesys soient en cause.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.