Forum Linux.général Disque dur SSHD Firecuda ne marche pas avec Linux

Posté par  . Licence CC By‑SA.
Étiquettes :
3
5
juil.
2019

Bonjour,

Ceci est un message à caractère informatif.

J'ai acheté deux disques durs 2.5" (Seagate FireCuda SSHD 2 To - ST2000LX001). Surtout parce qu'ils étaient garanti 5 ans (mais aussi parce que je voulais tester un SSHD).

Les disques sont bien reconnus par le bios, mais ils ne démarrent pas (pas de spin up) pendant le boot (Debian Stable avec kernel 4.19). Aucun soucis par contre si je les mets dans un boîtier (enclosure) USB.

J'ai testé avec deux carte-mères bien différentes (Asrock Z87E-ITX et Fatal1ty Z170 Gaming-ITX/ac) et j'ai exactement le même soucis avec les deux disques.

J'ai contacté le support Seagate qui m'a laconiquement répondu que Linux n'était pas supporté et que je devais tester sous Windows.

Donc attention si vous acheter ce type de disque !

Voici les logs:
[ 1.707935] aata4.00: exception Emask 0x50 SAct 0x1000000 SErr 0x4090800 action 0xe frozen
[ 1.711859] ata4.00: irq_stat 0x00400040, connection status changed
[ 1.715750] ata4: SError: { HostInt PHYRdyChg 10B8B DevExch }
[ 1.719634] ata4.00: failed command: READ FPDMA QUEUED
[ 1.723525] ata4.00: cmd 60/08:c0:00:00:00/00:00:00:00:00/40 tag 24 ncq dma 4096 in
[ 1.723525] res 40/00:c0:00:00:00/00:00:00:00:00/40 Emask 0x50 (ATA bus error)
[ 1.731372] ata4.00: status: { DRDY }
[ 1.735282] ata4: hard resetting link
[ 2.451932] ata4: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[ 2.540516] ata4.00: configured for UDMA/133
[ 2.544484] ata4: EH complete
[ 2.891957] ata4: limiting SATA link speed to 3.0 Gbps

  • # Comment peut-on faire aujourd'hui ...

    Posté par  . Évalué à 4.

    … pour sortir un disque dur qui ne serait pas utilisable sous n'importe quel OS ?

  • # Disques HS ?

    Posté par  . Évalué à 4.

    Les disques sont bien reconnus par le bios, mais ils ne démarrent pas (pas de spin up) pendant le boot (Debian Stable avec kernel 4.19).

    Puisque ça n'est pas en mesure de démarrer avec Linux, comment as-tu pu obtenir ce journal ?

    Les erreurs indiquées ressemblent à un disque qui a un problème, ou d'un soucis de câble SATA, ou de problème de contrôleur.
    Vu que les 2 disques sont impactés sur 2 cartes-mères différentes… effectivement c'est troublant. Il te reste à installer Windows pour voir :-)

    La réponse du support est juste « j'en sais rien, le mec est un bricoleur, j'ai autre chose à faire et puis je suis payé au mini alors basta ».

    À quel moment cela bloque ?
    Vois-tu GRUB ?
    Si tu démarres via une clef USB, les disques sont-ils accessibles ? Je suppose que c'est comme cela que tu as obtenu le journal.

    • [^] # Re: Disques HS ?

      Posté par  . Évalué à 2. Dernière modification le 08/07/19 à 06:47.

      J'ai démarré avec l'OS sur un autre disque.
      Le processus de Boot est bloqué (bien après GRUB) avec les messages d'erreurs (ci-dessus) qui s'affichent en boucle.

      • [^] # Re: Disques HS ?

        Posté par  (site Web personnel) . Évalué à 1.

        C'est probablement un jugement de valeur, mais je trouve cela plutôt rassurant que le chargeur de démarrage arrive bien à faire son boulot, et qu'il « suffise » de disposer d'un noyau avec un correctif ou d'une option qui évite de tomber sur le bogue en question… J'avais peur qu'il y ait un problème entre le firmware UEFI et le chargeur de démarrage. :)

        Vu la cadence infernale côté mainline et la « rétroportabilité » habituelle de pleins de patches, j'imagine que des corrections pourraient arriver facilement dans les branches stable/longterm et dans les distributions…

        Debian Consultant @ DEBAMAX

        • [^] # Re: Disques HS ?

          Posté par  . Évalué à 1.

          Ce disque est sorti il y a presque 3 ans et le rapport de bogue sur un soucis similaire (j'ai donné le lien plus haut) date d'environ 5 ans.
          Donc je doute qu'il soit corrigé rapidement.

          C'est juste que ce n'est pas une priorité et que donc personne n'a prévu d'y regarder. Si le constructeur ne fait aucun effort, tant pis pour lui: il y a d'autres marques de disque dur…

  • # Problème d'alimentation ?

    Posté par  . Évalué à 2.

    Franchement, parier sur un problème de compatibilité logicielle me paraît douteux… Le problème ne serait-il tout simplement pas hardware, genre l'alimentation des disques n'est pas suffisante pour qu'ils démarrent ? Le fait qu'ils ne se lancent pas est quand même un indice.

    Comment as-tu branché ces disques 2,5" sur une machine fixe : avec des alimentations utilisées d'habitude pour les 3,5" ? Si ton alimentation n'est pas géniale, ça se trouve ils zappent le 5V (normalement une prise SATA a du 3,3V, 5V et 12V, mais les disques 3,5" n'utilisent que 12V et 3,3V). Ou un truc du genre. Avec un boîtier USB, c'est le boîtier qui fait l'adaptation 3,3V à partir du 5V (standard en USB).

    J'irais donc plutôt regarder de ce côté d'abord.

    • [^] # Re: Problème d'alimentation ?

      Posté par  . Évalué à 2.

      Pour info, le 3,3V c'est souvent pour la logique, et le 5V (ou 12V en 3,5") pour les moteurs.

      • [^] # Re: Problème d'alimentation ?

        Posté par  . Évalué à 1. Dernière modification le 15/07/19 à 11:40.

        Salut,

        J'ai testé avec deux boîtiers différents et deux alimentations différentes.
        De plus les boîtiers marchent très bien avec d'autres disques durs 2.5" (seagate, western digital…).

        Je n'ai pas souhaité tester plus en avant et j'ai retourné les disques…

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.