Forum Linux.général lecture seule

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
4
jan.
2019

Bonjour et bonne année à tous.
Notebook Samsung NP300ESl (j'habite au Brésil)
Ubuntu 18-04-1 LTS
J'ai un disque partagé en deux partitions, l'une pour xubuntu et l'autre pour y mettre toutes mes photos. Ca fonctionne ainsi depuis des années et ça marche très bien. Sauf que depuis quelques jours, mon disque "photos" est en lecture seule…
Quand j'interroge "propriétés" du disque, il est indiqué que j'ai un accès lecture et écriture, mais c'est faux!
Que puis-je faire?
merci

  • # Regarder dans les logs ?

    Posté par  (site Web personnel) . Évalué à 2. Dernière modification le 04/01/19 à 12:40.

    dmesg
    te dit quoi, après un boot, par exemple ?

    La gelée de coings est une chose à ne pas avaler de travers.

    • [^] # Re: Regarder dans les logs ?

      Posté par  . Évalué à 1. Dernière modification le 04/01/19 à 14:28.

      Peux-tu préciser ta question car dmesg me donne plusieurs centaines de lignes de réponse.

  • # ça marche!

    Posté par  . Évalué à 1.

    Désolé de vous avoir dérangés mais ça refonctionne correctement! Ne me demandez pas cpmment, je n'en sais rien.
    Merci

    • [^] # Re: ça marche!

      Posté par  (site Web personnel) . Évalué à 1.

      Parfois ça arrive si un problème est détecté au niveau du système de fichiers: ça passe en lecture seule pour ne pas aggraver le cas. Mais dans ton cas ce serait étonnant, je ne crois pas que ça se répare tout seul.

      Un LUG en Lorraine : https://enunclic-cappel.fr

      • [^] # Re: ça marche!

        Posté par  . Évalué à 1.

        Effectivement, ça recommence! Quelle poisse!

        • [^] # Re: ça marche!

          Posté par  (site Web personnel) . Évalué à 1.

          Je ne sais comment ça se passe dans l'outil "Disques" fourni par Ubuntu, mais avec gparted tu as une icône indiquant que ton volume a un problème, et précisant que c'est pour ça qu'il est monté en lecture seule. D'ailleurs tu devrais même trouver un tel message dans /var/log/syslog, fais une recherche de "mount" et "readonly" dans ce fichier.

          gparted peut te proposer de réparer le problème, mais attention car ça peut aussi casser davantage ton système de fichiers. Si tu penses que ton système de fichier est corrompu: fais une sauvegarde de tout ce qui est important sur un autre support avant de tenter la réparation.

          Un LUG en Lorraine : https://enunclic-cappel.fr

          • [^] # Re: ça marche!

            Posté par  . Évalué à 1. Dernière modification le 05/01/19 à 00:06.

            Non, rien dans gparted

        • [^] # C’est SMART

          Posté par  . Évalué à 4.

          Le système passe aussi un disque en lecture seule quand il présente un problème matériel.

          À voir avec smartctl -a /dev/sda (à supposer qu’il soit bien en sda) ou mieux avec gsmartcontrol (dans l’onglet Attributes, quand on met le pointeur sur un attribut, il apparaît une info-bulle avec une explication de ce à quoi il correspond).

          La dernière possibilité serait qu’il y ait des erreurs de communication. Ça arrive plutôt sur des fixes, et ça s’arrange souvent simplement en débranchant et en rebranchant les connecteurs du câble SATA. Mais dans ce cas encore plus que dans le précédent, c’est tout le disque qui serait passé en lecture seule, pas qu’une partition.

          Si tu vois quelque chose d’anormal dans les données SMART, il est peut-être le temps de recopier les données sur un nouveau disque.

          Sinon, démonter la partition et forcer sa vérification (e2fsck -f) me semble la meilleure idée.

          Frаnсе : 115363, Allеmаgnе : 92559. Масrоn : 22804.

          • [^] # Re: C’est SMART

            Posté par  . Évalué à 1.

            comme je ne maitrise pas totalement linux, je suis repassé sur windows et ai fait un chkdsk sur mon disque en cause: rien du toit, tout est bon.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.