Forum Linux.général "Network is unreachable" sur mon NAS DS413j

Posté par  . Licence CC By‑SA.
Étiquettes :
1
9
nov.
2013

Bonjour à tous,

Depuis quelque temps et pour une raison inconnu, mon NAS n'a plus accès au réseau externe. Je ne suis pas un expert en réseau. Malgré tout j'ai fait quelque test et pour moi tout semble OK.

Par exemple un wget de google.com :

$ wget google.com
--18:57:11--  http://google.com/
=> 'index.html'
Resolving google.com... 173.194.40.192, 173.194.40.195, 173.194.40.206, ...
Connecting to google.com|173.194.40.192|:80... failed: Connection timed out.
Connecting to google.com|173.194.40.195|:80... failed: Connection timed out.

Alors que wget sur un poste local fonctionne :

> wget 192.168.0.11
--19:05:35--  http://192.168.0.11/
=> 'index.html.1'
Connecting to 192.168.0.11:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1,619 (1.6K) [text/html]
100%[==========================================================>] 1,619         --.--K/s             
19:05:35 (47.56 MB/s) - 'index.html.1' saved [1619/1619]

Les routes ne me semblent pas déconnantes :

> route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0

Enfin le traceroute de google.com, qui montre qu'il arrive bien à sortir. Peut être est-ce le retour alors ?

> traceroute google.com
traceroute to google.com (173.194.40.194), 30 hops max, 38 byte packets
 1  192.168.0.1 (192.168.0.1)  0.396 ms  0.328 ms  0.165 ms
 2  10.92.0.1 (10.92.0.1)  7.114 ms  7.339 ms  8.499 ms
 3  ip-225.net-80-236-9.asnieres.rev.numericable.fr (80.236.9.225)  7.524 ms  8.369 ms  11.472 ms
 4  ip-249.net-80-236-0.static.numericable.fr (80.236.0.249)  15.135 ms  13.875 ms  8.017 ms
 5  172.19.128.170 (172.19.128.170)  8.292 ms  9.545 ms  12.645 ms
 6  ip-161.net-80-236-1.static.numericable.fr (80.236.1.161)  32.985 ms  8.636 ms  20.024 ms
 7  72.14.239.205 (72.14.239.205)  12.873 ms  11.426 ms  9.698 ms
 8  209.85.243.51 (209.85.243.51)  10.159 ms  9.604 ms  10.049 ms
 9  par10s12-in-f2.1e100.net (173.194.40.194)  9.448 ms  11.503 ms  10.495 ms

Quelqu'un aurait une idée ?

  • # tcpdump / wireshark

    Posté par  (site Web personnel) . Évalué à 2.

    sur le routeur ( ou écoute du traffic entre les deux )

    pas de firewall, filtrage sur le routeur ?

    Système - Réseau - Sécurité Open Source

    • [^] # Re: tcpdump / wireshark

      Posté par  . Évalué à 1.

      Rien de spécial sur le routeur sinon des transferts de ports :

      SSH 22  22  Both    192.168.0.11
      HTTP    80  80  TCP 192.168.0.11
      HTTPS   443 443 TCP 192.168.0.11
      DiskStation 5000    5000    TCP 192.168.0.13
      
  • # Commentaire supprimé

    Posté par  . Évalué à 5.

    Ce commentaire a été supprimé par l’équipe de modération.

  • # Bloqué par un processus ?

    Posté par  . Évalué à 2.

    Bonjour,

    Merci pour ces réponses.

    Ce n'est pas un problème de conflit d'IP, car j'ai deux machines sur le réseau et elles utilisent des IPs différentes.
    Je changé l'adresse IP du NAS et toujours le même problème.

    J'ai remarqué un truc étrange, lors du démarrage du NAS ou de son extinction j'ai l'espace de quelques secondes accès au réseau. Je me suis dis que c'était un problème de firewall. Normalement rien n'est configuré, il ne filtre rien. J'ai quand même ajouté une règle pour tout laisser passer. Pas plus de résultat.

    J'ai tenter d'éteindre apache et autres serveur. Pas plus de résultat. Pour finir, j'ai fait un while :; do date +%Y-%m-%d_%H-%M-%S; top -b -n1 > test.date +%Y-%m-%d_%H-%M-%S; sleep 1; done et éteint le NAS. J'ai récupéré les fichier sur mon pc fixe et j'ai comparé les TOP. Grâce à cela je vois les processus un à un s'éteindre. J'ai remarqué que le synology lance une commande :
    /usr/syno/bin/synopkg onoffall stop

    Après avoir redémarré le NAS, j'ai tenté cette dernière et miracle j'ai récupéré mon accès à l'extérieur :)

    Quelqu'un a-t-il une idée de pourquoi cette commande règle le problème ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.