Forum Linux.général Partage de connexion internet

Posté par (page perso) .
Tags : aucun
0
4
août
2005
Je me retrouve a devoir partager une connexion internet. Jusqu'a maintenant je n'ai jamais eu de problème pour le faire, mais ici le cas est différent. En général la machine connectée est sous linux, et la machine qui veux accéder a internet est sous windows, et ça marche nickel.
Mais ici la machine connectée est sous windows, et celle qui voudrais avoir accès au net est sous linux... et là, j'y arrive pas.
Est-ce que l'un d'entre vous à déjà eu ce genre de chose à faire, et si oui comment l'a-t-il fait ?
Merci
  • # Partage de connexion internet

    Posté par . Évalué à 0.

    Moi j'ai ca le PC connecte est sous windows 2000 connecte avec le SAGEM de free, et mon PC est sous debian.
    Au demarrage ca reconnait le DHCP est j'ai ma connexion direct, j'ai fait aucun reglage particulier. Y a juste, sous windows, a partager ta connexion net avec le reseau local.

    @+
  • # reseau

    Posté par . Évalué à 3.

    il faut que le pc qui partage soit en 192.168.0.1 255.255.255.0

    Les autre pc doivent etre sur le meme réseau et tu met les dns de ton fai
    • [^] # Re: reseau

      Posté par (page perso) . Évalué à 3.

      "il faut que le pc qui partage soit en 192.168.0.1"
      De toute facon sous windows, si tu utilises leur truc de partage de connexion, tu n'as pas le choix... Il change ton ip en 192.168.0.1...

      Les autres PCs doivent être configuré pour utiliser comme passerelle : 192.168.0.1
      Bien sur avec le meme masque de sous reseaux les ordis :)
      Pour les dns, je ne sais plus trop s'il faut mettre dans /etc/resolv.conf les adresses ips fourni par ton FAI ou si 192.168.0.1 marche aussi... Dans tous les cas, les adresses ips de ton FAI marcherons donc bon :)
  • # Problème insoluble

    Posté par . Évalué à 1.

    Bonjour,

    Je rencontre a peut prêt le même type de problème.
    J'ai un ordi sous Win XP Pro qui se connecte a mon FAI en DHCP
    j'ai un autre ordi portable sous linux (Mandrake)que 'j'essaye de connecter a internet par l'intermédiaire de mon Win.

    Alors quand je créer un réseau local manuellement, (sans l'assistant windows) linux arrive a voir mon win (avec Samba) et les pings répondent entre les deux ordi . Cependant même en partageant la connexion sur le réseau local de win , linux ne peux pas se connecter a internet (et les pings externe au réseau local ne répondent pas).

    Quand je fais un réseau local et partage de connexion avec l'assistant de windows, tout se met en DHCP et lorsque que je met le DHCP sur linux voici mes résultats:
    - ping internet (exemple: ping www.free.net) marche
    - ping interne marche ( les ordi entre eux)
    - échange de fichier et montage du réseau local sous Samba impossible
    - et la seul page consutable sur le linux est la page google (qui est la page d'acceuil de mon win), je peux effectuer des recherches sous google a partir du linux mais impossible d'aller sur les sites trouvée par google. et quand je tape une adresse autre que google dans la bare des adresses de Konqueror aucune réaction , il attend jusqu'a la fin du temps de réponse et me dit impossible a chargée.

    Quelqu'un a t'il une idée de ce qui se passe sur mon/mes PC? ou doit je cherché l'erreur?

    Please Help

    Grand merci

    Tafiole.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.