Forum Linux.général Problème de config DNS avec le serveur sur le réseau local

Posté par (page perso) . Licence CC by-sa.
Tags : aucun
0
23
avr.
2015

Salut,

J'ai un petit souci de résolution de nom sur mon LAN et je ne trouve pas de solution. Je t'explique.

Mon objectif est de mettre sur le réseau une machine servant de NAS. La première configuration que j'ai mis en œuvre consistait simplement à configurer une IP fixe pour cette machine et à nommer cette IP dans les /etc/hosts des autres machines. Malheureusement je ne peux pas éditer ce fichier sur les smartphones et tablettes connectés sur le réseau, il me faut donc une alternative.

Pour corriger le problème j'ai choisi de mettre un DNS sur le réseau de façon à pouvoir accéder à la machine par un simple http://nas.lan. Comme la Freebox v5 ne permet pas de configurer le DNS j'ai du aussi gérer le DHCP moi même. Malheureusement pour une raison que j'ignore mes machines n'utilisent pas ce DNS et n'arrivent donc pas à résoudre nas.lan, c'est pourquoi je te demande de l'aide.

Je mets toute la config ci-dessous. D'après moi le DHCP dit bien d'utiliser le DNS 192.168.1.10 quand on est sur le réseau 192.168.1.0, et la config du DNS fait bien le lien entre 192.168.1.10 et le nom nas.lan. Malheureusement ça ne fonctionne pas, comme l'indiquent ces commandes lancées sur une machine du réseau :

$ nslookup nas.lan
Server:     127.0.1.1
Address:    127.0.1.1#53

** server can't find nas.lan: NXDOMAIN

$ nmcli dev list iface wlan0 | grep IP4
IP4.ADRESSE[1]:                         ip = 192.168.1.12/24, gw = 192.168.1.254
IP4.DNS[1]:                             212.27.40.240
IP4.DNS[2]:                             212.27.40.241

Vois-tu ce que je dois modifier dans la config ci dessous pour que ça fonctionne correctement ?

Freebox

  • Wifi actif
  • Routeur actif
  • DHCP inactif
  • IP Freebox 192.168.1.254
  • IP fixe 192.168.1.10 pour le NAS

Le NAS

  • Les services
$ service isc-dhcp-server status
isc-dhcp-server start/running, process 7593
$ service bind9 status
 * bind9 is running
  • IP
$ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr ab:cd:ef:01:23:45
          inet adr:192.168.1.10  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: aaaa::aaaa:aaaa:aaaa:aaaa/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:37787768 erreurs:0 :0 overruns:0 frame:0
          TX packets:39584386 errors:0 dropped:0 overruns:0 carrier:17
          collisions:0 lg file transmission:1000 
          Octets reçus:3661351674 (3.6 GB) Octets transmis:512245301 (512.2 MB)
  • DHCP
$ cat /etc/dhcp/dhcpd.conf

ddns-update-style none;

option domain-name "lan";
option domain-name-servers 212.27.40.240, 212.27.40.241;

default-lease-time 600;
max-lease-time 7200;

authoritative;

log-facility local7;

subnet 192.168.1.0 netmask 255.255.255.0 {
       range 192.168.10.1 192.168.1.200;
       option routers 192.168.1.254;
       option broadcast-address 192.168.1.255;
       option domain-name-servers 192.168.1.10;

       host nas {
            hardware ethernet ab:cd:ef:01:23:45;
        fixed-address 192.168.1.10;
       }
}
  • DNS
$ cat /etc/bind/named.conf.local
zone "lan" {
     type master;
     file "/etc/bind/db.lan";
};

zone "1.168.192.in-addr.arpa" {
     type master;
     notify no;
     file "/etc/bind/db.192";
};
$ cat /etc/bind/named.conf.options
options {
    directory "/var/cache/bind";

    forwarders {
           212.27.40.240;
           212.27.40.241;
        };

    dnssec-validation auto;

    auth-nxdomain no;    # conform to RFC1035
    listen-on-v6 { any; };
};
$ cat /etc/bind/db.lan
$TTL    604800
@   IN  SOA nas.lan. julien.localhost. (
                  3     ; Serial
             604800     ; Refresh
              86400     ; Retry
            2419200     ; Expire
             604800 )   ; Negative Cache TTL
;
@   IN  NS  nas.lan.
nas IN  A   192.168.1.10
$ cat /etc/bind/db.192
$TTL    604800
@   IN  SOA nas.lan. julien.localhost. (
                  2     ; Serial
             604800     ; Refresh
              86400     ; Retry
            2419200     ; Expire
             604800 )   ; Negative Cache TTL
;
@   IN  NS  nas.
10.1.168    IN  PTR nas.lan.
  • # piste

    Posté par . Évalué à 2. Dernière modification le 23/04/15 à 22:09.

    $ nslookup nas.lan
    Server: 127.0.1.1
    Address: 127.0.1.1#53

    ca, ca veut dire que la machine sur laquelle tu lances la commande, resoud en utilisant un DNS qui tourne sur elle meme

    ici ce serait la resolution du nas, sur lui meme,

    ca donne quoi depuis une autre machine ?
    sous linux :
    host nas.lan ou dig nas.lan

    nmcli dev list iface wlan0 | grep IP4
    IP4.ADRESSE[1]: ip = 192.168.1.12/24, gw = 192.168.1.254
    IP4.DNS[1]: 212.27.40.240
    IP4.DNS[2]: 212.27.40.241

    ta machine est en WIFI, et meme si tu desactives le DHCP de la Freebox, je crois que ca ne le desactive que sur le LAN.
    c'est alors le DHCP de la freebox qui va servir pour ton wifi

    ou alors tu n'as pas renouvelé l'adresse IP de ta machine apres avoir desactiver le dhcp de la freebox et redemarré celle-ci.

    • [^] # Re: piste

      Posté par (page perso) . Évalué à 2.

      Pour le DHCP wifi, j'ai testé en configurant mon serveur DHCP pour que cette machine ait une IP fixe, et après reconnexion elle a bien obtenu l'IP attendue.

      Sur une autre machine où ça ne fonctionne pas non plus, le dig donne ça :

      $ dig nas.lan
      
      ; <<>> DiG 9.9.5-3ubuntu0.2-Ubuntu <<>> nas.lan
      ;; global options: +cmd
      ;; Got answer:
      ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 7590
      ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
      
      ;; OPT PSEUDOSECTION:
      ; EDNS: version: 0, flags:; udp: 4096
      ;; QUESTION SECTION:
      ;nas.lan.           IN  A
      
      ;; AUTHORITY SECTION:
      .           84614   IN  SOA a.root-servers.net. nstld.verisign-grs.com. 2015042500 1800 900 604800 86400
      
      ;; Query time: 68 msec
      ;; SERVER: 127.0.1.1#53(127.0.1.1)
      ;; WHEN: Sat Apr 25 08:26:36 CEST 2015
      ;; MSG SIZE  rcvd: 114
      
      • [^] # Re: piste

        Posté par . Évalué à 2.

        ;; SERVER: 127.0.1.1 #53(127.0.1.1)

        c'est toujours la machine ubuntu qui fait sa propre resolution DNS
        probablement à cause de DNSmasq qui est installé par defaut, et qui va faire du cache.

        Personnellement à defaut de le desinstaller, je l'ai desactivé au demarrage (cf les tuto pour ca sur internet, c'est juste mettre un NO dans un fichier de configuration)

        ca resoud pas mal de mes problemes de DNS

  • # problème de config DNS

    Posté par . Évalué à 1.

    salut Julien, je te propose quelques solutions à ton problème:

    1- dans le fichier named.conf.options tu ajoute <<< listen-on { any; }; >>>
    2- dans tes fichiers db.192 et db.lan, tu changes localhost par nas.lan
    3- dans ton fichier /etc/bind/db.192 , tu change <<< 10.1.168 IN PTR nas.lan. >>> par <<< 10 IN PTR nas.lan.>>> et tu ajoute << @ IN A 192.168.1.10 >>>. Dc tu doit avoir ceci:

    $ cat /etc/bind/db.192
    $TTL 604800
    @ IN SOA nas.lan. julien.nas.lan. (
    2  ; Serial
    604800  ; Refresh
    86400  ; Retry
    2419200  ; Expire
    604800 )  ; Negative Cache TTL
    ;
    @ IN NS nas.lan.
    10 IN PTR nas.lan.
    @ IN A 192.168.1.10

    4- dans ton fichier db.lan tu change << nas IN A 192.168.1.10>> par << @ IN A 192.168.1.10 >>
    Dc tu doit avoir ceci:

    $ cat /etc/bind/db.lan
    $TTL 604800
    @ IN SOA nas.lan. julien.nas.lan. (
    3  ; Serial
    604800  ; Refresh
    86400  ; Retry
    2419200  ; Expire
    604800 )  ; Negative Cache TTL
    ;
    @ IN NS nas.lan.
    @ IN A 192.168.1.10

    redémarre tout d'abord le serveur et si ça ne fonctionne toujours pas, alors tu signales…….(._.)

    • [^] # Re: problème de config DNS

      Posté par (page perso) . Évalué à 2.

      Alors ça ne fonctionne toujours pas, par contre si dans la la configuration du serveur DHCP je met des IP fixes associées à certaines machines, alors ces machines ont le bon DNS et arrivent à résoudre le domaine. J'aimerais bien avoir ce comportement sans IP fixe.

      • [^] # Re: problème de config DNS

        Posté par . Évalué à 2.

        ca c'est l'option update-dns qu'il faut activer dans le dhcp, en lui precisant qui est le DNS, avec peut-etre une clef de securité entre DHCP et DNS.

  • # pb config DNS

    Posté par . Évalué à 1.

    dans ton fichier /etc/bind/named.conf.local ce n'est pas zone "lan" {…} mais c'est plutot zone "nas.lan" {…}

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.