Forum Linux.général Proxmox, container & ip failover

Posté par . Licence CC by-sa.
Tags :
0
2
juil.
2014

Bonjour,

Je rencontre un soucis sur un serveur dédié sous proxmox. Comment ça s'est passé :
- le serveur complet perds le net (câble débranché d'après les logs)
- le net revient
- tout repart comme avant sauf une ip failover qui ne fonctionne plus (sur un container)

Ce que j'ai testé :
- le traceroute depuis l'extérieur va bien jusqu'au serveur hôte puis plus rien
- j'ai mis à jour proxmox, noyau compris, et redémarré le serveur
- j'ai testé une autre ip sur le même container, pas de soucis
- j'ai testé l'ip sur un autre container, même probléme.

Je ne sais pas quoi faire et quels outils utiliser pour pousser plus loin les investigations. Si vous avez une idée, je suis preneur.

  • # niveau 2 ethernet

    Posté par (page perso) . Évalué à 2.

    ça dit quoi ? la machine reponds au requêtes arp ( pont, … )

    Système - Réseau - Sécurité Open Source

    • [^] # Re: niveau 2 ethernet

      Posté par . Évalué à 1.

      C'est une interface venet
      Je n'ai pas d'adresse mac sur la vm, je ne vois pas comment faire des requêtes arp

  • # securité chez le fournisseur

    Posté par . Évalué à 2.

    le switch detecte des requetes ARP associé au serveur et à l'IP sur un port qui ne devrait pas, il coupe le port pendant 5 minutes.

    donc verifie deja que, dans l'interface de gestion de tes serveurs et IPs failover, tu as bien affecté l'IP failover à ce serveur.

    ensuite :
    1°) les IPs failover se mette en direct dans l'interface du container (pas dans la machine en elle meme)
    2°) elle n'a pas besoin de masque ni de gateway, c'est un /32

    • [^] # Re: securité chez le fournisseur

      Posté par . Évalué à 1.

      Ce n'est pas au cours d'une modification que le problème est survenu mais en pleine "production" depuis environ 3 mois ..

      L'interface était en "venet", je n'avais donc à saisir que l'adresse ip dans proxmox sans me soucier des adresses mac.
      En testant avec une interface "veth", donc à configurer dans le container & spécifier l'adresse mac, cela fonctionne pas non plus.

      Test supplémentaire que je n'avais pas essayé : depuis le serveur hôte je peux ping l'ip qui pose problème (en venet)

      • [^] # Re: securité chez le fournisseur

        Posté par . Évalué à 2.

        Test supplémentaire que je n'avais pas essayé : depuis le serveur hôte je peux ping l'ip qui pose problème (en venet)

        normal elle est "locale" à ta machine (venet ou veth)

        verifie que cette IP soit toujours affectée à ton serveur dans la console de ton fournisseur,
        si ca se trouve elle n'est simplement plus "routée" vers ton serveur, donc inutilisable en dehors du serveur.

        • [^] # Re: securité chez le fournisseur

          Posté par . Évalué à 1.

          Un traceroute sur l'ip va jusqu'au serveur qui répond et ensuite ça se perd.
          Un ping sur l'ip failover (qui ne répond pas) est vu avec tcpdump sur l'hote.

          • [^] # Re: securité chez le fournisseur

            Posté par . Évalué à 3.

            tcpdump le voit arriver ET repartir ?

            en gros il voit le "echo request" ET le "echo reply" ?

            • [^] # Re: securité chez le fournisseur

              Posté par . Évalué à 1.

              Je pense que tu avais raison, le problème a l'air de venir des routeurs de l'hebergeur.

              Je vois le ping arriver puis repartir avec tcpdump sur l'hôte (ping depuis une ip externe ver l'ip failover).
              Je vois le ping partir mais pas revenir avec tcpdump sur l'hote (ping depuis le container vers la passerelle de l'hôte)

              J'ai laissé un ticket chez l'hebergeur à 3 lettres en espérant que ce soit traité avant la saint glinglin …

              Merci beaucoup pour ton aide

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.