Forum Linux.général [Résolu] Impossible de booter sur disque dur

Posté par . Licence CC by-sa.
Tags :
2
22
mai
2019

Bonjour,

J'ai manifestement fait une boulette. Au démarrage j'avais un message d'erreur m'indiquant qu'il était impossible de démarrer le serveur X à cause d'une erreur interne. J'ai rebooté, et suis allé dans le setup pour voir s'il n'y avait pas moyen de faire un démarrage en mode sans échec. Et c'est là que bêtement, dans l'onglet "Exit", j'ai sélectionné "Load up setup defaults" en croyant que c'était une sorte d'équivalent. J'ai maintenant le message suivant au démarrage : "Reboot and select proper device…". Le problème est que je ne peux plus sélectionner mon disque dur comme disque de démarrage, en effet suite à ma mauvaise manip le menu Boot du Setup a changé :

Boot option priorities
(vide)

UEFI Settings
- UEFI Boot [enabled]
- Network Stack [disabled]

Que dois-je faire ? Votre aide sera précieuse, cet ordi je fais tout dessus !
Cordialement.

  • # Peut-être étais-tu en CSM?

    Posté par (page perso) . Évalué à 3 (+1/-0).

    Mais il n'y a que toi que saches le réglage précédent!

    ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # Menu Setup?

    Posté par (page perso) . Évalué à 1 (+0/-0).

    Quand tu dis

    J'ai rebooté, et suis allé dans le setup

    Ça c'est le menu de ton BIOS, le système qui est intégré à ta carte mère. Changer des valeurs ici ne résoudra pas le problème que tu as avec ton serveur graphique. Mais tu peux essayer de démarrer en "Recovery" depuis le menu de GRUB (faut voir quelle distri tu utilises).

    Déjà, si tu as juste modifié les paramètres du BIOS, ton système est intact. Il faut juste réussir à retrouver les bons paramètres du BIOS pour relancer ton système.

    Généralement si on ne fait pas de dual boot, le plus simple est de paramétrer le BIOS en mode Legacy. En remettant les paramètres par défaut, tu es peut-être repassé du mode legacy au mode EFI, ce qui empêche le démarrage.

    Bonne chance!

    Un LUG en Lorraine : https://enunclic-cappel.fr

    • [^] # Re: Menu Setup?

      Posté par . Évalué à 1 (+0/-0).

      Bonjour Ted, merci de ta réponse. J'ai lu quelques tutos sur le Legacy, mais aucun des menus de mon Bios ne fait apparaitre une telle option.

      • [^] # Re: Menu Setup?

        Posté par . Évalué à 2 (+1/-0). Dernière modification le 22/05/19 à 14:10.

        Hello, pour activer le mode legacy il faut que tu passes ton paramètre "UEFI Boot [enabled]" à disabled.

        Au passage, essaye de mettre ton disque dur dans le paramètre "Boot option priorities" qui semble vide d'après ton post.

        Bonne chance et bon courage !

  • # Fonctionnement (U)EFI

    Posté par (page perso) . Évalué à 3 (+2/-0).

    Si tu n'as pas fait de manipulations particulières, notamment si tu ne savais pas ce qu'étaient les termes CSM, Legacy BIOS, etc., tu n'as probablement pas modifié toi-même d'option dans ton firmware. Celui-ci était donc probablement configuré pour booter en EFI plutôt qu'en BIOS.

    Dans ce cas, les différents OS sont stockés dans des variables persistantes, qui ont probablement été vidées lors de la remise à zéro. Il faudrait donc réussir à rétablir ces entrées.

    Je ne sais pas quelle distribution tu utilises, mais au moins côté Debian, il est possible de démarrer le système d'installation en mode Récupération (Rescue), de détecter le système installé, et de rejouer l'installation du chargeur de démarrage (ce qui doit avoir comme effet de bord la réinscription de l'entrée correspondante côté firmware). Une alternative pourrait être de lancer soi-même la bonne commande efibootmgr depuis le système en question.

    Debian Consultant @ DEBAMAX

  • # Démarrer avec un média Live de ta distribution favorite

    Posté par (page perso) . Évalué à 7 (+5/-0).

    Déjà pour commencer, je démarrerais avec un média Live histoire de récupérer les données. Ensuite seulement j’essaierais les manipulations qui t'ont été données et nettement plus tranquillement.

    OS préféré Mageia 6 et Mageia 7, CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.

  • # UEFI disabled

    Posté par . Évalué à 2 (+1/-0). Dernière modification le 23/05/19 à 19:53.

    Bonjour à tous,
    Un grand merci pour vos réponses. Dans le menu Boot du Setup j'ai réglé le UEFI Boot à [disabled]. J'ai redémarré et là, ô miracle, cela a démarré sur le disque, et toutes les options sont revenues dans le menu Boot. Mais je me retrouve désormais avec mon problème de départ : "impossible de démarrer le serveur X à cause d'une erreur interne…". Je mets ce sujet en résolu et j'en ouvre un autre ?

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.