Forum Linux.général Un peu d'aide pour apache2 svp

Posté par .
Tags : aucun
0
20
sept.
2007
Je viens d'installer apache 2 et php 5 sur ubuntu avec le synaptic package manager
Mon serveur tourne bien quand je tape l URL http://localhost/ car g la page d'accueil de apache.

J'ai cree la ligne DocumentRoot /etc/apache2/htdocs dans httpd.conf et g place 2 fichiers index.html et index.php dans htdocs,
mais malgre ca, si je tape l'URL suivante http://localhost/index.html il me balance une erreur 404.
c'est surement un truc tt bete a faire mais la je vois pas quoi et je craque un peu..

Merci de vos reponses
  • # rtfm ?

    Posté par . Évalué à 3.

    C'est effectivement tout bête : il faut lire un peu la doc.

    Déjà, le fichier de conf par défaut est désormais apache2.conf et non
    httpd.conf.

    Ensuite, regarde du côté de /etc/apache2/sites-enabled/.
    Tu devrais avoir un fichier 000-default qui est en fait un lien vers
    /etc/apache2/sites-available/default.
    Le contenu de ce fichier laisse apparaitre un DocumentRoot...

    je dois en avoir assez dit pour que tu avances...
    • [^] # Re: rtfm ?

      Posté par . Évalué à 1.

      dans la meme idée, je ne toucherais pas au fichier default...

      "mais comment fais tu ?" me direz vous

      1°) je cree un utilisateur pour le site (comme ca je peux ensuite deleguer la gestion du site)

      2°) j'active le module userdir dans la conf apache

      3°) je cree le dossier public_html dans le /home/mon_user
      en prenant soin de lui donner les droits dessus.

      4°) je cree un fichier /etc/apache2/sites-available/le_site
      je met les options qui m'interesse, le document root aussi.

      5°) je fais le lien vers /etc/apache2/sites-enabled/ afin de rendre le site visible

      6°) je relance apache2

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.