Forum Linux.mandriva échec lecture vidéo

Posté par .
Tags : aucun
0
22
août
2008
Après moult bidouillages et quêtes d'informations, mes tentatives pour lire des fichiers ou des flux vidéo (avec vlc ou kaffeine) restent vouées à l'échec. Si ce n'est qu'un ami a déposé un fichier vidéo il y a quelques jours, que j'ai pu le lire 2 fois avec vlc, avec lequel j'ai pu aussi lire des flux tv (via la freebox), mais seulement quelques instants, car tout s'est recoincé. Avec ce message d'erreur :

libdvbpsi error (PSI decoder): TS discontinuity (received 4, expected 0) for PID 0
X Error of failed request: BadAlloc (insufficient resources for operation)
Major opcode of failed request: 141 (XVideo)
Minor opcode of failed request: 19 ()
Serial number of failed request: 108
Current serial number in output stream: 109

Avec kaffeine, l'ouverture d'un fichier vidéo donne le son pas l'image.
Mes moyens techniques et connaissances sont rudimentaires ; quelqu'un a-t-il des suggestions ?

Mandriva 2008
Dell Latitude | D505
Carte graphique : Intel Corporation 82852/855 GM
  • # X11

    Posté par (page perso) . Évalué à 6.

    Salut,

    J'ai déjà vu exactement le même problème sur une mandriva 2008, il faut changer la sortie video de VLC sur x11 et normalement ça devrait le faire si je me souviens bien (avec mplayer option "-vo x11" et avec vlc : "vlc -V x11 <fichiervideo>" mais il y avoir moyen de régler ça en dur dans la conf)

    ça doit correspondre au bug : https://qa.mandriva.com/show_bug.cgi?id=33254
    • [^] # Re: X11

      Posté par . Évalué à 2.

      Chapeau bas, mon cher ! Non seulement ta réponse a été rapide, succincte et précise, mais elle semble bel et bien être la solution de mon problème. Comme c'est expliqué sur le lien, je suis allé dans mcc>matériel>configurer les effets bureau 3D>Compiz Fusion où, dans les paramètres avancés il faut sélectionner Xgl. Merci, je me doutais que c'était un truc tout bête, mais auquel il faut avoir le mérite de penser !
      • [^] # Re: X11

        Posté par (page perso) . Évalué à 2.

        Effectivement, ça mérite un plussage :-)
        Il m'en reste une demi palette, hop, c'est fait.
      • [^] # Re: X11

        Posté par . Évalué à 2.

        C'est bizarre, j'ai essayé de comprendre parce que je n'aime pas les problèmes résolus "bêtement", mais je ne vois pas le rapport de ta solution ni avec la réponse Thibault, ni avec les messages du forum. Tu pourrais préciser ?
        Activer la lecture par X11 directement désactive l'accélération matérielle, donc c'est quand même moins efficace.
        La solution du forum réactive le support XV en appliquant un patch à mplayer.
        Mais alors ta solution, je ne comprend pas du tout ...
        • [^] # Re: X11

          Posté par . Évalué à 1.

          Désolé, je ne trouve ton commentaire qu'aujourd'hui. La solution dont je parlais, ce ne sont pas les premières lignes de Thibault qui me l'ont donnée, mais le site auquel il renvoyait à la fin, où j'ai appris qu'il fallait dans mcc>matériel>configurer les effets 3D activer Compiz-fusion. Voilà, c'est ce qui était trop bête pour qu'on continue d'en parler...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.