Forum Linux.mandriva Compilateur g77 fortran

Posté par  .
Étiquettes : aucune
0
1
fév.
2005
J'aimerai savoir ou je peux le telecharger j'ai du mal à l'installer, j'ai telecharge le :
gcc-3.4.1-4mdk.src.rpm
gcc-g77-3.4.1-4mdk.i586.rpm
glibc-debug-2.3.3-21mdk.i586.rpm

j'ai essayé d'installer ca ne s'installe pas correctement.
j'ai mandrake 10.1
Merci pour aide, de me montrer ou je peux trouver le compilateur fortran g77 et comment installer.
Merci
  • # apt/emerge/yum/etc

    Posté par  . Évalué à 1.

    Utilise le gestionnaire de paquet de ta distribution , c fait pour !

    Tous paquet avec src dedans c un paquet source , a moins que tu as envie de recompiler le paquet c sans interet pour toi ,

    Donc utilise le gestionnaire de paquet de ta distro !!!
  • # g77 != gcc

    Posté par  . Évalué à 1.

    Le fortran et le C++ sont deux languages differents.
    Tu as besoin de g77.

    --
    Xtophe
  • # f77

    Posté par  . Évalué à 1.

    Bonjour

    je ne connais pas mandrake, mais le paquet gcc-g77-3.4.1-4mdk.i586.rpm semble le bon
    la commande est f77 et non g77.

    a noter aussi que ce n'est pas un vrai compilateur fortran, mais une moulinette qui convertit ton fortran en c. (f2c)
    mais a chaque fois que je l'ai essayé, pour compiler des bouts de codes d'il y a 15 ans, ca c'est soldé par un echec.
    je ne suis pas sur que toutes les fonctionalités de fortran77 soient supportées.

    malheureusement, je crois qu'il n'y a pas de compilo fortran libre et efficace, pour une utilisation pro il faut se rabattre sur celui d'intel par exemple.
    • [^] # Re: f77

      Posté par  . Évalué à 0.

      j'ai travaillé bien avec g77. Tous mes programmes fonctionnaient bien lorsque j'avais mandrake 9.2.
      j'"ai formaté et installer mandrake 10.1
      j'ai pas trouvé la commande g77 j'ai voulu installer ce fichier gcc-g77-3.4.1-4mdk.i586.rpm et ne s'installe pas correctement il me demande : d'installer et puis rien tu as impression qu'il s'est installé mais e nfait lorsque je fais which g77 ou f77 ou f2c je ne trouve pas cette commande.
      j'ai impression qu'il a été mal installé ou il lui manque qq chose.
      Franchement j'ai pas compris comment faire ? d'habitude à partir du Mandrake on pouvait installer la paquetage g77.
      Merci
    • [^] # Re: f77

      Posté par  . Évalué à 0.

      j'ai travaillé bien avec g77. Tous mes programmes fonctionnaient bien lorsque j'avais mandrake 9.2.
      j'"ai formaté et installer mandrake 10.1
      j'ai pas trouvé la commande g77 j'ai voulu installer ce fichier gcc-g77-3.4.1-4mdk.i586.rpm et ne s'installe pas correctement il me demande : d'installer et puis rien tu as impression qu'il s'est installé mais e nfait lorsque je fais which g77 ou f77 ou f2c je ne trouve pas cette commande.
      j'ai impression qu'il a été mal installé ou il lui manque qq chose.
      Franchement j'ai pas compris comment faire ? d'habitude à partir du Mandrake on pouvait installer la paquetage g77.
      Merci
      • [^] # c'est bon!!! c'est réglé !!

        Posté par  . Évalué à 0.

        Merci à vous tous .

        Dans la version mandrake 10.1 g77 ne se trouve sur les 3 premiers CD.
        et le g77 se
        trouve sur le CD4 qui est vendu.
        Finalement j'ai téléchargé les deux fichiers :
        libf2c0-3.4.1-4mdk.i586.rpm
        gcc-g77-3.4.1-4mdk.i586.rpm

        je vous donne adresse d' un moteur de recherche des rpm
        linux pour toutes les distributions, c'est facile de
        trouver ce qu'on veut : http://rpm.pbone.net/(...)
        • [^] # PB g77

          Posté par  . Évalué à 1.

          Bonjour,

          J'ai le même pb que terki en voulant installer un logiciel d'analyse statistique. J'ai donc procédé au téléchargement et à l'installation des fichiers :
          libf2c0-3.4.1-4mdk.i586.rpm
          gcc-g77-3.4.1-4mdk.i586.rpm

          Mais lors de l'installation, il a besoin de quelques autres dépendances que j'ai également téléchargé :
          gcc-3.4.1-4mdk.i586.rpm

          J'installe avec la commande urpmi, tout ce passe bien.
          Cependant, quand j'essaie de de faire un urpmi de gcc-g77-3.4.1-4mdk.i586.rpm, j'ai un message d'erreur qui m'indique que gcc-3.4.1-4mdk n'est pas installé!
          Certains paquetages demandés ne peuvent pas être installés :
          gcc-g77-3.4.1-4mdk.i586 (car gcc[== 3.4.1-4mdk] est non satisfait)

          C'est vraiment la galère ... :op .. ça fait 2 jours que je me prends la tête dessus, alors si tu as une idée ou une âme compatissante....

          Merci et bonne soirée !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.