Forum Linux.mandriva Horloge Bios en UTC et non locale

Posté par .
Tags : aucun
0
2
juil.
2004
J'ai un petit problème avec le réglage de l'horloge avec une Mandrake 10.0 fraîchement installée.

Comme je n'ai plus de Windows sur mon micro, j'ai réglé l'horloge du Bios (ou horloge RTC) en heure universelle, UTC (anciennement GMT), Linux se chargeant de modifier l'affichage selon le fuseau horaire sélectionné. Je précise que ça marche ainsi parfaitement avec une Mandrake 9.1 sur le même micro.

Le problème, c'est que par défaut, Mandrake considère l'horloge Bios comme étant à l'heure locale (dans l'hypothèse de la présence d'un Windows gérant ça aussi mal qu'on le sait). Mais je n'arrive pas à changer ce comportement. Avec la 9.1, j'avais dans l'outil de configuration linuxconf la possibilité d'indiquer que l'horloge locale est en UTC ou local. Je ne sais donc pas comment ce paramètre se change sans Linuxconf (absent de la Mandrake 10.0). Et aucun outil de configuration graphique ne permet de changer ça.

J'ai bien repérer le fichier /etc/adjtime qui contient LOCAL ou UTC (selon la config), mais cette valeur est remise à LOCAL lors du reboot ! Il doit y avoir un programme qui modifie ce fichier.

Comment on change ça ?
  • # La réponse est dans le noyau

    Posté par (page perso) . Évalué à 1.

    Je n'utilise pas la mdk 10, et je ne sais pas quel outil de config peut gérer ça..
    Mais dans le noyau, tu peux changer l'option "RTC stores time in GMT" dans Power Management/APM (ou, si tu le fais à la dure : CONFIG_APM_RTC_IS_GMT=y dans le .config)
    Voili voilou
  • # Re: Horloge Bios en UTC et non locale

    Posté par . Évalué à 5.

    Bonsoir,

    « Je ne sais donc pas comment ce paramètre se change sans Linuxconf »
    C'est dans le fichier /etc/sysconfig/clock que tu dois faire ce paramétrage.

    $ cat /etc/sysconfig/clock
    ZONE="Europe/Paris"
    UTC=true
    ARC=false

    Plus d'informations dans /usr/share/doc/initscripts-*/sysconfig.txt

    Fab.
    • [^] # Re: Horloge Bios en UTC et non locale

      Posté par . Évalué à 1.

      C'est dans le fichier /etc/sysconfig/clock que tu dois faire ce paramétrage.

      Bingo ! C'est bien ça. J'avais jeté un oeil par là, mais j'avais raté ce fichier.

      Merci !
  • # Un petit truc

    Posté par . Évalué à 2.

    Ne te fie pas à l'assistant de configuration de ntp, qui est pas très fiable en ce moment, du moins sur Cooker. Après avoir quitté l'assistant, refais un petit

    # /etc/init.d/ntpd restart

    qui devrait régler le problème.
    • [^] # Re: Un petit truc

      Posté par . Évalué à 1.

      Ah bon!

      j'avais le Pb de mise à l'heure comme je suis pas savant j'ai
      ouvert le config d'horloge , choisi Paris et mise à l'heure par
      serveur ntp

      Ca marche ....pour l'instant alors?

      Bonsoir

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.