Forum Linux.mandriva kmplayer en rade

Posté par  .
Étiquettes : aucune
0
8
sept.
2007
bonjour,

depuis aujourd'hui mon kmplayer est en rade : il refuse de lancer mes fichiers videos
Ce n'est pas mieux avec kaffeine.

j'ai un peu bidouillé, et lorsqu'en console je lance mplayer (pas kmplayer) avec l'option -nosound : pas de problème.

je relance mplayer sans l'option -nosound et j'obtiens ce message :

[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
alsa-lib: pcm_hw.c:1248:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
alsa-lib: pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
alsa-init: playback open error: Device or resource busy
[AO ESD] esd_open_sound failed: No such file or directory
client-conf.c: WARNING: failed to open configuration file '/etc/pulse/client.con f': No such file or directory
AO: [pulse] Failed to connect to server: Connection refused
JACK tmpdir identified as [/tmp]
[JACK] cannot open server
ao_nas: init(): Can't open nas audio server -> nosound
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
alsa-lib: pcm_hw.c:1248:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
alsa-lib: pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
mcop warning: user defined signal handler found for SIG_PIPE, overriding
mcop warning: user defined signal handler found for SIG_PIPE, overriding
AO: [sdl] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
A: 3.0 V: 3.1 A-V: -0.143 ct: -0.008 4/ 4 ??% ??% ??,?% 0 0


Pourquoi ne peut il ouvrir le "sound device" ? il est "busy" : un autre programme s'en sert il ?

Le problème vient il d'Alsa ? et quid du fichier de conf qu'il ne trouve pas ?...

Cela me dépasse un peu, avez vous des suggestions? merci d'avance

Roof
  • # /dev/dsp occupé

    Posté par  . Évalué à 2.

    oui, en effet, /dev/dsp doit être occupé par une autre appli (souvent flash-player).

    Ce que je te conseille :
    - configurer kmplayer d'utiliser alsa au lieu d'oss (suivant ta distrib, plusieurs applis peuvent utiliser le son grâce à alsa)

    Si jamais ça ne fonctionne pas, tu peux savoir qui monopolise ta carte via OSS grâce à la commande :
    lsof | grep /dev/dsp

    Et, si tu veux savoir pour ALSA :
    lsof | grep /dev/snd/
    • [^] # résolu !

      Posté par  . Évalué à 1.

      merci de ta réponse,

      C'était Wengophone qui me prenait ma carte ...

      roof

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.