Forum Linux.mandriva MDK 10.1 / Shuttle SN41G2 - Freezes + retour à l'écran de login

Posté par  .
Étiquettes : aucune
0
13
déc.
2004
Bonjour à tous,

Après divers "googlages" et autres recherches dans les forums et mises-à-jour :

je connais toujours des freezes intempestifs, parfois toutes les applications sont coupées et je me retrouve à l'écran de login...

Mon record d'upload : 4 jours ; certains trouveront que c'est peut-être beaucoup, mais avec XP je fais (malheureusement) beaucoup mieux avec la même config.

Comme je compte utiliser ce poste pour des raisons professionnelles, j'aimerais savoir si qqn avec une config équivalente a réussi à avoir une config stable.

Toute autre piste sera aussi étudiée avec attention, sachant que les aspects hardware ne semblent pas mis en cause (cf. stabilité sous Windo???), que j'ai déjà essayé avec les options no apci et que le driver de Nvidia a plutôt amélioré la situation...


D'avance merci.

Thierry
  • # Vive les titres

    Posté par  . Évalué à 2.

    mandrakefr.org bonjour ( je plaisante bien-sûr),

    MDK 10.1 / Shuttle SN41G2 + je connais toujours des freezes intempestifs, parfois toutes les applications sont coupées et je me retrouve à l'écran de login...

    Ceci semble être la seule description de ton problème, c'est peut-être un peu léger si tu souhaites trouver solution à ton problème.
    M'enfin bon, peut-être as tu déjà posté un message plus explicite dans ce forum ou peut-être n'as tu pas d'informations plus significatives. ( dans ce cas là, avec un peu de chance, les fichiers /var/log/messages, /var/log/* sont tes amis).
    Le Hardware " pourrait être mis en cause " si ton architecture n'était pas bien supportée par le noyau linux.
    Le mieux pour toi serait peut-être de tester une autre distribution afin de savoir si tes problèmes se reproduisent.
    Pour peu que ton disque dur soit assez gros ou si ça ne te dérange pas d'effacer ta Mdk, tu peux par exemple tester une des distrib' suivantes :
    Debian
    Ubuntu
    (Qui a dit que j'étais pro Debian ?)
    Fedora
    Suse
    Slackware
    etc.... ( Je ne vais pas toutes les citer, vive distrowatch et certaines non citées peuvent bien évidemment être plus intéressantes que celles sus-nommées ( ?!?))
    Bref, tes recherches restant sans réponse, tu peux en profiter pour découvrir une ou plusieurs des nombreuses distributions GNU/linux, merci le libre.
  • # Memtest ?

    Posté par  . Évalué à 2.

    Un peu succint comme description m'enfin bon:
    freeze aleatoire => Pb RAM ? => http://www.memtest86.com/(...)

    Apres, que ce soit plus stable sous windows, possible qu'il utilise pas trop la mem a fond... d'experience depuis mes dernieres utilisation de ce vieux truc, ca prefere utiliser le Swap que la RAM (hein? ou ca un troll ?)
    • [^] # Re: Memtest ?

      Posté par  . Évalué à 1.

      il y a longtemps, j'avais du baisser le FSB de 133 MHz a 130 MHz, et tout etait rentre en ordre.

      C'etait le meme type de probleme, et Windows fonctionnait normalement (etrange).

      Il faudrait decrire un peu plus la situation :
      - que ce passe t-il si tu n'as pas de serveur X (ca semble fonctionner puisque tu es delogger, mais tu parles egalement de freeze, qu'entends-tu par freeze) ,
      - es-tu sous Gnome, ou KDE,
      - aRtSd, le serveur de KDE est-il coupe ?
      - si tu crees un nouvel utilisateur, avec le minimum en service, le probleme est-il tjs present ?
      - ecrans de veille ...
  • # ça fait pas avancer le schmilblick, mais ...

    Posté par  (site Web personnel) . Évalué à 3.

    s/upload/uptime

    j'ai du relire pas mal de fois avant de comprendre ...
    car 4j d'upload, c énorme ...
    4j d'uptime, c peu ;-(
  • # Précisions :

    Posté par  . Évalué à 1.

    Il y a effectivement 2 problèmes concurrents :

    1. Freezes aléatoires
    --------------------------
    Dans ce cas, aucune possibilité de reprndre la main (y compris ALT + SYST + R-S-E-I-U-B)

    2. Retour à l'écran de login
    ----------------------------------

    Aussi difficile de déceler la raison, mais conséquences moins graves : il suffit de se relogger (et de récupérer les tâches que j'étais en train d'effectuer)

    Je suis actuellement sous KDE 3.2.3, mais le problème est aussi présent sous Gnome 2.6.

    Je souhaite continuer à utiliser Mandrake pour avoir le choix entre Gnome et KDE le cas échéant.

    Est-il possible qu'une appli (Ex : Amarok) puisse planter l'ensemble du système ?

    PS : pour manatlan, 4 j d'upload et 4 j d'uptime ne sont pas incompatibles, c'est même très fréquent si tu utilises du P2P et que tu restes connecté en permanence.

    Merci pour vos réponses
    • [^] # Re: Précisions :

      Posté par  . Évalué à 1.

      Bonjour,

      J'ai le même problème en PIRE.
      J'ai installé Mandrakelinux 10.1 Official avec tous les updates (j'ai même fais une tentative avec une mise à jour sur Cooker).

      Je boot le PC --> tout va bien.
      Je m'authentifie, KDE démarre nickel.

      A partir de là FREEZE à tous les coups. Je démarre n'importe quelle application tout se bloque sauf la souris qui ne me sert plus à rien.

      CTRL+ALT+SUPP ou tout autre combinaison : rien. Le clavier est mort.


      Par contre, au lieu de démarrer KDE je me connecte en mode console cela marche nickel. Je peux tout faire en mode console sans avoir aucun plantage.

      Malheureusement je ne trouve rien de vraiement signification dans les fichiers de logs: /var/log/messages ....

      PS: j'ai le même problème avec FWVM ...
      PS2: carte video NVIDIA NFORCE2 integrated

      TOUT marchait nickel avec la 10.0 !!!!!!!!!!!!!!!!!!

      Je suppose qu'il y a un problème avec Xorg car je ne vois pas d'autres pistes. Il faut que je fasse une dernière tentative avec X11R6 s'il est toujours dispo sous 10.1.

      Seuls message d'erreur:
      gconfd: Resolved address "xml:readonly:/etc/gconf.xml.mandatory" to a read-only config source at position 0.

      gconfd: Resolved address "xml:readwrite:/home/stiffux/.gconf" to a writable config source at position 1.

      gconfd: Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only config source at position 2.
      • [^] # Re: Précisions :

        Posté par  . Évalué à 1.

        J'ai enfin trouvé que c'est le nouveau serveur X qui pose problème.
        Plus précisément la version Xorg-6.7.0-3mdk fournit avec Mandrake 10.1.

        En forcant la désintallation-réinstallation de XFree86 tout marche bien.

        Voilà pour ceux qui rencontreraient le même problème.

        Bon courage à tous.
        • [^] # Re: Précisions :

          Posté par  . Évalué à 1.

          Salut !

          Je n'ai plus (pour l'instant) de freezes complets (j'ai arrêté d'utiliser arts et sous KDE je n'utilise plus amaroK car les plantages avaient apparemment lieu alors que cette appli tournait).

          Par contre, je rencontre tojours le problème de retour à l'écran de login.

          Pourrais-tu détailler la méthode qui t'as permis de désintaller / réinstaller Xfree86 (d'ailleurs XFree ou Xorg ?)

          Merci et bravo pour ta recherche.

          Thierry
          • [^] # Détails de la manip.

            Posté par  . Évalué à 1.

            Voici les deux lignes à executer en mode console:
            Bien évidemment il faut avoir les medias de Mandrake10.0 pour installer XFree86.

            1- Désinstallation
            rpme --nodeps -e X11R6-contrib-6.7.0-3mdk xorg-x11-server-6.7.0-3mdk xorg-x11-6.7.0-3mdk libxorg-x11-6.7.0-3mdk


            2- Installation
            urpmi XFree86-server libXFree86 X11R6-contrib XFree86


            Voilà cela devrait être bon.

            Bon courage.

            En ce qui concerne le bug Xorg est toujours présent. cf. le bug sur bugzilla:
            https://bugs.freedesktop.org/show_bug.cgi?id=1176(...)

            N'hésite pas je suis preneur d'info si ca marche ou pas dans ton cas.
            @+.
            • [^] # Re: Détails de la manip.

              Posté par  . Évalué à 1.

              Salut,

              J'ai effectué la manip que tu avais indiquée (après avoir ajouté une souce pour les paquets de la Mandrake 10.0) ; mais après la désinstallation de Xorg, XFree n'a pas pu s'installer (problèmes de dépendances à priori).

              Donc ré-installation des paquets Xorg précédemment supprimés et retour du grand méchant bug...

              Je commençais à envisager le passage à Ubuntu (qui utilise XFree) mais je trouve certains softs KDE comme K3B ou amaroK plus aboutis que leurs équivalents Gnome.

              Merci pour ton aide en tous cas ; peut-être existe-t-il une version de XFree compilée pour Mandrake 10.1 ou alors je vais peut-être étudier la méthode pour le compiler sur ma machine à partir des sources.

              To be continued....
              • [^] # Re: Détails de la manip.

                Posté par  . Évalué à 1.

                As-tu essaié de forcer l'installation sans vérifier les dépendances ??

                Bonne année à tous.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.