Forum Linux.mandriva Problème MAJ 10.1 -> 2005 par le réseau

Posté par  (site Web personnel) .
Étiquettes : aucune
0
20
avr.
2005
Bonjour à tous,

J'ai essayé de mettre à jour ma Mandrake 10.1 official en Mandriva 2005 par le réseau via urpmi.

Aprés avoir choisit les bonnes sources grace à easyurpmi, j'ai fait un :

# urpmi urpmi

J'ai mis à jour pas mal de paquetages.

Mais maintenant voila : je ne peut plus faire de urpmi --auto-select, car quand je tape urpmi, j'ai le message d'erreur suivant :

[root@delta darckense]# urpmi
Can't locate URPM.pm in @INC (@INC contains: /usr/lib/perl5/5.8.6/i386-linux /usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.6/i386-linux /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.6/i386-linux /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/vendor_perl/5.8.5/urpm.pm line 16.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.5/urpm.pm line 16.
Compilation failed in require at /usr/sbin/urpmi line 22.
BEGIN failed--compilation aborted at /usr/sbin/urpmi line 22.


Bon, je vois bien qu'il y a un problème avec perl, mais vous savez comment je peut m'en sortir ?
Accessoirement, comment fait-on pour mettre à jour correctement par le réseau ?

Merci pour tout,

Cordialement,


Darckense
  • # Solution

    Posté par  (site Web personnel) . Évalué à 3.

    Télécharges :
    ftp://ftp.free.fr/pub/Distributions_Linux/Mandrakelinux/devel/10.2(...)

    et installe ce paquet avec un :

    rpm -Uvh perl-URPM-1.11-1mdk.i586.rpm

    ça devrais suffire.

    Autrement pour faire une mise à jour proprerement, il suffit tout simplement de faire un :

    urpmi --auto-select


    ça suffit. La première fois il met à jour urpmi tout seul et tout ce qui touche de près au système urpmi, ensuite il redémarre urpmi et continue la mise à jour.
    • [^] # Re: Solution

      Posté par  (site Web personnel) . Évalué à 1.

      Voici ce que cela me donne


      [root@delta darckense]# rpm -Uvh perl-URPM-1.11-1mdk.i586.rpm
      attention: perl-URPM-1.11-1mdk.i586.rpm: signature V3 DSA: NOKEY, key ID 26752624
      erreur: Dépendances requises:
      packdrake >= 5.0.2 est nécessaire pour perl-URPM-1.11-1mdk
      [root@delta darckense]# rpm -Uvh packdrake-5.0.20-1mdk.i586.rpm
      attention: packdrake-5.0.20-1mdk.i586.rpm: signature V3 DSA: NOKEY, key ID 26752624
      erreur: Dépendances requises:
      rpmtools <= 5.0.0 entre en conflit avec packdrake-5.0.20-1mdk
      [root@delta darckense]# rpm -Uvh rpmtools-5.0.20-1mdk.i586.rpm
      attention: rpmtools-5.0.20-1mdk.i586.rpm: signature V3 DSA: NOKEY, key ID 26752624
      erreur: Dépendances requises:
      perl(Config::IniFiles) est nécessaire pour rpmtools-5.0.20-1mdk
      [root@delta darckense]#


      Je tourne en rond... :-/


      Darckense

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.