Forum Linux.mandriva SanDisk Sansa E260 : montage auto impossible

Posté par .
Tags : aucun
0
26
déc.
2007

Bonjour,

Le père noël m'a gaté ... seulement voilà.
Qd je connecte mon Sandisk J'obtiens une fenêtre me demandant quoi fare. Je sélectionne Ouvrir dans une nouvelle Fenêtre.
Le résultat est un message d'erreur :


mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or so

> dmesg | tail
sda: sda1 sda2
sd 2:0:0:0: Attached scsi removable disk sda
sd 2:0:0:0: Attached scsi generic sg0 type 0
Vendor: SanDisk Model: Sansa e260 Rev:
Type: Direct-Access ANSI SCSI revision: 00
sd 2:0:0:1: Attached scsi removable disk sdb
sd 2:0:0:1: Attached scsi generic sg1 type 0
usb-storage: device scan complete
FAT: Unrecognized mount option "uhelper=hal" or missing value
Shorewall:net2all:DROP:IN=eth0 OUT= MAC= SRC= 82.233.99.153 DST= 82.233.99.255 LEN=208 TOS=0x00 PREC=0x00 TTL=64 ID=0 DF PROTO=UDP SPT=631 DPT=631 LEN=188


Ca semble montrer que l'appareil est bien reconnu, mas que la commande de montage utilise une opton moisie.
Si je passe en root, et que j'exécute simplement la commande :
mount /dev/sda1 /media/Sansa\ e260

Tout se passe bien, et je peux accéder (en tant que user) au lecteur, et passer des cp ou faire un glsser/déposer de répertoires ou de fichers mp3.
Reste donc à comprendre comment faire en sorte que le montage par défaut se passe correctement.

En, fait, c'est un pb que je retrouve avec d'autres appareils USB.
Serait-ce un pb d'optons dans un fichier de conf ... mais lequel ?

Ma config est la suivante :
MdV2007.0
Kernel 2.6.17-5
hal-0.5.9-0
Merci à tous, et bonnes fêtes de fin d'année !
J-L
  • # option dans /etc/fstab

    Posté par . Évalué à 1.

    il y a peut-etre une option voire meme une ligne pour sda1 dans ton /etc/fstab

    du coup c'est peut-etre cette ligne qui est prise en compte par le montage automatique.

    à voir.
  • # J'ai aussi un Sansa, je crois avoir ta réponse.

    Posté par . Évalué à 1.

    Je suis sous debian, j'ai aussi un Sansa depuis quelques mois.

    Quand je le branche, il est reconnu et monté.

    Dans mon /etc/mtab j'ai :

    /dev/sdc1 /media/disk vfat rw,nosuid,nodev,noatime,uhelper=hal,flush,uid=1000,utf8,shortname=lower 0 0


    j'ai donc bien le uhelper=hal mais chez moi , aucun problème.

    après quelques recherches google et synaptic, il semblerait que Hal soit en fait le Hardware Abstraction Layer , un truc si j'ai bien tout compris qu'il faut avoir installé ( dans mon synaptic il y est, et il est installé ) pour que ton sansa puisse être monté automatiquement.

    Vérifie que ton Hal ( et ton udev ) sont bien installés et après ça devrait marcher.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.