Journal Démarrage rapide d'OpenOffice.org 2

Posté par  (site Web personnel) .
Étiquettes : aucune
0
26
sept.
2005
Le démarrage rapide d'openoffice.org n'a jamais vraiment existé sous Linux.
Avec la version 2 l'option "quickstart" a été supprimé car elle faisait la même chose que l'option "-nologo -nodefault".
la conséquence c'est qu'il faut patcher le programme de "démarrage rapide" sous KDe: oooqs (pour Gnome je ne sais pas). Les explications et le patch sont là:
http://www.openoffice.org/issues/show_bug.cgi?id=47835(...)

Les malins se contenteront d'un script shell, mais attention quand on quitte OpenOffice.org ça ferme toutes les instances (lisez le commentaire de helmerj à http://www.oooforum.org/forum/viewtopic.phtml?t=21329&highlight(...)

Connaissez-vous d'autres solutions pour accélérer le démarrage de la version 2 (sous Linux)?
  • # d'autres solutions ?

    Posté par  . Évalué à 8.

    abiword ?
    • [^] # Re: d'autres solutions ?

      Posté par  . Évalué à 4.

      Sauf que compare le resultat de :

      $od /dev/urandom | dd of=/tmp/test bs=1024 count=2000
      2000+0 enregistrements lus.
      2000+0 enregistrements écrits.
      2048000 bytes transferred in 0,293050 seconds (6988569 bytes/sec)

      $time openoffice test
      real 0m12.729s
      user 0m5.516s
      sys 0m2.304s

      $time abiword test
      real 1m37.796s
      user 1m26.597s
      sys 0m3.464s

      PS : oui le pb est connu, mais vu que ca impliquerait trop de changement, les developpeur s'en foutent.
      • [^] # Re: d'autres solutions ?

        Posté par  . Évalué à 3.

        Ah, oui, ça c'est intéressant, openoffice est beaucoup plus rapide qu'abiword pour ouvrir un fichier bidon...

        Je peux comprendre que les développeurs n'y accordent pas une très grande importance, surtout si ça implique beaucoup de changements. D'ailleurs, est-ce que tu peux nous en dire un peu plus sur ce problème ?

        Il faut quand même garder à l'esprit que l'équipe de développeurs d'abiword peut probablement se compter sur les doigts d'une main...
        • [^] # Re: d'autres solutions ?

          Posté par  . Évalué à 2.

          Ah, oui, ça c'est intéressant, openoffice est beaucoup plus rapide qu'abiword pour ouvrir un fichier bidon...
          Donc le temps que tu gagnes au lancement, tu le perds lors de l'ouverture du fichier...
          Je peux comprendre que les développeurs n'y accordent pas une très grande importance, surtout si ça implique beaucoup de changements.
          Pourtant ca rend l'utilisation d'abiword tres penible des que tu bosse sur des gros fichiers. D'ailleur ca serait interessant de faire des courbes pour voir a partir de quelle taille abiword est plus lent qu'OOo pour le lancement et chargement...

          D'ailleurs, est-ce que tu peux nous en dire un peu plus sur ce problème ?
          IIRC, abiword charge le fichier par petit morceaux (ou un truc du genre), ce qui n'est pas tres efficace sur des gros fichiers. Faudrait regarder dans le bugzilla.
        • [^] # Re: d'autres solutions ?

          Posté par  . Évalué à 2.

          Ah, oui, ça c'est intéressant, openoffice est beaucoup plus rapide qu'abiword pour ouvrir un fichier bidon...
          J'ai pris un fichier texte pour qu'on me disse pas que c'est le parseur word qui merde...

          Prennons par example le tomeI du comte de Monte-Cristo (http://www.ebooksgratuits.com/newsendbook.php?id=330&format=so(...) )

          $time abiword dumas_monte_cristo_1_source.doc
          real 1m2.901s
          user 0m54.359s
          sys 0m1.204s

          $time openoffice dumas_monte_cristo_1_source.doc
          real 0m24.508s
          user 0m16.409s
          sys 0m0.848s

          Et en prime avec OOo ont a un affichage correct du document word...
          • [^] # Re: d'autres solutions ?

            Posté par  . Évalué à 2.

            Et si tu veux des doments textes, tu peux faire mumuse avec ceux du projet gutemberg....
            • [^] # Re: d'autres solutions ?

              Posté par  . Évalué à 2.

              Non, je te crois :)

              Je pensais que le premier test que tu suggérais n'était pas représentatif.

              Seulement, ce qui m'a fait réagir (un peu vite), c'est « les développeurs s'en foutent ».
    • [^] # Re: d'autres solutions ?

      Posté par  . Évalué à -3.

      gentoo ? :)
    • [^] # Re: d'autres solutions ?

      Posté par  . Évalué à 6.

      abiword ?

      Pour être plus honnête, il faudrait plutôt dire:

      abiword + gnumeric + inkscape + criawips + mergeant
    • [^] # Re: d'autres solutions ?

      Posté par  . Évalué à 1.

      si vous voulez un truc rapide utilisez koffice
      il est compatible openoffice 1 et openoffice oasis
      il se lance très rapidement

      PS:
      "Ok l'interface est pas encore assez compatible avec openoffice ou word"
      "et je trollerais pas sur gnome"
  • # pour Gnome

    Posté par  (site Web personnel) . Évalué à 3.

    En ce qui concerne Gnome, j'ai commencé à réécrire et améliorer l'applet ooqstart-gnome (qui avait gardé du vieux code obsolète et qui marchait plus très bien) et dès que je trouve un peu de temps je vais la faire fonctionner pour OOo2.
    Pour l'instant je m'occupe de faire marcher les autoconf/automake et l'i18n de l'applet. (presque fini).

    Vous pouvez déjà essayer en attendant. Ca marche pour OOo1.1, mais pas encore pour 2.0 (doit pas y avoir gd chose à faire, mais j'essaierai de mettre les icônes en fonction de la version, etc..)

    http://gorfou.fr/contrib/ooqstart-gnome/(...)
    • [^] # OOo2 pour Gnome

      Posté par  (site Web personnel) . Évalué à 2.

      D'après ce que j'ai lu, il faut remplacer l'option "quickstart" par l'option "-nologo -nodefault" et relancer OOo2 quand l'utilisateur quitte une fenêtre

      "La liberté est à l'homme ce que les ailes sont à l'oiseau" Jean-Pierre Rosnay

    • [^] # suggestion sur les icones

      Posté par  (site Web personnel) . Évalué à 2.

      Petite suggestion sans autre prétention que d'aider l'utlisateur novice:
      Tu as remplacé les icones par celles de Ximian, mais que se passe-t-il pour l'utilisateur dont la version d'OOo ne les utilise pas? Ne vaudrait pas mieux aller les chercher dans le répertoire d'OOo ?

      "La liberté est à l'homme ce que les ailes sont à l'oiseau" Jean-Pierre Rosnay

      • [^] # Re: suggestion sur les icones

        Posté par  (site Web personnel) . Évalué à 2.

        oui, pourquoi pas, à condition d'avoir une méthode fiable pour retrouver les icônes d'OOo.

        quoique non, parce que j'utilise des icônes modifiées, et qui dépendent de l'état de l'applet (en démarrage, démarré, arrêté, inconnu).
  • # leeeeeennt

    Posté par  . Évalué à 2.

    autant la version 1.4 est encore acceptable au niveau démarrage (bah, 15 secondes à la première instance... dépend de la machine évidemment), autant les version 2.0 beta que j'ai pu tester étaient terribles de lenteur... J'espère vraiment que cela s'améliorera, par n'importe quel moyen (quitte à avoir moins de fonctionnalités), car là on court à la catastrophe, déjà c'est difficile de faire passer les employés d'une entreprise sous openoffice quand ils ne connaissent que word / excel, si en plus il faut 2 plombes pour charger le logiciel c'est raté d'avance (ici sur le même ordi sous linux version 2.0 = au moins 40-45 secondes de démarrage... c'est fou ce que cela peut être long. Et si on quitte et redémarre, c'est guère moins long).
    En plus les menus s'affiche poussivement, genre comme sur un programme java (sur un celeron 2 Ghz avec 512 Mo de ram, cela fait mal quand même...)

    Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

    • [^] # Re: leeeeeennt

      Posté par  (site Web personnel) . Évalué à 1.

      Par hasard puisque c'est une beta elle ne serait pas compilée avec toutes les options de débuggage activées, ce qui expliquerait une partie de la lenteur observée ?
      (c'est une vraie question).
      • [^] # Re: leeeeeennt

        Posté par  (site Web personnel) . Évalué à 2.

        Il y a un blog de Tinic Uro http://www.kaourantin.net(...) (cf la dépêche "Flash player 8 recherche son ingénieur linux"), surles Betas - à propos de Flash 8 je crois. Il dit qu'une Beta publique n'a _aucune_ option de débogage ou du code volontairement pas optimisé. C'est exactement la même version que la finale, les bogues en plus, c'est tout.
        Il ajoute qu'il faut prévenir les développeurs si c'est lent, ralenti sur un truc particulier, etc. pour qu'ils optimisent.

        "La liberté est à l'homme ce que les ailes sont à l'oiseau" Jean-Pierre Rosnay

        • [^] # Re: leeeeeennt

          Posté par  . Évalué à 2.

          j'avais manqué faire une syncope lorsque j'avais testé les premières bêta tellement c'était lent, j'ai écrit cela sur le forum de ooo (pas pour la syncope, mais la lenteur...), mais visiblement les développeurs considéraient que c'était normal et tout à fait supportable...

          Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.