Journal Installation de Debian sur serveur IBM eserver xseries 336

Posté par .
Tags : aucun
0
16
déc.
2005
Bien que Debian ne soit pas supporté par IBM, la distribution Debian stable (Sarge) s'installe et fonctionne parfaitement sur un serveur IBM server xseries 336.

Le controleur RAID ainsi que la carte réseau sont parfaitement reconnu par l'installeur. Cependant il n'y a rien (ou je n'ai rien trouvé) dans Debian pour interroger le controleur RAID (SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 08)) sur l'état des disques.

Il faut pour cela utiliser cfg1030 ( http://www-307.ibm.com/pc/support/site.wss/document.do?lndoc(...) ) en prenant bien soins de recréer le device, celui ci ayant visiblement changer, avec mknod /dev/mptctl c 10 220.

On peut ensuite interroger ce controleur :

./cfg1030 getconfig 1
Read configuration has been initiated for controller 1
------------------------------------------------------------------------
Controller information
------------------------------------------------------------------------
Controller type : LSI53C1020/1030
BIOS version : 5.04.07.00
Firmware version : 1.03.40.33
SCSI channel description : 1 parallel SCSI wide
Initiator IDs (Channel/SCSI ID) : 1/7
Maximum physical devices : 15
Concurrent commands supported : 222
------------------------------------------------------------------------
Logical drive information
------------------------------------------------------------------------
Logical drive number 1
Status of logical drive : Degraded (DGD)
RAID level : 1
Size (in MB) : 34678
Physical hard disks (Channel/SCSI ID) : 1/0 1/1
------------------------------------------------------------------------
Physical device information
------------------------------------------------------------------------
Channel #1
Initiator at SCSI ID 7
Target on SCSI ID 0
Device is a Hard disk
SCSI ID : 0
State : Online (ONL)
Size (in MB)/(in sectors) : 34715/71096639
Device ID : IBM-ESXSMAU3036NC FNBC11
Target on SCSI ID 1
Device is a Hard disk
SCSI ID : 1
State : Online (ONL)
Size (in MB)/(in sectors) : 34715/71096639
Device ID : IBM-ESXSVPR036C3-ETS10FNS3C0
Target on SCSI ID 8
Device is a Processor device
SCSI ID : 8
State : Standby (SBY)
Device ID : IBM 25P3495a S320 11


Le HOT SWAP fonctionne parfaitement, le RAID est reconstruit automatiquement à l'ajout d'un nouveau disque et l'on peut voir l'état d'avancement :

./cfg1030 getstatus 1
Background command progress status for controller 1...
Current operation : Synchronize
Logical drive in progress : 1
Volume status : Enabled
Volume state : Degraded
Physical disk I/Os : Not quiesced
Logical drive size (in sectors) : 71020544
Number of remaining sectors : 27861509
Percentage complete : 60.77%


Il me reste l'IPMI à faire fonctionner, si quelqu'un à des info...
  • # ipmi

    Posté par . Évalué à 1.

    • [^] # Re: ipmi

      Posté par . Évalué à 3.

      Je demandais ça dans l'optique d'avoir une réponse un peu plus construite, parceque ça, je connais déjà, merci...
      • [^] # Re: ipmi

        Posté par . Évalué à 3.

        En même temps ta question n'est pas pour autant plus construite ou plus detaillée.
        • [^] # Re: ipmi

          Posté par . Évalué à 3.

          Euh si tu connais trois prédicats :
          - ipmi
          - Serveur IBM
          - Debian

          ça peut permettre de construire un peu plus !
          • [^] # Re: ipmi

            Posté par . Évalué à 3.

            A peine , il manque encore les problèmes que tu as rencontrés .
  • # debian stable

    Posté par . Évalué à 2.

    Salut,

    Lorsque j'ai voulu installer debian stable sur mon xseries 345, je n'avais que la moitié des periphs reconnus d'origine. Je suis passé par cet iso : http://wiki.osuosl.org/display/LNX/Debian+on+Dell+Servers?fo(...) qui est un rebuild de woody avec tous les modules récents sata, raid, réseau etc

    Il est compatible avec le 336 (ainsi que de nombreux serveurs), jettes y peut être un oeil pour voir si ton problème n'y serait pas résolu.

    Je l'avais récupéré à la base pour installer un Optiplex GX280 avec que du sata d'origine.
    • [^] # Re: debian stable

      Posté par . Évalué à 2.

      Précision ; la Sarge s'installe désormais parfaitement sur un Optiplex GX280.
    • [^] # Re: debian stable

      Posté par . Évalué à 2.

      Euh non j'ai pas de problème à installer une Debian stable Sarge.
  • # Officieusement

    Posté par . Évalué à 2.

    >Bien que Debian ne soit pas supporté par IBM

    Officiellement;
    Officieusement, ca fait longtemps que les équipes IBM de xSerie et consoeurs installent des Debian, RedHat et autres sur les serveurs IBM (préprod/prod)
    • [^] # Re: Officieusement

      Posté par . Évalué à 2.

      Ca me fait bien rire tout ca.
      Il y a environ 6 mois j'ai eu l'occasion d'installer 2 serveurs xseries identiques pour faire un cluster.

      Une carte mere a rendu l'ame et j'ai du appeler le support. Le mec au bout du fil (en plus d'avoir un accent qui sent bon les vacances à l'étranger) ne connaissait a l'evidence pas Linux (il l'a reconnu lui meme...).

      Plus grave, lors du changement de carte mere, le tech m'a flashe tout ce qui etait flashable (BIOS SCSI diagnostiques) et ... depuis impossible d'activer l'hyperthreading (a config equivalente, le serveur avec la vieille carte a la fonction activee => 1 CPU est vu 2 fois mais ce n'est pas le cas du serveur avec la nouvelle carte). Je leur ai envoye les dmesg cpuinfo et autre mais jamais eu un seul rappel (j'ai toujours un incident ouvert, peut etre qu'en fin d'annee ils me rappeleront lorsqu'ils vont tenter de clore leurs incidents ;).

      Bilan ca m'a bien casse le mythe IBM qui fait de la pub Linux dans tous les sens (equipe de basket au nom avec joueur Linux etc etc). Pour moi tout ca, cela reste de la com'.
      • [^] # Re: Officieusement

        Posté par . Évalué à 4.

        IBM c'est gros. Croire qu'une boite pareille va adpoter une techno d'un bloc, quelle qu'elle soit, avec compétence et savoir faire est illusoire.
        • [^] # Re: Officieusement

          Posté par . Évalué à 3.

          en même temps, ça fait des années qu'ils s'y sont collés, 5 ans sinon plus

          alors que la personne qui décroche le téléphone avant d'aiguiller vers une autre ne soit pas spécialisée dans ce domaine, pas grave, mais faudrait que ça suive derrière

          or ils ne semblent même pas avoir rappellé la personne ni même accusé réception, ce qui ne nécessite pas de compétence technique spéciale...
  • # plus d'infos ?

    Posté par . Évalué à 2.

    type de la carte mere ?
    intel ? BMC standard ou module professional / advanced ?
    supermicro ? avec module 1.5 ou 2.0 ?

    et donne moi le output de dmidecode au passage.
  • # BMC pourri

    Posté par . Évalué à 2.

    Moi j'ai de gros problèmes avec le chip BMC de ces Xseries recents.
    le chip utilise la premiere interface réseau pour communiquer, et pour cela "forge" une adresse mac différente de l'adresse normale de la carte. (la carte a 2 mac adresse si vous voulez).
    résultat: => pertes de paquets quand BMC s'active, bazar sur le réseau avec les fonctions de sécurité (controle des mac address sur le switch ...).
    Le plus fort, c'est que le chip BMC continue ses merdoiement meme après l'avoir désactivé dans le Bios.

    Résultat: ces xseries ont 2 interfaces ethernet mais seule la seconde se comporte correctement.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.