Seb a écrit 10 commentaires

  • # ...

    Posté par (page perso) . En réponse au message Dual boot : Debian/W7 - problème de boot sous W7. Évalué à 1.

    Bonjour,

    merci beaucoup de vos réponses.

    • @Olivier

    1) Effectivement, j'ai aussi pensé à un blocage de la part de Windows. Comme tu me l'as redis, j'ai décidé de poser la question directement au constructeur.

    2) Si j'ai bien compris, Windows boote à partir du /dev/sdb3 "System Reserved" qui est sur le SSD. Et c'est dans cette partition qu'il faudrait changer une instruction : "va booter sur le /dev/sda3 du HD" en "va booter sur le /dev/sdb4 du SSD".

    Aussi, d'après ce que j'ai cru comprendre du fonctionnement de grub2 / drivemap, je ne pense pas que cela permettra grand'chose.

    • @NeoX

    J'ai copié Windows en faisant une copie de partition par GParted. Je souhaite éviter de réinstaller Windows à zéro parce que j'ai fait beaucoup de modif dessus. De plus, je ne suis pas sûr que je puisse le refaire… (fichiers d'install, tatouage, etc.)

    boot.ini est maintenant bootmgr.dll (cf. ici)

    Je pense qu'avec easybcd, c'est cela qu'on modifie. Malheureusement, comme je l'ai dit, mes modifs n'ont pas marché pour le moment !

  • [^] # Re: oui mais

    Posté par (page perso) . En réponse au message Parted Magic : clonage impossible de Windows pour un dual boot. Évalué à 0.

    Ok merci beaucoup… Je vais me pencher là-dessus dès que j'ai plus de temps !

  • [^] # Re: oui mais

    Posté par (page perso) . En réponse au message Parted Magic : clonage impossible de Windows pour un dual boot. Évalué à 0.

    C'est ce que fait la session recovery, non ? Sinon, je dois bien avoir les CD d'install quelque part mais je voulais éviter cela car j'ai installé et beaucoup configuré Windows pour l'alléger et j'ai pas trop envie de repartir de zéro…

    Je pense que je vais faire une image sur un DD externe, redimensionner cette image puis la cloner. Si j'y arrive…

  • [^] # Re: oui mais

    Posté par (page perso) . En réponse au message Parted Magic : clonage impossible de Windows pour un dual boot. Évalué à 1.

    ntfsfix /dev/sda3
        Mounting volume... OK
        Processing of $MFT and $MFTMirr completed successfully.
        Checking the alternate boot sector... FIXED
        NTFS volume version is 3.1.
        NTFS partition /dev/sda3 was processed successfully.
    

    Mais malheureusement, ça n'a rien changé…

    J'ai essayé de faire un "Vérifier" sous Gparted mais…

    ntfsresize -P -i -f -v /dev/sda3
    
    ntfsresize v2012.1.15AR.5 (libntfs-3g)
    Device name : /dev/sda3
    NTFS volume version: 3.1
    Cluster size : 4096 bytes
    Current volume size: 438729994752 bytes (438730 MB)
    Current device size: 438730000384 bytes (438731 MB)
    Checking for bad sectors ...
    Checking filesystem consistency ...
    Cluster 33582503 is referenced multiple times!
    Cluster 33582504 is referenced multiple times!
    (...)
    Cluster 39857453 is referenced multiple times!
    Cluster 39857454 is referenced multiple times!
    Cluster 39857455 is referenced multiple times!
    ERROR: Filesystem check failed!
    ERROR: 20 clusters are referenced multiple times.
    NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
    The usage of the /f parameter is very IMPORTANT! No modification was
    and will be made to NTFS by this software until it gets repaired.
    
  • # oui mais

    Posté par (page perso) . En réponse au message Parted Magic : clonage impossible de Windows pour un dual boot. Évalué à 1. Dernière modification le 30/08/13 à 00:11.

    Merci de vos réponses. Entre temps, j'ai installé Debian et enlevé Ubuntu.

    lelent > ça m'a mis sur une piste. Malheureusement, je n'arrive plus à lancer Windows (seule la session Windows recovery se lance). Le grub le reconnait bien mais au lancement, cela bloque sur un curseur blanc clignotant sur fond noir :-( Serait-ce dû au fait que j'ai déplacé une partition "System Reserved" de 100 Mo d'un disque à l'autre ?

    NeoX > c'est effectivement ce que j'ai cherché à faire mais comme je dis, sous Gparted, il y a un cadenas à côté de la partition Windows (/dev/sda3) qui visiblement m'empêche de la redimensionner.

    N'étant utilisateur que très occasionnel de Windows (montage vidéo), je ne suis pas dans l'urgence mais j'aimerais tout de même pouvoir régler ce problème !

  • [^] # Re: debut de solution

    Posté par (page perso) . En réponse au message générer des documents aléatoires (quiz) à partir d'une base. Évalué à 0.

    effectivement, il ne sert à rien. Mais l'enlever ne produit pas de retour à la ligne non plus…

  • [^] # Re: debut de solution

    Posté par (page perso) . En réponse au message générer des documents aléatoires (quiz) à partir d'une base. Évalué à 1. Dernière modification le 23/03/12 à 23:27.

    Tu as raison, NeoX, je vais finalement utiliser shuf.

    Donc un truc qui va ressembler à ça :

    #! /bin/bash
    
    echo "début" > test.txt
    
    for ((i = 0; i <= 60; i += 1))
    do
    echo "Nom/Prénom : .................." >> test.txt  
    echo `shuf -n 6 base-questions.txt` >> test.txt
    done
    
    

    puis copier-coller dans openoffice en se débrouillant pour les QCM aient tous le même format (sinon LaTeX effectivement, lenod).

    Par contre,

    echo `shuf -n 6 base-questions.txt` >> test.txt 
    
    

    ne fait pas de renvois à la ligne alors qu'avec

    shuf -n 6 base-questions.txt 
    
    

    toutes les questions sont chacune sur une ligne différente. Ce n'est qu'un problème très mineur, juste une interrogation…

  • # merci

    Posté par (page perso) . En réponse au message lecture vidéo par un vidéoprojecteur. Évalué à 1.

    ok, merci, je teste ça la prochaine fois :-)
  • [^] # Re: debian stable

    Posté par (page perso) . En réponse au message Install Linux sur un vieux portable 48Mo RAM. Évalué à 1.

    En fait, y'a même pas de place pour une carte PCMCIA :(

    Bon alors les geeks pas de solutions ?? :D
  • [^] # Re: debian stable

    Posté par (page perso) . En réponse au message Install Linux sur un vieux portable 48Mo RAM. Évalué à 1.

    si ! de même qu'acheter un carte PCMCIA ethernet pour résoudre le problème. Ceci dit, j'aimerais éviter d'avoir à faire des frais sur cet ordinateur. Et dépenser une quarantaine d'euros pour de la mémoire + une vingtaine pour une carte me semble être trop élévé pour cet ordi.

    D'où ma demande de conseils...