Journal xfce4 et gentoo

Posté par (page perso) .
Tags : aucun
0
23
sept.
2003
Bonjour mon hournal et ses lecteurs,

Est-ce que quelqu'un sait comment faire pour installer des paquet "masqué", comme xfce4 par exemple, dans une gentoo?
  • # Re: xfce4 et gentoo

    Posté par . Évalué à 1.

    idem pour openldap 2.1.22 et ses dépendances

    le seul moyen que j'ai trouvé c'est de préciser le .ebuild directement mais c'est naze, à la première dépendance masquée il me tej, il faut que je fasse tout à la main -> pas envie
    • [^] # Re: xfce4 et gentoo

      Posté par (page perso) . Évalué à 3.

      Non, dans gentoo il y a un prcédé qui permet de démaqué des paquet... Et qui a été fait pour ca :)

      Tous les pacquets masqués sont dans /usr/portage/profile/package.mask

      Si tu enleves dans ce fichier xfce4, ca te le mettra en non masqué. Le problème, c'est qu'a la prochaine synchronisation, ce fichier est écrasé, et tout repasse en masqué.
      Le moyen pour résoudre ça c'est de spécifié tes propres paquets masqués et démasqué qui viendra surcharger celui par défaut.

      Ces fichiers sont : /etc/portage/package.mask et /etc/portage/package.unmask (à créer s'ils n'existent pas encore)

      Donc, dans ton cas tu rajoutes :
      >=x11-wm/xfce-4 dans /etc/portage/package.unmask, et ca te démaquera tout les xfce supérieur ou égal à la version 4 (je dis ca de tête donc le nom du paquet tdoit etre légèrement différent)
      • [^] # Re: xfce4 et gentoo

        Posté par . Évalué à 1.

        et ca demasque les paquets dont il dépend ?

        parce que sinon je vois pas l'intrêt par rapport à un
        emerge /usr/portage/x11-wm/xfce-4.truc.ebuild

        (a part s'entrainer a taper au clavier)
  • # Re: xfce4 et gentoo

    Posté par . Évalué à 3.

    Pour passer en gentoo dit instable il suffit d'ajouter dans le /etc/make.conf
    ACCEPT_KEWORD="~x86"

    Sinon un
    #ACCEPT_KEYWORDS="~x86" emerge nomDuMachinAInstaller
    pour installer nomDuMachinAInstaller et les dépendance en dit "instable"
    • [^] # Re: xfce4 et gentoo

      Posté par (page perso) . Évalué à 2.

      Je répond à ce post pour compléter celui que j'ai écris en dessus.
      En effet, Nimlar a raison, pour accepter les paquets instable, il faut appliquer la procédure qu'il a décrite.

      La procédure que j'ai donné plus haut sert au cas où tu te trouves déjà en instable et que tu souhaites vraiment utiliser des paquet masqués (donc encore plus instable que ~x86)
    • [^] # Re: xfce4 et gentoo

      Posté par . Évalué à 1.

      ca ne marche pas pour openldap par exemple
      • [^] # Re: xfce4 et gentoo

        Posté par (page perso) . Évalué à 1.

        Chez moi openldap n'est ni masqué, ni unstable :)
        Mais bon generalement quand un truc est en unstable, c'est qu'il a ete un minimum verifie, mais que les merdes peuvent arriver, et quand il est masqué, c'est que ya une bonne raison :)
        • [^] # Re: xfce4 et gentoo

          Posté par . Évalué à 1.

          ah bon, chez toi openldap version 2.1.22 est ni masqué, ni unstable ???
  • # Re: xfce4 et gentoo

    Posté par (page perso) . Évalué à 1.

    Merci à Nicolas Antoniazzi et Nimlar pour l'aide.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.