Journal Cohabitation module-init-tools et modutils

Posté par .
Tags : aucun
0
21
fév.
2004
Comme beaucoup d'autres, je suis en train d'essayer le noyau 2.6(.3).

Et comme d'autres, j'ai compris qu'il fallait installer module-init-tools pour gérer le nouveau format de modules.

Et j'ai aussi constaté que module-init-tools ne gérait pas les modules du noyau 2.4 (ce qui est à priori un peu surprenant).

Il faut donc les faire cohabiter ensemble. Oui, mais comment fait-on pour faire cohabiter 2 outils qui utilisent les mêmes noms : lsmod, insmod, modprobe ????

Je pourrais nommer différement les 2 séries de programmes, mais je ne vois pas comment chaque noyau (le 2.4 et le 2.6) devineront tout seul quel programme utiliser ...
  • # Re: Cohabitation module-init-tools et modutils

    Posté par . Évalué à 2.

    Les module-init-tools appellent les modutils quand ils ont affaire à un module de version <2.6.
    • [^] # Re: Cohabitation module-init-tools et modutils

      Posté par (page perso) . Évalué à 1.

      sous debian cela semble etre le cas...
      sous mandrake, ils utilisent les alternatives.
      • [^] # Re: Cohabitation module-init-tools et modutils

        Posté par (page perso) . Évalué à 1.

        Bon... je sens que je vais le compiler ce 2.6.3... ;)

        par contre a chaque fois que je reboote sur un nouveau noyau (la j'ai 2.4.22, j'ai essayé le 2.4.24) il me trove toujours des nouveaux periphériques, a savoir :
        une floppy (OK)
        et 8 lecteur/graveur de Cd-rom qui sont tous le même...

        Je Comprends rien à ce qu'il se passe et a chaque fois c'est l'attent qu'il configure tout... c'est du a quoi ?

        (hardrake ?)
  • # Re: Cohabitation module-init-tools et modutils

    Posté par . Évalué à 2.

    Il faut donc les faire cohabiter ensemble. Oui, mais comment fait-on pour faire cohabiter 2 outils qui utilisent les mêmes noms : lsmod, insmod, modprobe ????
    man modprobe (ou ce que tu veut dans les module-init-tools)

    BACKWARDS COMPATIBILITY
    This version of modprobe is for kernels 2.5.48 and above. If it
    detects a kernel with support for old-style modules (for which much of
    the work was done in userspace), it will attempt to run modprobe.old in
    its place, so it is completely transparent to the user.
    • [^] # Re: Cohabitation module-init-tools et modutils

      Posté par . Évalué à 1.

      j'oubliais "make moveold" pour faire le renomage (cf le readme...)
      • [^] # Re: Cohabitation module-init-tools et modutils

        Posté par . Évalué à 1.

        j'oubliais "make moveold" pour faire le renomage (cf le readme...)

        J'avais apperçu ça dans le readme, mais je n'avais pas compris que module-init-tools les utilisait pour gérer les anciens modules.

        J'étais en train d'en faire un RPM pour moi (1), mais je crois que je vais faire une exception ...

        (1) : je commence à prendre l'habitude de faire des RPMs des sources que je télécharge pour garder un système de package cohérent.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.