Journal Pb sources noyau Debian

Posté par  .
Étiquettes : aucune
0
11
août
2005
Cher journal

Ayant repris mon cher manchot apres plusieurs mois d'oubli (suite a des soucis de disque dur sur le portable, et apres remplacement aupres du constructeur), me voici confronté à un (sérieux) problème:

Reprenant le fichier de config de mon 2.6.10(car ayant perdu toutes mes données, n'ayant gardé que quelques fichiers de config), je l'applique aux sources debian 2.6.11.7 . Résultat = ne compile pas.
J'essaie ensuite avec des sources de 2.6.10 = ne compile tjs pas

J'obtiens a chaque fois des erreurs sur la configuration du port série, ou de I2C (lié je pense au framebuffer de ma carte ATI, option que je sélectionne dans le noyau)

Me voici donc coincé a ce niveau la.

Ni une, ni deux, j'essai de prendre les sources (2.6.12.4) depuis kernel.org, j'applique mon fichier de configuration, et ca compile comme un charme. Malheureusement, (du a ma grande ignorance), je ne suis jamais arrivé a utiliser un kernel non compilé depuis les sources Debian (support du cramfs par exemple, ou creation d'une initrd)


Cher journal, pourrais-tu m'aider a voir plus clair ou devrais-je ceder a la tentation et essayer de mettre une gentoo a la place (car l'envie me demange depuis un certain temps)

PS: est-ce moi ou Debian a "quelques" soucis en ce moment? J'ai une moins grande "facilité" d'utilisation qu'avant, dépendances cassées, pas de sources pour le 2.6.12 meme en unstable... (PS2: ce n'est PAS un troll, juste une demande d'avis)
  • # 2.6.12

    Posté par  . Évalué à 5.

    pas de sources pour le 2.6.12 meme en unstable...

    Si, ils ont changé le nom :
    linux-source-2.6.12
    linux-image-*

    Essaie le debian_source_2.6.12. Tes problèmes sont peut-être liés à gcc4.
    • [^] # Re: 2.6.12

      Posté par  . Évalué à 2.

      GNNN?!? Bon sang mais c'est vrai!!
      Je ne me souviens pas avoir lu quoi que ce soit à propos de ça dans la newsletter! Si ce n'est pas une erreur de ma part, comment était-on censés avoir l'information? (pas de troll, je ne changerais ma debian pour rien au monde, et non, "rien au monde", ce n'est pas la prochaine version d'ubuntu ou quoi que ce soit ;) )
      • [^] # Re: 2.6.12

        Posté par  (site Web personnel) . Évalué à 4.

        J'ai découvert aussi ce changement après deux mois d'interrogation comme toi. La réponse est passée sur la liste debian-kernel[1].

        Et ce sera dans la DWN de mardi prochain[2].

        [1] http://lists.debian.org/debian-kernel/2005/07/msg00192.html(...)
        [2] http://www.infodrom.org/~joey/Writing/DWN/dwn-2005-33.html(...)
      • [^] # Re: 2.6.12

        Posté par  . Évalué à 1.

        On est en 2.6.12-2 maintenant. La première version 2.6.12-1 est dans unstable depuis le 21 juillet !
        De mon coté, j'utilise synaptic. Quand je fais un update, synaptic permet de voir les nouveaux paquets que je regards toujours. Sinon un changement important comme ça, on en parle(ra) certainement dans la newsletter.
        • [^] # Re: 2.6.12

          Posté par  (site Web personnel) . Évalué à 2.

          J'ai essayé de passé en 2.6.12 (j'était en 2.6.11). Mais je suis retourner sur mon ancien noyau. En effet j'utilise du NAT, et en 2.6.12 il ne marche plus pareil (c'est l'impression que j'en ai)

          Voilà ce que je dit dans mon NAT.

          Toute les connections sortante vers le port 110 sont retourner en localhost sur le port 8110

          Toute les connections sortante vers le port 110 de l'utilisateur p3scan sont accepté (et donc pas redireger).

          Apperement cette dernière règle ne passe pas, ce qui fait que p3scan se reconnecte sur lui même en boucle en 2.6.12 (alors que c'est nickel en 2.6.11).

          J'ai verifié et apperement les bonnes options du noyau sont bien activé.
  • # Dépendances cassées...

    Posté par  . Évalué à 5.

    Oui, en ce moment un bon nombre de paquets sont cassés, pour deux raisons majeures : le passage à Xorg et le passage à gcc 4.
    Il y a encore beaucoup de paquets à recompiler (notamment ceux qui dépendent directement de la xlib), ce qui demande pas mal de boulot, mais ça avance ;)
  • # GCC ?

    Posté par  . Évalué à 3.

    Si jamais ton problème est lié à l'utilisation de GCC 4, et que tu en as un autre, par exemple le 3.3, tu peux essayer un:
    make CC=gcc-3.3 HOSTCC=gcc-3.3 bzImage
    • [^] # Re: GCC ?

      Posté par  . Évalué à 2.

      Il me semble que ca ne marchera pas. Je crois (et je crains) que l'appel specifique a 'gcc' est hardcodé dans le Makefile. Donc il faut éditer le fichier directement.
      • [^] # Re: GCC ?

        Posté par  . Évalué à 6.

        Ah si, ça marche, c'est une certitude. Par contre je ne sais pas si son problème vient de là.

        Le fonctionnement de make est un peu traître, car les variables ressemblent à des variables d'environnement. On aurait donc envie de faire:
        > CC=gcc-3.3 HOSTCC=gcc-3.3 make bzImage
        Et ça, effectivement, ça ne marche pas, car il s'agit de variables qui sont définies dans le makefile. Par contre,
        > make CC=gcc-3.3 HOSTCC=gcc-3.3 bzImage
        indique à make la valeur que l'on veut donner à ces variables.
        • [^] # Re: GCC ?

          Posté par  . Évalué à 2.

          Les traitres ! J'ai trop l'habitude des autotools, on dirait. Et en prime j'ai ete pris en traitre par le patch pour le noyau d'Ubuntu (qui modifie les valeurs dans le fichier directement).

          mea maxima culpa, donc, et merci de l'info. :)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.