mike.simonson a écrit 42 commentaires

  • # top notch conference

    Posté par . En réponse à la dépêche ConFoo 2019 : la conférence pour les développeurs est à la recherche de conférenciers. Évalué à 2.

    Pour information, j'ai déjà été sélectionné par deux fois à cette conférence.
    C'est sans le moindre doute la conférence à laquelle j'ai participé où les intervenants sont le mieux traité/dorloté.
    Si vous êtes plutôt intéressé par y aller en tant que visiteurs, j'ai particulièrement apprécié la mixité de langage. C'est particulièrement enrichissant d'apprendre comment des problèmes similaires sont approchés dans d'autres communautés.

  • [^] # Re: pbkdf2

    Posté par . En réponse au journal Publication de WKR. Évalué à 2.

    Si tu vas sur la page de la doc de hash_pbkdf2 tu verras qu'il est recommandé d'utilisé à la place la fonction password_hash.
    L'avantage de password_hash sur crypt ou hash_pbkdf2 c'est que c'est plus une interface de génération de hash prévu pour être compatible avec des changements de primitive de hash dans le futur (pour plus de sécurité).

    Même si tu prévois de ne plus utilisé le hachage coté serveur, c'est une alternative bien meilleure.
    Et la beauté de la chose veut qu'une âme généreuse et fait une implémentation en php de cette lib pour la rendre accessible sur php 5.3 et 5.4.
    Çà ne devrait pas vous dispenser de faire la mise à jour mais c'est toujours mieux qu'utiliser autre chose.

  • # maigre résultat de chasse

    Posté par . En réponse au journal Edward Snowden mis à nu sur internet (bookmark le monde). Évalué à 5.

    Je suis le seul à penser qu'ils n'ont justement à peu prêt rien retrouvé ?

    Peut-être que l'article du monde a été mis à jour mais quand je l'ai lu hier à part les photos de sa copine il n'y avait à peu prêt rien sur lui. En tout cas rien de comparable à l'article que le Tigre avait il y a quelque année.

    PS: kudo pour les admins et dev de linuxfr c'est le seul site qui est parfaitement accessible depuis la connexion wifi pourrie du ID bus.

  • # icône / logo ??

    Posté par . En réponse à la dépêche LibreOffice se met en 4.0. Évalué à 5.

    Sans vouloir faire mon inculte, quelle est le dernier logo dans la liste ?
    C'est pour les extensions ?
    Impossible de trouver ce logo sur le site de LibreOffice ou pas évident en tout cas.

  • [^] # Re: un reglage dans le bios ne suffirait pas ?

    Posté par . En réponse au message ASPM problem on a Primergy RX 300 S5. Évalué à 0.

    Effectivement, l'idée était très bonne mais il n'y avait aucun réglage lié à ça dans le bios même de loin.

    Maintenant le problème est p-e lié au matériel pcq qu'on à déplacé les disques dans une autre machine et ça boot sans broncher.

    Merci pour l'idée en tout cas

  • # Not fixed

    Posté par . En réponse à la dépêche Cuvée 18 pour Firefox et Firefox Mobile. Évalué à -4.

    Un bug vieux de plus de 12 ans a été corrigé

    J'ai testé et je confirme que le bug n'est pas corrigé.
    Je laisse le troll aux autres…

  • [^] # Re: forum != support

    Posté par . En réponse au message un petit up ? samba kernel lock up. Évalué à 1.

    Effectivement, c'est fuse qui est responsable du crash, tout est rentré à la normale quand je l'ai tué.

  • [^] # Re: forum != support

    Posté par . En réponse au message un petit up ? samba kernel lock up. Évalué à 1.

    Pour le moment j'essaie simplement de savoir à qui je dois envoyer le rapport de bug.

    Tes conclusions sur fuse sont donc précieuse pour moi et en plus elles collent avec l'impression que je en avais.

    Personnellement je n'utilise pas Fuse, mais on dirait que c'est ça que nautilus utilise quand on passe par la fonctionnalité "Browse Network". Ça pourrait aussi expliquer pourquoi ce problème n'est pas encore survenu quand je lis les films avec xbmc.

    Maintenant je dois trouver la combinaison de touche qui active sysrq sur mon clavier et rediriger le résultat de t dans un fichier ???
    Ensuite je pourrai faire un rapport de bug exploitable par gnome et fuse.

    Merci beaucoup

  • [^] # Re: backtrace or it didn't happen

    Posté par . En réponse au message samba kernel lock up. Évalué à 0.

    Bon tout vient à point à qui sait attendre.

    Alors dans un premier temps c'est totem qui a planté et j'ai essayé de relancer la vidéo dans vlc et smplayer mais ils se sont tous plantés à l'ouverture du fichier.

    Voici les différentes informations que j'ai pu extraire.

    la stack de totem
    la stack de vlc
    la stack de smplayer

    Ensuite, après un redémarrage totem c'est à nouveau planté au début de la vidéo (quelques secondes tout au plus) mais smplayer à fonctionné sans soucis.

    Ici il y a toutes les informations que j'ai essayé d'extraire de /proc/$pid/…
    la stack de totem autre crash
    fichier sched
    le fichier io
    le fichier maps

    J'ai également le pagemap, exe et environ mais c'est un peu plus compliqué à partager pcq ça affiche bcp de null dans les pastes. Si tu en as besoin je ferai les conversions nécessaires.

    Merci beaucoup pour vos lumières.

  • [^] # Re: Faibles perfs pour Btrfs

    Posté par . En réponse au journal [Filesystem] Benchmark SSD vs HDD. Évalué à 2.

    Pas de bol les 5% en question c'est les admin sys donc si ils trouvent que ça leur simplifie la vie ce sera çà.
    Il se contenteront de mettre un disque de plus dans la grappe pour que tu ne sentes pas la différence de performance.
    Ça coûte pas cher un ou deux disque à coté d'un admin sys.

  • [^] # Re: backtrace or it didn't happen

    Posté par . En réponse au message samba kernel lock up. Évalué à 0.

    sysrq-t n'est pas installé par défaut chez moi on dirait mais apparemment un simple cat sur /proc/$pid/stack suffit.

    Waiting for the bug ….

  • [^] # Re: backtrace or it didn't happen

    Posté par . En réponse au message samba kernel lock up. Évalué à 0.

    Ouf merci.

    Je finissais pas croire que je n'arriverais jamais à avoir le mot de la fin.

    Quelle commande exactement je dois faire tourner pour obtenir une stacktrace d'un processus ? Apparemment il faut gdb c'est ça ?

    Après je ne suis pas certain d'avoir des résultats tout de suite vu que pour le moment ça à l'air très aléatoire.

    Merci bcp

  • [^] # Re: Solution de contournement

    Posté par . En réponse au message samba kernel lock up. Évalué à 0.

    C'est quoi le délire, qui à parler de faire ça sur le lieu de travail?!?

  • [^] # Re: Solution de contournement

    Posté par . En réponse au message samba kernel lock up. Évalué à 1.

    Je n'ai pas essayé mais c'est a tenter.

  • [^] # Re: probleme similaire ici

    Posté par . En réponse au message samba kernel lock up. Évalué à 2.

    Effectivement j'ai remarqué que le lien avait changé et que toute la partie après server était assez bizarre et problèmogène mais dans ce cas je ne comprend pas pourquoi ça fonctionne pendant une demi heure de film puis ça se plante tout d'un coup.
    Je regarde certain film sans problème et d'autre je n'arrive même pas à les lancer.
    Ce n'est pas un problème dans le nom de fichier parce que le problème touche des fichiers avec des nom qui ne contienne que de l'ascii bien standard.

  • [^] # Re: lsof ?

    Posté par . En réponse au message espace disque qui est grignoté. Évalué à 1.

    Donc en gros pour trouver ce genre de problèmes un petit coup de lsof et de awk derrière avec les options qui vont bien pour lister par taille.
    On redémarre le processus qui utilise ce fichier de log (puisqu'on dirait que c'est surtout les logs qui sont concernés) et hop problème résolu.

    c'est plus malin donc de d'abord stopper le processus, puis effacer son fichier de log que le contraire où on oublie de stopper le processus.

    Merci

  • [^] # Re: lsof ?

    Posté par . En réponse au message espace disque qui est grignoté. Évalué à 1.

    Et maintenant la question qui me taraude.
    Comment on en est arrivé là ?
    Je ne comprend pas bien le rapport avec le fichier effacé mais pas fermer.

    En gros ma question c'est surtout comment on évite de se trouver dans des situations comme celle-là.

    Merci d'avance pour vos réponses qui vont illuminer ma lanterne j'en suis sur.

  • # html ?

    Posté par . En réponse au message Des maths et du texte. Évalué à 0.

    Si tu fais ton rendu en HTML, tu peux regarder de ce coté.
    C'est vraiment bien foutu, c'est pas parfait mais pour du web c'est le moins contraignant que j'ai trouvé.

    Je pense que l'entré en ascii math t'intéressera.

    Bonne recherche

  • [^] # Re: Un détail

    Posté par . En réponse au journal Des firmwares, des backdoors et du libre. Évalué à 5.

    J'ai l'impression que vous avez un peu loupé le l'idée du papier.
    L'idée c'est que si le fabriquant ( la chine ) décide de mettre se genre de backdoor dans le matériel on n'a "aucun moyen" de contourner le problème. Et on s'en rendra compte quand ce sera trop tard.

    C'est aussi valable si il y a un seul employé du fabriquant qui décide de jouer au plus malin et ça c'est déjà produit. Je me rappelle d'une histoire d'en le genre un lecteur mp3 qui était fourni par l'usine avec un firmware qui infectait la machine.

  • [^] # Re: Ca me rappel un truc ca...

    Posté par . En réponse au message Saga d'une installation d'ubuntu sur un mac 3.1. Évalué à 0.

    voici la trace de startx.

    obtenu avec

    strace -fv -o /tmp/trace_startx startx
    
    
  • [^] # Re: Ca me rappel un truc ca...

    Posté par . En réponse au message Saga d'une installation d'ubuntu sur un mac 3.1. Évalué à 0.

    insmod /lib/modules/3.2.0-26-generic/updates/dkms/nvidia_current.ko

    la trace du chargement.

    Je n'ai pas l'impression que ce soit le chargement du module nvidia dans le noyau qui soit un problème mais plus son "activation".

  • [^] # Re: Ca me rappel un truc ca...

    Posté par . En réponse au message Saga d'une installation d'ubuntu sur un mac 3.1. Évalué à 0.

    Oui c'était fait quand j'ai testé cette méthode.
    Je me demande ce qui se passe pour que je n'arrive même pas à provoquer une autre d'erreur.

  • [^] # Re: Ca me rappel un truc ca...

    Posté par . En réponse au message Saga d'une installation d'ubuntu sur un mac 3.1. Évalué à 0.

    Il est sur le bus PCI:1:0.0:0 .
    Mais il semble que quand on spécifie le BusID il faut retirer le ".0" .

  • [^] # Re: Ca me rappel un truc ca...

    Posté par . En réponse au message Saga d'une installation d'ubuntu sur un mac 3.1. Évalué à 0.

    Le tail -f syslog complet.

    acpid: client 1577[0:0] has disconnected
    acpid: client connected from 2059[0:0]
    acpid: 1 client rule loaded
    kernel: Failed to copy vbios to system memory
    
    
  • [^] # Re: Ca me rappel un truc ca...

    Posté par . En réponse au message Saga d'une installation d'ubuntu sur un mac 3.1. Évalué à 0.

    C'est de plus en plus bizarre.

    Quand je fais lsmod, je vois que le driver nvidia est chargé (SIZE 10888310 Used by 0).
    Par précaution je l'ai quand même enlevé (rmmod) et reloader (modprobe).

    Mais le log de Xorg me dit toujours "Failed to initialize the nvidia GPU at PCI:1:0:0.
    Et le tail -f syslog me donne la même erreur également "Failed to copy vbios to system memory".

    Je vais essayer avec un vmalloc plus grand on verra si ça change quelque chose.