Journal Déclaration d'impôts 2008 sous Linux

Posté par  .
Étiquettes :
0
18
mai
2008
Un petit journal pour ceux qui, comme moi, n'arrivent pas à signer leur déclaration d'impôts avec leur distrib préférée.

J'ai parcouru quelques pages de forum qui donnent des recettes diverses et variées pour que ça marche. Pour la plupart il faut réinstaller à la mano un Firefox 2 et une JVM Sun. Et même avec ça, ça marche pas toujours. En tout cas pas chez moi.

J'ai fini par tomber sur un truc qui a le mérite d'être tout simple et qui ne met pas le souk sur ma machine :

Utiliser le live CD Kaella - Knoppix Linux Azur

Testé et approuvé (en version 3.1.1).
Moyennant un export / import du certificat, bien sûr.

Hope this helps (à pas trop s'arracher les cheveux).
  • # Et ton certificat

    Posté par  (site Web personnel) . Évalué à 6.

    En même temps, c'est peut-être pas non plus la meilleure solution, pour ceux qui veulent conserver leur certificat, afin de pouvoir le réutiliser pour revenir sur le site, conserver la même identification, et utiliser le même certificat pour les autres opérations, comme pour signer la prochaine déclaration, par exemple.
    Ou alors, il faut bien penser à enregistrer le certificat sur une clé USB - la procédure est indiquée dans l'aide du site des impôts.

    Remarque, je donne des conseils, mais la dernière fois que j'ai changé d'ordi, j'ai bien pris soin d'oublier de récupérer ce certificat...
    • [^] # Re: Et ton certificat

      Posté par  . Évalué à 4.

      en même temps, la révocation et la recréation d'un nouveau certificat est bien plus facile et rapide maintenant. Il faut juste faire attention de préparer les documents nécessaire (anciennes déclarations) afin de fournir des éléments d'identification.

      La création prend moins d'une heure pour ne pas dire que c'est instantané. Avant il fallait au moins un jour. Les certificats devaient être générés en batch par une machine non connectée au net.

      Sinon, pour ma part, sur Ubuntu, ca marche sans difficulté particulière.
    • [^] # Re: Et ton certificat

      Posté par  . Évalué à 5.

      Oui, bien sûr, il faut pouvoir conserver le même certificat pour que cela reste confortable.
      Via une clef USB (qui n'en a pas aujourd'hui ?) ; ou bien, comme j'ai fait, tu lances le LiveCD dans une session virtuelle (qemu, virtualbox, vmplayer, ...). Tu peux ainsi copier ton certificat via le réseau, et récupérer l'accusé réception de la même façon. Et tu économises le reboot de ton PC.
  • # Le plus important c'est la jre pas la distro

    Posté par  . Évalué à 2.

    Salut,

    Le plus important c'est la version (et l'origine) du java utilisé et non la distro ou le navigateur.

    En ce qui me concerne je suis sous Archlinux et j'utilise la jre officielle de sun (version 6 update 5) et je n'ai eu aucun soucis avec Firefox ou Epiphany (en activant l'extension certificats).

    IcedTea (sur F8 et autres) ne passe pas car c'est un Java 7 pas encore officiel (donc les impots ne connaissent pas).
    Java Blackdown ne devrait pas passer non plus (à confirmer).

    Si vous utilisez une Jre version 6 de Sun alors vous ne devriez pas avoir de problèmes, quelque soit la distro.
  • # mandriva 2008 64 bits

    Posté par  . Évalué à 2.

    Je n'ai pas réussi à le faire avec un linux 64 bits.

    A priori, le plugin ns n'existe pas en 64 bits et java 7 n'est pas assez complète pour faire fonctionner le truc des impôts.

    Pour faire fonctionner les impots, il faut une JVM mais aussi le lien entre la jvm et le navigateur qui n'existe pas encore en 64 bits.

    "La première sécurité est la liberté"

    • [^] # Re: mandriva 2008 64 bits

      Posté par  (site Web personnel) . Évalué à 2.

      Oui : pas de Java officiel en 64 bit. Et ce depuis toujours.

      ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

      • [^] # Re: mandriva 2008 64 bits

        Posté par  . Évalué à 2.

        Correction : pas de plugin Java officiel en 64 bits.

        Il y a des navigateurs qui n’utilisent pas le plugin pour les applets (p.ex. Konqueror), ils lancent eux-mêmes une machine virtuelle Java, qu’elle soit 32 bits ou 64 bits, et y font tourner les applets.

        En revanche, il semble qu’une bibliothèque 32 bits soit installée/utilisée par l’applet de notre trésor, donc elle ne fonctionne pas avec une JVM 64 bits.
        Ça s’arrangera quand Vista (tout) 64 bits sera plus répandu… mouhaha. Désolé. ⟶[]
  • # Recours à l'assistance technique (chat)

    Posté par  . Évalué à 1.

    Avant de me tourner vers Google, j'ai contacté l'assistance technique par chat. Voici l'échange (expurgé des politesses) :

    edeion: Lorsque je valide la saisie de ma feuille d'impôts pour signature, j'obtiens le message d'erreur suivant : "Erreur technique (erreur n° 100) d'exécution du module de signature en ligne". Comme indiqué, je je suis reconnecté et j'ai tenté à nouveau la signature : même résultat. Que puis-je faire ?
    Assistance: Vous êtes sous Linux?
    edeion: oui, sous Linux avec le navigateur IceWeasel (identique en fait à Firefox)
    Assistance: Dans ce cas, je vous demanderai de nous contactez au 0820 326 326, nous ne pouvons régler cette erreur par tchat.
    edeion: et au téléphone, vous pouvez ?
    Assistance: oui, vous aurez une expertise technique qui pourra prendre le temps de vous aider dans les manipulations.

    Plutôt que d'appeler le service en question, je me suis tourné vers Google et j'ai trouvé la solution ici-même, résumée par le commentaire http://linuxfr.org/~pini/26648.html#934599. Je serais curieux de savoir ce que conseillerait l'assistance technique...
  • # C'est le dernier jour

    Posté par  . Évalué à 2.

    ... pour moi en tout cas. C'est maladif, il faut que je fasse tout au dernier moment. Cette année j'avoue que ça a été la panique, et oui je suis passé sous Ubuntu 8.04 alors :

    sudo apt-get remove sun-java6-plugin sun-java6-fonts sun-java6-jre sun-java6-bin
    sudo apt-get install firefox sun-java5-plugin sun-java5-fonts sun-java5-jre sun-java5-bin libnss3-1d libnspr4-0d
    cd /usr/lib
    sudo ln -s libnss3.so.1d libnss3.so
    sudo ln -s libnspr4.so.0d libnspr4.so
    cd


    source : un peu partout sur le net et surtout là http://www.olivierberger.com/weblog/index.php/2008/05/18/103(...)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.