Journal pigeon dans debian sarge

Posté par .
Tags : aucun
0
18
juin
2004
Bonjour mon cher journal,

Après avoir vu des screenshot de pigeon, un logiciel pour graver des CD sous Gnome 2, j'ai tout de suite pensé qu'il était enfin le soft que j'attendai, interface claire et simple, joli etc...

Donc, ni une ni deux :
apt-get install pigeon

tout ce passe bien, je le lance et là : erreur, une belle boite avec un message simple "Le programme a quitté inopinement".

je me dis, essayons en root, pas mieux.

Donc, je vais charger les sources pour compiler. Je compile, aucun problème, et au lancement : pareil. Voici ceque j'obtient avec la console :

ondex@romain:~/programmes/systeme/pigeon-0.4.1$ pigeon
INFO ( 6827: 0) Initializing GStreamer Core Library version 0.6.4
INFO ( 6827: 0) CPU features: (00000730) MMX 3DNOW MMXEXT
INFO ( 6827: 0) registry: loaded global_registry in 0,329544 seconds
(/var/lib/gstreamer/0.6/registry.xml)


quelqu'un a déjà eu ce problème ?
est ce juste avec debian ou bien toutes les distrib ?
une dépendance non précisé ?

Merci à tous.
  • # sarge ou sid...

    Posté par (page perso) . Évalué à 2.

    j'utilise la versio 0.4.1-4 de pigeon en sid et ça marche, j'avait le même problème avant, mais un upgrade à réparer le problème. attend l'upgrade et tu l'aura ( ou moins sérieux : apt-get -t sid install pigeon ) .
    • [^] # Re: sarge ou sid...

      Posté par . Évalué à 3.

      J'ai déjà cette version installé, du moins c'est ce que dit
      apt-get show pigeon
      Puis comme j'ai tenté par les sources, il y a autre choses je pense.

      Si je fais tout de même la commande :

      [romain ~]# apt-get -t sid install pigeon
      Lecture des listes de paquets... Fait
      Construction de l'arbre des dépendances... Fait
      pigeon est déjà la plus récente version disponible.
      0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

      Autre fait étrange. Si on fait une recherche sur le site de debian, il ne trouve pas le paquet pigeon, c'est bizarre. J'ai parcouru toute l'arborescence du dépot que j'utilise (ftp.fr.debian.org), je ne l'ai trouvé nul part. Mais d'où vient t'il ?
  • # il me rappelle

    Posté par . Évalué à 4.

    l'interface me rappelle beaucoup gtoaster ou eroaster je sais plus
    le projet sur sf.net :
    http://sourceforge.net/projects/gnome-cd-burner/(...)
    les screenshots :
    http://gnome-cd-burner.sourceforge.net/Pigeon-CD-Recorder-0.2.png(...)
    http://gnome-cd-burner.sourceforge.net/Pigeon-CD-Recorder-0.4.png(...)

    en t out cas il a l'air sympa :)
    • [^] # Re: il me rappelle

      Posté par . Évalué à 2.

      Ouais, mais je me demande si c'est pas un peu mort... La 0.4.1 date de janvier, et est toujours en gstreamer-0.6. Quant au CVS, il est tout simplement vide.
      • [^] # Re: il me rappelle

        Posté par . Évalué à 2.

        ça serais vraiment dommage, il a l'air très sympa.

        J'ai tellement de mal a trouvé un bon logiciel pour graver.

        Vous utilisez quoi vous ?
        Un soft GTK 2 est plus que bien venu.
        • [^] # Re: il me rappelle

          Posté par . Évalué à 2.

          Perso, c'est un peu suivant l'humeur. J'aime bien gcombust pour faire mes CD de données ou graver des isos, et simplecdrx pour faire des CD audio depuis des ogg/mp3. Sinon XCDRoast fonctionne bien, est très complet, tout ça, mais l'interface est quand même assez lourde (vachement plus de clics que dans gcombust pour une même tâche). Et sinon, quand c'est just pour dumper rapidos un divx sur un CD, il m'arrive d'utiliser le machin de gravure de Nautilus.

          Mais niveau interface, je peux pas dire que je suis 100% satisfait, par aucun des logiciels sus-cités. J'ai un meilleurs souvenir de Nero sous Windows par exemple. Sinon j'entends beaucoup de bien de K3B, mais ça me lourde d'installer KDE pour ça.
          • [^] # Re: il me rappelle

            Posté par . Évalué à 0.

            K3b est pas mal et tu n'es pas obligé d'installer tout kde pour l'utiliser

            Pour les CD, j'aime beaucoup utiliser eroaster quand j'ai la flemme de chercher la syntaxe pour ce que je veux faire, mais je n'ai pas trouvé l'option pour graver des DVD (que j'ai depuis 1 semaine), alors je me suis rabattu sur k3b pour le moment

            Quelqu'un connait une interface GTK pour graver des DVD (si possible dispo dans SID), je suis preneur
          • [^] # Re: il me rappelle

            Posté par . Évalué à 2.

            XCDRoast est une horreur selon moi. L'interface est vraiment tout sauf intuitive. Si l'interface etait revu, ce pourrait être LE logiciel de gravure. Pour justifier mon opinion, cet exemple :
            Il m'a fallu une dizaine de minutes (véridique) pour trouver comment effacer mon CD-RW. Je suis peut êter un peu niais pour voir mis tant de tant, mais cela prouve bien qu'il n'est pas accessible à tout le monde.

            GCombust est pas mal, c'est vrai, je trouve l'interface un peu austere (GTK 1) mais il n'est pas trop compliqué. Il fut longtemps mon logiciel de prédilection pour graver.

            J'ai vu hier soir que Eroaster etait passer en version 2.2 beta, il est GTK 2, je l'ai installé, il à l'air pas mal, je croit que je vais rester avec celui là. L'interface est bien pensé je trouve, ce qui manque c'est navigateur de fichier. Le fait d'aller chercher par une boite "Ouvrir un fichier" n'est pas très pratique. Mais c'est compensé par le fait que l'on peux faire un drag'n drop depuis nautilus, xffm ou autre.

            J'ai un meilleurs souvenir de Nero sous Windows par exemple.
            Exactement ce que je pense. Nero est vraiment bien (simple). Mais cette opinion vient peut être du fait que l'on est habitué à Nero ?
  • # Oukilé?

    Posté par (page perso) . Évalué à 2.

    je l'ai pas dans mes source officielles debian. T'es sur qu'il vient bien de sid ou testing ton paquet? :)
    • [^] # Re: Oukilé?

      Posté par . Évalué à 3.

      Voici la copie exacte de mon source.list au moment où j'ai fais
      apt-get install pigeon
      Bien sur, j'ai fais update avant.

      ###############################################################################
      # Mirroir officiel Debian
      deb http://ftp.fr.debian.org/debian/(...) sarge main contrib non-free
      deb http://ftp.fr.debian.org/debian-non-US/(...) sarge/non-US main contrib non-free

      ###############################################################################
      # Outils pour le bootsplash
      #deb http://mentors.debian.net/debian(...) unstable main

      La preuve, je le fais maintenant :

      [romain ~]# apt-get update
      Atteint http://ftp.fr.debian.org(...) sarge/main Packages
      Atteint http://ftp.fr.debian.org(...) sarge/main Release
      Atteint http://ftp.fr.debian.org(...) sarge/contrib Packages
      Atteint http://ftp.fr.debian.org(...) sarge/contrib Release
      Atteint http://ftp.fr.debian.org(...) sarge/non-free Packages
      Atteint http://ftp.fr.debian.org(...) sarge/non-free Release
      Atteint http://ftp.fr.debian.org(...) sarge/non-US/main Packages
      Atteint http://ftp.fr.debian.org(...) sarge/non-US/main Release
      Atteint http://ftp.fr.debian.org(...) sarge/non-US/contrib Packages
      Atteint http://ftp.fr.debian.org(...) sarge/non-US/contrib Release
      Atteint http://ftp.fr.debian.org(...) sarge/non-US/non-free Packages
      Atteint http://ftp.fr.debian.org(...) sarge/non-US/non-free Release
      Lecture des listes de paquets... Fait

      [romain ~]# apt-cache search pigeon
      xcb - Pigeon holes for your cut and paste selections
      pigeon - GNOME2 CD Burner

      [romain ~]# apt-cache show pigeon
      Package: pigeon
      Status: install ok installed
      Priority: optional
      Section: gnome
      Installed-Size: 252
      Maintainer: Link Dupont <link@subpop.net>
      Architecture: i386
      Version: 0.4.1-4
      Depends: libart-2.0-2 (>= 2.3.8), libatk1.0-0 (>= 1.4.1), libbonobo2-0 (>= 2.4.3), libbonoboui2-0 (>= 2.4.3), libc6 (>= 2.3.2.ds1-4), libgcc1 (>= 1:3.3.2-1), libgconf2-4 (>= 2.4.0.1), libglade2-0 (>= 2.0.0), libglib2.0-0 (>= 2.2.3), libgnome2-0 (>= 2.4.0), libgnomecanvas2-0 (>= 2.4.0), libgnomeui-0 (>= 2.4.0.1-2), libgnomevfs2-0 (>= 2.4.1), libgnomevfs2-common (>= 2.4.1), libgstreamer0.6-0 (>= 0.6.1-2), libgtk2.0-0 (>= 2.2.1), libice6 | xlibs (>> 4.1.0), liborbit2 (>= 1:2.8.0), libpango1.0-0 (>= 1.2.1), libpopt0 (>= 1.7), libsm6 | xlibs (>> 4.1.0), libstdc++5 (>= 1:3.3.2-1), libxml2 (>= 2.6.6), zlib1g (>= 1:1.2.1), gconf2 (>= 2.4.0), gstreamer-vorbis, gstreamer-mad, gstreamer-flac, gstreamer-plugin-libs
      Conffiles:
      /etc/gconf/schemas/pigeon.schemas 3cf84517dcb33e6e646c4c4fdba764f3
      Description: GNOME2 CD Burner
      A Gnome2 CD Burner, designed to integrate into the gnome desktop. Can create
      audio CDs from Mp3s, oggs, wavs, etc., as well as data cds.




      Question, pourquoi il continue de prendre des paquets sur mentors.debian.net (j'ai regardé, le paquet pigeon y est).

      Est ce qu'une de ces options aurais un effet secondaire :

      APT::Get::Show-Upgraded "true";
      APT::Get::List-Cleanup "false";
      • [^] # Re: Oukilé?

        Posté par . Évalué à 2.

        Bon, finalement, il semblerai que ce soit de ma faute

        J'ai surement installé pigeon quand la ligne mentors n'était pas commenté.

        Et tant que le logiciel est installé, même si le dépot est commenté, il apparait dans la liste de apt-get.

        Doc je l'ai desinstallé et il ne fait plus parti de la liste.

        Et voilà. Un mystère de résolu.
        • [^] # Re: Oukilé?

          Posté par . Évalué à 1.

          Tiens, ton aventure me fait penser : y a pas moyen de limiter un repository à un choix de paquets ?

          Genre, pour ton cas, limiter mentors au bootsplash, mais ne rien télécharger d'autre. J'ai RTFM, mais j'ai pas trouvé (bon, d'accord, j'ai pas beaucoup cherché...)
        • [^] # Re: Oukilé?

          Posté par . Évalué à 3.

          la commande qu'il te manquait pour savoir la ou les versions disponible sur chaque source :

          # apt-cache policy pigeon
          pigeon:
          Installés : (aucun)
          Candidat : 0.4.1-4
          Table de version :
          0.4.1-4 0
          500 http://mentors.debian.net(...) unstable/main Packages
          500 http://mentors.debian.net(...) unstable/contrib Packages
          500 http://mentors.debian.net(...) unstable/non-free Packages

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.