Wiki [Tuto/HowTo] [Debian/Ubuntu] installer metasploit-framework depuis github

1
23
oct.
2018

logo metasploit

"Un grand pouvoir implique de grandes responsabilités." oncle Ben.

Introduction

Ce tutoriel ne se concentre que sur l'installation de metasploit-framework depuis github.
Ce tuto n'explique PAS comment utiliser metasploit.

Installation

Installez les pré-requis.

sudo apt update
sudo apt-get install -y ruby-dev libpq-dev libpcap-dev libsqlite3-dev postgresql git ruby-bundler build-essential patch ruby-dev zlib1g-dev liblzma-dev libgmp-dev

Créez le dossier pour accueillir les fichiers.

sudo mkdir /opt/metasploit

Accordez les bonnes permissions au dossier.

sudo chown $USER:root -R /opt/metasploit
sudo chmod 770 -R /opt/metasploit

Clonez le répertoire de msf sur github vers votre dossier local.

git clone https://github.com/rapid7/metasploit-framework.git /opt/metasploit

Rendez exécutable les fichiers.

sudo chmod +x /opt/metasploit/

Lancez la commande suivante pour lancer l'installation de tout ce qui est lié à Ruby.

cd /opt/metasploit
bundle install

Mettez à jours metasploit.

sudo /opt/metasploit/msfupdate

Lancez enfin la console metasploit.

/opt/metasploit/msfconsole

Si vous souhaitez utiliser la base de données PostGreSQL avec metasploit suivez ce tuto : [Tuto/HowTo] [Debian/Ubuntu] Interfacer metasploit avec la base de données PostGreSQL

  • # je n arive pas a installer nokogiri

    Posté par . Évalué à 1 (+1/-0).

    bonjour,
    j ai suivi le tuto mais arrive bundle install ca me met(An error occurred while installing nokogiri (1.10.4), and Bundler cannot continue.
    Make sure that gem install nokogiri -v '1.10.4' --source 'https://rubygems.org/' succeeds before
    bundling.)
    je débute dans l informatique svp soyez clair dans vos explications
    je vous remercie d'avance

  • # missing gems

    Posté par . Évalué à 0 (+0/-0). Dernière modification le 16/10/19 à 17:13.

    user-net@user:/opt/metasploit$ /opt/metasploit/msfconsole
    Could not find rubyzip-2.0.0 in any of the sources
    Run bundle install to install missing gems.
    user-net@user:/opt/metasploit$

    Comment je peut faire pour remédier a ceci?

  • # bundle install

    Posté par . Évalué à 0 (+0/-0). Dernière modification le 16/10/19 à 17:16.

    user-net@user:/opt/metasploit$ bundle install
    Fetching gem metadata from https://rubygems.org/…………..
    rubyzip-2.0.0 requires ruby version >= 2.4, which is incompatible with the
    current version, ruby 2.3.1p112
    user-net@user:/opt/metasploit$

    En Attente d'un petit coup de main!!

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.