Journal Il parait que GNOME 2.32 is out

Posté par (page perso) .
Tags : aucun
16
30
sept.
2010
Dans une quasi indifférence générale semble t'il tant les nouveautés sont réduites à peau de chagrin.
http://library.gnome.org/misc/release-notes/2.32/index.html.(...)

Ha si, quand même un truc, Un bug ouvert depuis plus de 9 ans a enfin été fermé !!
Evolution 2.32 est désormais en mesure de gérer un vrai dossier corbeille et un vrai dossier spam comme le font TOUS les autres logiciels de messagerie et webmail !!
https://bugzilla.gnome.org/show_bug.cgi?id=206061

http://git.gnome.org/browse/evolution/tree/NEWS
"Bug 206061 - Allow normal, non-vFolder, Trash and Junk folder (Milan
Crha)"


RDV dans 6 mois pour GNOME 2.34.
Bah oui, GNOME 3 ne sera pas prêt tant la liste des GNOME Goals est encore longue
http://live.gnome.org/GnomeGoals
En même temps, je ne suis pas pressé de subir la nouvelle métaphore du bureau !
  • # Roooh...zut

    Posté par (page perso) . Évalué à 1.

    Ils auraient quand même pu attendre demain pour sortir ça... on aurait pu s'en donner à coeur joie sans scrupule ...

    Bon aller je me lance....
    Quand on vois le changelog, on se demande si la 2.32 est une version mineur...

    Je suis effectivement curieux de savoir si 2.34 sera effectivement 3.0 et si 3.0 sera aussi stable que les version 2.* ...
    Pour l'instant on est pas loin des problèmes "Kde 4.0 " ...

    wait & see donc
    • [^] # Re: Roooh...zut

      Posté par . Évalué à 1.

      "Pour l'instant on est pas loin des problèmes "Kde 4.0 " ..."
      Mais sans les nouveautés inhérentes à un tel changement de version !


      (pourquoi on n'est pas déjà demain ?!? :-/ )
      • [^] # Re: Roooh...zut

        Posté par . Évalué à 10.

        l'impression que j'ai est plutôt qu'ils suivent l'autre extrême.
        kde 4.0 est sorti avec trop de nouveautés complètement instables et pas finie, parce qu'ils voulaient à tout prix sortir pour avancer. Ce choix leur a été préjudiciable, même s'il peut être compréhensible.
        gnome 3.0 est en train d'être de plus en plus repoussé et les changements sont réduits pour éviter de casser toute forme de compatibilité.

        Maintenant, l'avenir nous dira quelle était la meilleur stratégie. Personnellement je pense que celle de gnome est meilleur pour l'image et le marketing et celle de kde meilleur pour l'évolution et l'innovation.
        • [^] # Re: Roooh...zut

          Posté par (page perso) . Évalué à 3.

          cite>kde 4.0 est sorti avec trop de nouveautés complètement instables et pas finie

          Pas exactement.
          Les autres versions majeures n'étaient pas non plus tout à fait au point. Mais le public de KDE a changé. Il y a 8 ans, on était encore une majorité d'utilisateurs très avancés, ça ne nous gênait pas de "tester" et on savait tous qu'a la sortie d'une version majeure, il fallait attendre un peu pour avoir un truc utilisable.
          Maintenant le public est plus élargi, et comme la course à l'échalotte a bien pris, on est tous impatients, à l'affut des nouveautés. Les développeurs de KDE s'en sont rendu compte trop tard.

          "La liberté est à l'homme ce que les ailes sont à l'oiseau" Jean-Pierre Rosnay

          • [^] # Re: Roooh...zut

            Posté par . Évalué à 2.

            je suis assez d'accord avec ce que tu dis, je ne vois juste pas en quoi cela rends moi exact ce que j'ai dit moi plus haut...
            • [^] # Re: Roooh...zut

              Posté par (page perso) . Évalué à 2.

              Je voulais surtout dire (amicalement) que ta phrase reflète un point de vue.
              Le point de vue des "anciens" n'est pas le même, puisqu'on n'attendait pas plus d'une version 4.0. De même que le site de kde indiquait clairement pour des yeux d'"ancien" que kde 4.0 n'était pas fait pour tout le monde.
              Je trouve que l'équipe kde a compris le problème et qu'ils ont changé de stratégie, ils ne suivent plus "l'autre extrême" et s'attachent aux finitions et aux évolutions plus lente - ce qui énerver plein de vieux routiers du coup, car on voudrait voir arriver certaines choses plus vite (même mal foutues)! ;-)

              Enfin de toute façon je suis moi aussi assez d'accord avec ce que tu as dit, c'était pour rééquilibrer la balance.

              "La liberté est à l'homme ce que les ailes sont à l'oiseau" Jean-Pierre Rosnay

    • [^] # Re: Roooh...zut

      Posté par . Évalué à 4.

      Je préfère encore une nouvelle version de GNOME avec moins de nouveautés mais stable, plutôt qu’un environnement non testé avec pleins de bugs partout. D’ailleurs, et les utilisateurs de bases l’oublient trop souvent, installer une version de test sur sa machine entraîne bien souvent une mauvaise impression de l’ensemble. D’ailleurs, je suis encore sous Lenny c’est pour dire, comment ça on n’est pas encore vendredi ?
  • # Quid de Gnome scan ?

    Posté par (page perso) . Évalué à 2.

    Je n'ai pas trop le temps de lire et encore moins de tester en ce moment mais je me demande où en est l'intégration de Gnome scan.
    • [^] # Re: Quid de Gnome scan ?

      Posté par . Évalué à 10.

      Ave,

      Depuis que je bosse, je n'ai plus le temps de maintenir GNOME Scan alors que je suis chef scout par ailleurs.

      Je met parfois à jours le code vers les dépendances (Vala, GEGL). J'ai commencé à écrire des suites de tests unitaires pour passer au TDD. Mais aucune fonctionnalités.

      Bref, le projet est au point mort :(. Dommage, le code est sain (il manque juste la couverture de tests) et assez stable.

      N'hésitez pas à me contacter pour donner un coups de main ou prendre le projet en main :)

      Étienne
      • [^] # Re: Quid de Gnome scan ?

        Posté par (page perso) . Évalué à -2.

        Qui peut m'expliquer pourquoi le commentaire ci-dessus est à zéro?
        Merci!
        • [^] # Re: Quid de Gnome scan ?

          Posté par . Évalué à 5.

          Peut-être une petite perte de karma due à un précédent journal un peu trop prosélyte pour linuxfr
          http://linuxfr.org/~bersace/29927.html
          • [^] # Re: Quid de Gnome scan ?

            Posté par (page perso) . Évalué à 0.

            Le commentaire en question est revenu dans le vert et heureusement. Inutiliser un commentaire parfaitement pertinent juste parce qu'on n'aime pas un autre journal ou un autre commentaire de son auteur, c'est n'importe quoi.
            • [^] # Re: Quid de Gnome scan ?

              Posté par (page perso) . Évalué à 2.

              Il est venu dans le vert, plutôt. Il a simplement été posté à 0 par défaut à cause de la répétition d'idées puantes que son auteur est venue déposer ici à une époque. C'est pas parce que tu les partages qu'il faut jouer les moralisateurs à deux ronds (vu le score actuel de 10 il semblerait que ce commentaire soit bien jugé suivant sa valeur et pas le passif de l'auteur).
  • # Evince

    Posté par . Évalué à 6.

    Les fans de PDF noteront quand même 2 améliorations importantes dans Evince :
    - possibilité d'ajouter des annotations enregistrées directement dans le PDF, comme le fait Adobe Bloatreader sous certains OS propriétaires (plus pratique et portable que Xournal...)
    - support de SyncTeX

    Maintenant, quand un collègue relira un de mes PDF faits avec LaTeX en y ajoutant des annotations pour suggérer des modifs, je n'aurai qu'à cliquer sur un point du texte pour ouvrir mon fichier .tex directement au bon endroit :)
    • [^] # Re: Evince

      Posté par . Évalué à 3.

      Ca c'est pas mal en effet. J'espere que cela sera present sur Okular rapidement. C'est bien gentil les annotations dans un fichier dans le repertoire .kde/share/apps/okular mais ce n'est pas portable ni pratique.
      • [^] # Re: Evince

        Posté par (page perso) . Évalué à 3.

        J'étais d'ailleurs étonné de ne trouver, jusqu'à présent, aucun logiciel libre qui le supportait.

        « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

      • [^] # Re: Evince

        Posté par . Évalué à 1.

        Je crois qu'Okular le supporte déjà : http://ubuntuforums.org/showthread.php?p=9633672

        (pas testé, je n'ai pas KDE sur mon PC...)
        • [^] # Re: Evince

          Posté par . Évalué à 1.

          Je viens de tester la "solution". Tout d'abord cela n'est pas simple du tout et ensuite soit je n'ai pas compris comment faire, et c'est tout a fait possible, soit cela ne fonctionne pas. En tout cas le clic gauche shift dans okular cela ne fait rien.

          Je ne pense pas que l'on puisse dire que cela fonctionne avec okular.
    • [^] # Re: Evince

      Posté par (page perso) . Évalué à 4.

      Quand on lit les notes de publications, on a l'impression que cette fonctionnalité était déjà là et a juste été améliorée.

      En fait, les annotations de PDF avec Evince, c'est une arlésienne. Elle a été annoncée plusieurs fois comme en cours de travail, comme à venir, et même parfois comme enfin prise en charge alors qu'en fait trop pas. Donc méfiance, à tester avant d'en parler.
      • [^] # Re: Evince

        Posté par (page perso) . Évalué à 2.

        et donc ça donne quoi ?

        (non mais je demande juste parce que tu en parles... ;) )
        • [^] # Re: Evince

          Posté par (page perso) . Évalué à 2.

          Pour la 2.32, je ne sais pas, je n'ai pas essayé. Mais pour la 2.30, on ne peut pas annoter de documents PDF, en tout cas pas sous Debian, et je vois mal Debian désactiver spécifiquement cette fonctionnalité.

          Donc les notes de publications sont mensongères, s'il y a une fonctionnalité d'annotation, elle n'a pas été améliorée mais introduite, vu qu'elle n'était pas présente dans la version précédente.
          • [^] # Re: Evince

            Posté par . Évalué à 4.

            En fait, elle était présente mais pas incomplète : on pouvait modifier des annotations, mais pas en créer. Pas très utile en l'état, sauf à posséder Acrobat à côté.

            Les notes sont donc bien correctes.

            Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

            • [^] # Re: Evince

              Posté par . Évalué à 3.

              D'abord on pouvait juste les afficher : c'était une limitation de poppler.
              Puis poppler a permis de modifier les annotations existantes, et Evince a donc pu faire ça.
              Et, depuis peu, poppler permet de créer de nouvelles annotations...

              Vivement que ça arrive dans les repos -- mais je fais confiance aux devs Arch pour que ce soit rapide :)
          • [^] # Re: Evince

            Posté par . Évalué à 8.

            et je vois mal Debian désactiver spécifiquement cette fonctionnalité.
            Bopf, tu sais, ils ont bien desactive la generation aleatoires de nombre d'OpenSSH, donc bon.

            If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

        • [^] # Re: Evince

          Posté par (page perso) . Évalué à 1.

          Je viens d'installer le evince 2.32 de ubuntu maverick, et ben soit je suis mauvais (c'est fort probable), soit je n'ai pas trouver la façon de faire pour ajouter les annotations.
          • [^] # Re: Evince

            Posté par (page perso) . Évalué à 1.

            Et pour les mauvaises langues qui diraient que je suis mauvais car je n'ai pas trouver, je confirme, je n'ai pas trouvé.
          • [^] # Re: Evince

            Posté par . Évalué à 1.

            Idem sous archlinux.

            Comme apparemment c'est poppler qui gère ça, qu'elle version faut-il ? Sur archlinux la version la 0.14.
            • [^] # Re: Evince

              Posté par . Évalué à 2.

              http://poppler.freedesktop.org/releases.html

              Il semble que la version de dev de poppler soit nécessaire (0.15) pour en profiter.
              • [^] # Re: Evince

                Posté par . Évalué à 3.

                Yep. Sur mon Arch Linux, J'ai recompilé poppler et poppler-glib en 0.15.0, puis recompilé evince 2.32.0, et là ça marche.

                poppler 0.14.3 ne suffit pas, il faut bien la 0.15.0...
              • [^] # Re: Evince

                Posté par . Évalué à 1.

                donc avec un peu de chance en avilr/mai pour les distributions a cycle de 6 mois...
    • [^] # Re: Evince

      Posté par . Évalué à 1.

      Apres une petite recherche il semblerait que cela ne marche que avec une version de poppler qui n est pas encore stable donc c est pas gagne
    • [^] # Re: Evince

      Posté par . Évalué à 2.

      Et c'est quand qu'Evince lira les PDF correctement ? ex. détail fort génant sur certains fichiers, Evince affiche des lignes fines, grisâtres et à peine visibles contre lignes noire, épaisses et bien visibles dans xpdf et acroread).

      J'ai toujours eu ce problème, je suis sous Ubuntu Lucid (désolé inside), idem pour toutes les autres versions depuis Hoary. vous pensez que ça pourrait venir d'Ubuntu ?
      • [^] # Re: Evince

        Posté par (page perso) . Évalué à 2.

        Oh, ne t'en fais pas, avec les prochaines versions c'est Xpdf qui affichera comme Evince. :->

        Parce que Debian va maintenant compiler Xpdf avec Poppler, le moteur de rendu d'Evince, à la place de celui de Xpdf d'origine.
  • # La corbeille d’Evolution

    Posté par (page perso) . Évalué à 1.

    Dommage, c’était pourtant une bonne idée, la poubelle comme un vFolder, je trouve. Faudra voir à l’usage…
  • # Gedit

    Posté par (page perso) . Évalué à 3.

    Gedit étant un éditeur de texte offrant bien plus de confort que les très mauvais emacs, vim, eclipse, geany, kwrite… voici les nouveautés :
    _Pas de Gedit 2.32, à la place Gedit 2.30.4
    _gedit-plugins passe en 2.32 et intègre deux plugins supplémentaires : synctex (via Evince, voir ci-dessus) et textsize pour rapidement changer la taille du texte.

    Les développeurs se concentrent sur le passage à la 3ème dimension, ils comptent en avoir fini pour mars 2011.

    Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

    • [^] # Re: Gedit

      Posté par . Évalué à 3.

      Bof, ça va encore. Le moniteur système est lui carrément bloqué à la version 2.28.C'est dommage, il est rudement pratique mais je suis sûr qu'il y a moyen d'y ajouter plein de fonctions.

      Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

      • [^] # Re: Gedit

        Posté par . Évalué à 3.

        je suis sûr qu'il y a moyen d'y ajouter plein de fonctions.

        Pas dans Gnome en tout cas !
    • [^] # Re: Gedit

      Posté par . Évalué à 5.

      > Gedit étant un éditeur de texte offrant bien plus de confort que les très mauvais emacs, vim, eclipse, geany, kwrite…

      Ouf tout va bien, j'utilise Kate :P
      • [^] # Re: Gedit

        Posté par . Évalué à 1.

        franchement y'a des gens qui utilisent Gedit ? J'ai jamais compris l'utilité de cet éditeur sachant que en face il y a vim et emacs.

        oau
        • [^] # Re: Gedit

          Posté par (page perso) . Évalué à 10.

          Oui, tous les gens qui n'ont pas l'envie/le temps/l'usage de s'attaquer a la falaise vertigineuse que représente la courbe de difficulté d'apprentissage d'emacs ou vim... Ce qui doit couvrir a vue de nez un majorité écrasante de l'humanité.
        • [^] # Re: Gedit

          Posté par . Évalué à 3.

          Faut aussi savoir que GEdit est un peu un des projets pilotes sur les dernière technos de GNOME (GI, Gnome 3, popup dans la fenêtre et autres widgets innovant, etc.).

          C'est pas rare qu'on aille voir dans le code de GEdit pour voir comment est implémenter tel ou tel comportement du logiciel pour le reproduire dans son code.
  • # Explication sur le peu de fonctionnalités apportées

    Posté par (page perso) . Évalué à 3.

    http://www.vuntz.net/journal/post/2010/09/29/GNOME-2.32-is-o(...)

    En gros le fait que la version qui vient

    Bah oui, GNOME 3 ne sera pas prêt tant la liste des GNOME Goals est encore longue
    Les GNOME Goals n'ont rien à voir avec GNOME 3, seuls certains sont indispensables pour pouvoir sortir GNOME 3 (en gros, éviter d'utiliser des fonctions GLib et GTK+qui vont être supprimées dans GNOME 3).

    C'est Vincent Untz qui a créé le concept des GNOME Goals pour GNOME 2.16, bien avant l'annonce que GNOME 3 soit d'actualité :
    http://www.vuntz.net/journal/post/2006/02/12/361-setting-gno(...)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.