Forum Linux.debian/ubuntu Bug Nautilus

Posté par . Licence CC by-sa
0
12
oct.
2017

Bonjour
Je suis actuellement sur Kali-Linux en architecture 64 bits
j'ai un problème, quand je tape nautilus dans un terminal j'obtient :

nautilus: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgnome-autoar-0.so.0: undefined symbol:
archive_entry_is_encrypted

En plus , je n'ai plus de bureau je n'ai plus accès à mes fichiers

Pouvez-vous m'aider ?

  • # console ?

    Posté par (page perso) . Évalué à 4 (+2/-0).

    Tu as quand même accès à la console ?

    • [^] # Re: console ?

      Posté par . Évalué à 3 (+1/-0).

      en environnement Gnome, Nautilus qui est le gestionnaire de fichier gère aussi les icones du bureau. Si Nautilus est mort, plus d'affichage de ces icones.

      • [^] # Re: console ?

        Posté par (page perso) . Évalué à 5 (+4/-0).

        Ça me rappelle étrangement Explorer® …

        « Il vaut mieux mobiliser son intelligence sur des conneries que mobiliser sa connerie sur des choses intelligentes. »

    • [^] # Re: console ?

      Posté par . Évalué à 1 (+0/-0).

      Oui ! Pas de problême pour la console !

  • # reinstaller les dependances

    Posté par . Évalué à 2 (+0/-0).

    Bizarre ton truc, on dirait que c'est la mauvaise version de la lib qui est installee… du coup essaies de reinstaller les dependances (via aptitude par exemple) a une autre version (aptitude permets de downgrader les paquets, s'ils sont encore connus).
    Si pas possible, tu peux regarder dans /var/cache/apt/archives et essayer de downgrade manuellement avec dpkg.

    Par curiosite, ca a pete apres une MaJ? Tu as peut-etre configure d'autres sources, et des depots seraient en conflits?

    • [^] # Re: reinstaller les dependances

      Posté par . Évalué à 1 (+0/-0).

      Merci d'acoir répondu !
      J'ai effectivement d'autres sources (comme MEGA, Google …)
      Quelles dépendances dois-je reinstaller ? ou
      Comment downgrader manuellement ?
      PS: Je ne m'y connais pas énormement en linux, je manipule un peu mais c'est pas ouf

      • [^] # Re: reinstaller les dependances

        Posté par . Évalué à 3 (+1/-0).

        Le plus simple a mon avis serait de passer par aptitude (dans un terminal. Sans arguments il lance une interface semi graphique assez utilisable) puis d'aller selectioner nautilus et afficher les details (touche entree): en bas il y a la liste des dependances, parmi elles, l'une aura un nom proche de ton erreur, aller dedans, et tout en bas il y aura la liste des versionsaccessibles par le reseau, tu peux donc upgrade/downgrade par la.

        je suis pas tres clair mais fatigue…

      • [^] # Re: reinstaller les dependances

        Posté par . Évalué à 1 (+0/-0). Dernière modification le 14/10/17 à 02:28.

        Il est possible que tes autres sources mettent le bazar.

        Ce que dit freem c'est qu'une fois sur le terminal, tu tapes "aptitude" puis tu devrais avoir un bandeau rouge dans le bas de l'interface graphique qui t'indique qu'il y a des conflits. Si c'est le cas, tape "e" comme indiqué pour voir les différentes propositions de résolution (en navigant avec , et . comme indiqué). Parfois il est pas très bon à comprendre ce que tu cherches à faire donc il faut sélectionner le paquet manuellement ("/" pour rechercher, touche entrée pour avoir la description du paquet) pour forcer une version ("+" installer, "-" pour supprimer un paquet)
        Une fois que les conflits sont résolus, "g" pour voir la liste des changements puis à nouveau "g" pour lancer les opérations.

        PS: Je ne m'y connais pas énormement en linux, je manipule un peu mais c'est pas ouf

        Peut-être que tu devrais te familiariser avec les outils sur une distribution plus facile d'accès. Kali c'est du Debian du coup ça demande un peu d'expérience pour l'administrer, surtout que la distribution est basée sur testing donc il y a régulièrement des choses qui bug (particulièrement maintenant quand il y a encore de nouvelles versions qui arrivent de unstable). Si tu as vraiment besoin des outils de pentesting spécifique à Kali, la version Live est un peu contraignante mais davantage clé en main.

        • [^] # Re: reinstaller les dependances

          Posté par . Évalué à 1 (+0/-0).

          J'ai reinstallé le paquet qui posait problème:
          quand j'ai ouvert aptitude il n'y avait pas de barre rouge alors j'ai cherché Nautilus et j'ai trouvé le paquet qui ne marchait pas et l'ai désinstallé puis réinstallé à la version disponible depuis aptitude mais pas de changement , meme apres mise a jour et redemarage …
          C'est vraiment handicapant de plus avoir le systeme de fichiers et de se déplacer dans le répertoire juste en commande (je me débrouille pas trop mal mais c'est plutôt embetant)

          • [^] # Re: reinstaller les dependances

            Posté par . Évalué à 2 (+0/-0).

            ce sont les dependances qu'il faut regarder, la barre rouge n'indique que si un paquet a un probleme en se basant sur les numeros de version, hors tu as plusieurs sources: il n'est donc pas impossible que certaines sources te fournissent un numero de version compatible, mais dont l'ABI (https://fr.m.wikipedia.org/wiki/Application_binary_interface) ne l'est pas. Ce genre de probleme est delicat a regler (y compris sous windows pour le coup) surtout pour un debutant. L'usage de kali n'est peut-etre pas etranger au probleme, je ne serai pas surpris que leurs paquets ne soient pas tout a fait compatibles avec ceux de debian (et donc probablement des autres sources que tu as ajoutees) surtout pour des choses liees a la securite (ici, le chiffrement).

            sinon, tu peux aussi temporairement installer un autre explorateur de fichiers, le temps de resoudre ce probleme (de preference un qui ne soit pas base sur gtk ou gnome, ca reduirait le risque de problemes d'ABI)

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.