Forum Linux.debian/ubuntu Bureau, icônes et caractères gnome remplacés par des couleurs aléatoires

Posté par . Licence CC by-sa.
0
5
déc.
2019

Bonjour à tous,

j'ai un bug d'affichage ! c'est le même que dans ce forum : http://forums.debian.net/viewtopic.php?t=122270 [non-résolu]
Ca se produit à la sortie de veille, en premier c'est le fond d'écran qui part en charpies et est remplacé par ça :
http://i.imgur.com/rlpZGvv.png
puis les choses deviennent de plus en plus droles et ce sont les icones et les caratères qui se font la malle, remplacés par le même patchwork.
au cas par cas : les icones du bureau et leurs caractères, les icones du lanceur et leur description (hoover et click droit) l'heure, les icones du haut (sauf le haut parleur je crois)… tout ça revient en ordre en redémarrant gnome (Alt+f2, r) mais i y a pire :
j'utilise Krita pour dessiner, et la zone de travaille et elle aussi souvent couverte du patchwork au réveil de l'ordi. J'ai noté que je pouvais toujours sauvegarder le dessin et le rouvrir sans perdre les modifs.
Voilà je suis sous ubuntu 19, et j'ai récement installé et désinstallé bumblebee qui est sensé gérer les cartes graphiques, donc j'en ai pas l'usage c'était par curiosité vu que j'ai un montage nvidia optimus.

diag@diag-gnu ~$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM75 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller AHCI mode
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF117M GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

diag@diag-gnu ~$ nvidia-detector
nvidia-340

je suis d'ailleurs assez surpris du nombre de ligne j'en attendais moins, pareil pour Xeon c'est plus que je ne croyais!
d'autre part j'ai les bons drivers Nvidias, ils tournent et sont à jour

diag@diag-gnu ~$ lsmod|grep nvidia
nvidia              10584064  80
drm                   491520  10 drm_kms_helper,nvidia,i915

Merci d'avance, merci d'avoir lu!

  • # des pistes

    Posté par . Évalué à 5 (+3/-0).

    il nous faudrait plus d'info sur ta machine,

    car

    Voilà je suis sous ubuntu 19, et j'ai récement installé et désinstallé bumblebee qui est sensé gérer les cartes graphiques, donc j'en ai pas l'usage c'était par curiosité vu que j'ai un montage nvidia optimus.

    Optimus/bumblebee sont là pour gérer la bascule entre la carte interne (iGPU=> VGA du lspci)

    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

    et la carte 3D

    01:00.0 3D controller: NVIDIA Corporation GF117M GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M

    lorsque le programme demande des ressources gourmandes en performance 3D.

    il faudrait voir si les pilotes Nvidia supportent encore ta carte graphique,
    je sais qu'à une époque, il fallait faire attention aux cartes qui deviennent non supportées par le pilote proprio Nvidia, et préférer le pilote open source appelé nouveau

    dans ton cas, je penses qu'il faut laisser le bumblebee/optimus car la carte Nvidia n'est pas autonome.

    si tu as récemment installé ton linux, tu peux repartir sur une installation de zero pour laisser le système installer ce qui est nécessaire pour ton système.

    autre option :
    certaines machines permettent de désactiver la carte 3D dans le bios/efi pour réduire la consommation batterie au prix d'une légère perte de performance graphique (pas très contraignant suivant les usages)

  • # la meme

    Posté par (page perso) . Évalué à 2 (+1/-0).

    jai le meme bug sur un portable MSI derniere gen avec une nvidia 1060 6g pilote proprio, ca a l'air d'etre un bug du pilote nvidia en sortie de veille.

  • # Quelques liens ...

    Posté par . Évalué à 3 (+2/-0). Dernière modification le 07/12/19 à 09:56.

    Bonjour, voici quelques liens pour détailler le problème / et quelques "solutions"

    Et il me semblait avoir lu qqpart qu'un des développeurs de nvidia disait un truc à ce sujet … de mémoire c'était du genre "on a bien noté le bug, on sait où il se trouve mais vu les modifications des appels graphiques de gnome/whatelse modernes on est bien emmerdés pour apporter un correctif rapide" à moins que je ne mélange avec des lectures au sujet de wayland :-/

    Pour ma part quand je reviens d'un sleep mode ou que j'ai mon bureau qui est partis en vrille je lance un script "background.sh" dont voici le code, c'est directement inspiré d'un des pointeurs indiqué au début.

    #!/bin/bash
    gsettings set org.gnome.desktop.background picture-uri file:///usr/share/backgrounds/gnome/Dark_Ivy.jpg 
    

    eric.linuxfr@sud-ouest.org

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.