Forum Linux.debian/ubuntu Hubicfuse, problème de permissions / propriétaire

Posté par  . Licence CC By‑SA.
Étiquettes :
1
20
juin
2016

Salut !

J'ai découvert Hubic (OVH) y'a pas longtemps et je veux en faire ma solution de sauvegarde de mes données. C'est possible en utilisant Hubicfuse, qui permet de monter son cloud Hubic dans un répertoire.
Je me suis aidé de ce tuto, ça fonctionne, le répertoire est bien monté, je peux lire et écrire dedans, enfin presque …

J'utilise Owncloud pour synchroniser mes fichiers entre plusieurs ordinateurs donc il faut que l'utilisateur www-data soit le propriétaire du répertoire. Ce que j'ai fait, sauf que ça ne marche pas. J'aimerai ne pas avoir a mettre des permissions trop "souple" parce-que évidemment si je fait 'chmod o+rwx' ça marche très bien mais c'est sale …

Malgré le fait que j'ai indiqué les options uid=33 et gid=33 (www-data) pour fuse dans le fstab et que un 'ls -l' me dit que je dossier appartient a www-data, et pourtant on dirait pas !
La commande 'mount' me retourne :
hubicfuse on /mnt/owncloud type fuse.hubicfuse (rw,relatime,user_id=0,group_id=0,allow_other)
alors que mon fstab contient ça :
hubicfuse /mnt/owncloud fuse uid=33,gid=33,umask=007,noauto_cache,sync_read,allow_other 0 0

Une idée ?
Merci d'avance.

  • # man fuse ?

    Posté par  . Évalué à 1.

    Salut,

    Je ne connais pas hubicfuse, mais avec l'option default_permissions en plus de allow_other, ça donne quoi ?

  • # Hubicfuse

    Posté par  . Évalué à 1.

    J'ai déjà essayé toute les combinaisons à ce niveau là … Je pense que le problème viens de fuse ou mount, ou du système directement. C'est Armbian sur un Odroid XU4.

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.