Forum Linux.debian/ubuntu impossible de sortir de veille

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
7
juil.
2020

Bonjour,

à chaque fois que je mets en veille ma session, lorsque je veux me reconnecter j'ai écrans noirs et impossible de pouvoir accéder à ma session, je suis obligée de redémarrer. Pourtant j'ai bien fait les configurations dans les paramètres. Pouvez vous m'aider svp ? (je suis sous Ubuntu 18.04LTS)

Merci :)

  • # GPU, BIOS

    Posté par  . Évalué à 2 (+1/-0).

    Hello,
    - quelle carte graphique as-tu ?
    - avec quels pilotes ?
    - as-tu un PC fixe ou portable ?

  • # Si c'est un dell latitude ou precision récent

    Posté par  . Évalué à 1 (+0/-0).

  • # solution la plus simple/crad

    Posté par  . Évalué à 2 (+0/-0). Dernière modification le 08/07/20 à 07:48.

    dans une console :

    xset s off

    le faire a chaque redemarrage, sauf si la veille marche super bien sur ton pc :)

    solution elegante :

    https://linuxfr.org/nodes/120992/comments/1816930

    • [^] # Re: solution la plus simple/crad

      Posté par  . Évalué à 1 (+0/-0).

      Ok j'ai réussi à retrouver ma session en faisant CTRL+ALT+F1, par contre maintenant ma barre latérale des favoris a disparu !!!

      • [^] # Re: solution la plus simple/crad

        Posté par  . Évalué à 1 (+0/-0).

        En allant dans les ajustements gnome je vois que toutes mes extensions gnome sont désactivées, je les réactive mais elles se désactivent à nouveau systématiquement.

        Pouvez vous m'aider svp ?

        • [^] # Re: solution la plus simple/crad

          Posté par  . Évalué à 2 (+0/-0).

          ca ressemble à une acceleration graphique qui ne se reactive pas,
          pour il faut virer le module graphique de ta carte avant la mise en veille, et le remettre apres la mise en veille.

          pour t'en dire plus il faudrait connaitre la marque/modele de l'ordi et de ta carte graphique.

  • # Tester l'ACPI

    Posté par  . Évalué à 3 (+1/-0). Dernière modification le 08/07/20 à 10:12.

    Souvent, les distribs passent par les options pour Windows de l'acpi, car les constructeurs ne se donnent pas la peine d'implémenter pour linux.

    Il se trouve que dans bien des cas DELL implémente l'acpi linux.

    tu peux trouver les moyens de voir les options d'acpi implémentées sur ton pc en suivant cette procédure.

    J'ai réglé le problème d'un PC DELL en passant cette option à acpi_osi=linux comme expliqué dans l'article. Cela ne coûte pas grand chose d'essayer au démarrage avec grub !

    • [^] # Re: Tester l'ACPI

      Posté par  . Évalué à 1 (+0/-0).

      Désolée mais je ne comprends rien à ton message…

      • [^] # Re: Tester l'ACPI

        Posté par  . Évalué à 5 (+3/-0).

        Oui, je comprends, ce n'est pas évident …

        Les paramètres du noyau sont documentés sur le site kernel.org.

        Pour comprendre ce que fait acpi_osi, tu dois savoir en gros comment fonctionne l'ACPI. L'ACPI consiste en des tables que le BIOS charge dans la mémoire vive avant le démarrage du système d'exploitation. Certaines d'entre elles contiennent simplement des informations sur les périphériques essentiels de la carte mère dans un format fixe, mais certaines, comme la table DSDT, contiennent du code AML. Ce code est exécuté par le système d'exploitation et fournit au système d'exploitation une structure arborescente décrivant de nombreux appareils sur la carte mère et les fonctions appelables qui sont exécutées par le système d'exploitation lorsque, par exemple, l'économie d'énergie est activée. Le code AML peut demander au système d'exploitation de quel système il s'agit en appelant la fonction _OSI. Cette fonction est souvent utilisée par les fournisseurs pour contourner les problèmes, par exemple en cas de bogue dans certaines versions de Windows.

        Comme de nombreux fournisseurs de matériel informatique ne testent leurs produits qu'avec la dernière version de Windows (à ce moment-là), les chemins de code "normaux" sans solution de contournement sont souvent bogués. C'est pourquoi Linux répond généralement par l'affirmative lorsqu'on lui demande si c'est Windows. Linux avait également l'habitude de répondre oui lorsqu'on lui demandait s'il s'agissait de "Linux", mais cela amenait les vendeurs de BIOS à contourner les bogues ou les fonctionnalités manquantes dans la (à l'époque) dernière version du noyau Linux au lieu d'ouvrir des rapports de bogues ou de fournir des correctifs. Lorsque ces bogues ont été corrigés, les solutions de contournement ont entraîné des baisses de performance et d'autres problèmes pour toutes les versions ultérieures de Linux.

        acpi_osi=Linux fait en sorte que Linux réponde à nouveau oui lorsqu'on lui demande si c'est "Linux" par le code ACPI, permettant ainsi au code ACPI d'activer les contournements pour Linux et/ou de les désactiver pour Windows.

        acpi_backlight=vendor modifie l'ordre dans lequel les pilotes ACPI pour les rétroéclairages sont vérifiés. Habituellement, Linux utilise le pilote vidéo générique lorsque le DSDT ACPI fournit un périphérique de rétro-éclairage revendiquant une compatibilité standard et ne vérifie les pilotes spécifiques d'autres fournisseurs que si un tel périphérique n'est pas trouvé. acpi_backlight=vendor inverse cet ordre, de sorte que les pilotes spécifiques des fournisseurs sont essayés en premier.

        Tu peux donc tester quelques options pour vérifier ce que ton PC supporte.

        La commande :

        sudo strings /sys/firmware/acpi/tables/DSDT | grep -i 'windows '

        te permet de vérifier les versions de Windows supportées, la dernière est celle qui est utilisée par défaut lors du lancement de ton noyau.

        Du coup tu peux rajouter

        GRUB_CMDLINE_LINUX= xxxx "acpi_osi=Windows 2015"
        

        ou

        GRUB_CMDLINE_LINUX= xxxx "acpi_osi=Linux"
        

        dans le fichier /etc/default/grub

        puis mettre à jour grub avec :

        sudo update-grub
        

        Essaye les différentes options et regarde si ça règle ton problème !!

        Plus clair comme ça ?

        • [^] # Re: Tester l'ACPI

          Posté par  . Évalué à 1 (+0/-0).

          Pas trop, je ne vois pas trop le rapport avec mon problème, c'est un peu trop tech pour moi. La commande strings ne me renvoie rien et je n'ose pas rajouter ce que tu dis dans le fichier grub car j'ai trop peur de faire n'importe quoi et là je ne saurais pas m'en sortir.

          • [^] # Re: Tester l'ACPI

            Posté par  . Évalué à 3 (+1/-0).

            Pas trop, je ne vois pas trop le rapport avec mon problème,

            Si ton problème est la sortie de veille, comme tu le décris, c'est un problème d'ACPI. Il faut donc regarder si des paramétrage de ton ACPI peuvent le régler. C'est la chose la plus logique à faire.

            c'est un peu trop tech pour moi.

            Malheureusement, ce genre de problème est de nature technique. La prise en compte de la veille sur un PC Linux est dépendante de la bonne implémentation de l'ACPI par le constructeur, de ce fait, si il utilise des contournements pour windows, ceux-ci peuvent mal se passer sur Linux, qui va réveiller des périphériques dans le mauvais ordre … Si tu ne testes pas les différents modèles d'ACPI alors, tu n'as aucune chance de le régler … Une mise à jour du noyau ne changera rien à cela …

            La commande strings ne me renvoie rien

            Je vois mal comment c'est possible …

            et je n'ose pas rajouter ce que tu dis dans le fichier grub car j'ai trop peur de faire n'importe quoi et là je ne saurais pas m'en sortir.

            Tu peux essayer de rajouter l'option lors du boot, comme expliqué ici, il suffit alors de rebooter …

            Tu n'auras pas de réponses ne demandant pas une compétence technique avancée sur ce sujet. Peut être te faudrait il aller dans un GULL pour voir quelqu'un de compétent, en lui montrant ce message.

            Bon courage

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.