Forum Linux.debian/ubuntu Pb driver OpenGL

Posté par (page perso) . Licence CC by-sa.
1
9
mai
2019

Bonjour,
Je sais que le problème est difficile:il s'agit d'un problème de driver pour les jeux:
sur une Debian/Sparky Linux 5.7, j'ai les driver Mesa Intel DRI 845G x86/MMX/SSE2 de The Xorg Foundation version 1.3 18.3.4. J'ai l'accélération graphique pour certains jeux mais pas ceux qui demandent Open GL 2 ou plus comme le très classique OpenArena. Je ne sais pas ce que je peux faire et si c'est possible d'améliorer la situation. Note:c'est sur un PC de récup P4 avec carte graphique Intel qui sont d'habitude bien supportées.

  • # Intel 845G

    Posté par (page perso) . Évalué à 3. Dernière modification le 09/05/19 à 18:30.

    Cette puce graphique a une limitation matérielle à OpenGL 1…. donc tu ne peux pas améliorer!

    C'était bien avant que Intel sorte des puces graphiques décentes… puisque même la génération suivante ne satisfait pas OpenGL 2.

    ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

    • [^] # Re: Intel 845G

      Posté par (page perso) . Évalué à 2.

      Flute de zut, ça va être difficile d'en faire un PC gamer, à la rigueur rétro.
      Merci pour la réponse claire et nette.

      • [^] # Re: Intel 845G

        Posté par . Évalué à 2.

        Si le PC a un emplacement PCIe ou AGP tu peux y ajouter une petite carte graphique à pas cher. Reste à voir la compatibilité des pilotes, surtout si tu dois mettre une carte AGP.

        • [^] # Re: Intel 845G

          Posté par (page perso) . Évalué à 2.

          Bien non, c'est un mini PC,il n'y a pas de place pour une carte video annexe. La solution que je vois est de trier en fonction des jeux (n'y mettre que les jeux qui marchent dessus.)Il y a Ri-Li, Chromium BSU (pour ce jeu c'est assez souvent qu'il lague, et là non, donc,il y a de l'espoir quand même d'en tirer quelque chose), ExtremTuxracer et plein d'autres. En fait il y a des jeux dont il faudrait trouver une ancienne version comme SupertuxKart : je cherche du côté d'anciens CD de jeux que j'ai en stock, par exemple LinuxConsole.

          • [^] # Re: Intel 845G

            Posté par . Évalué à 2.

            Ça doit vraiment être très petit (et même très propriétaire) comme design, ou alors une carte ITX vraiment mal fichue. Si c'est qu'une question de format de boitier et pas de PCB, il y a toujours l'option de bricoler un truc quitte à utiliser un riser PCI placé à l'horizontale et/ou une carte fille d'une demi-hauteur pour garder un format compact.

            Sinon pour les jeux, y a ptet moyen de choper les anciennes sources sur leurs dépots. Pour STK c'est ici. En plus c'est probablement plus propre que d'essayer de faire fonctionner d'anciens binaires.

            • [^] # Re: Intel 845G

              Posté par (page perso) . Évalué à 2.

              C'est un boitier mini HP-Compaq, c'est vraiment très compact. Pour compiler, avec d'anciennes sources, il n'y a que Linuxconsole/Yann Le Doare qui pourrait faire ça:une iso personnalisée spécifique à la machine.

              • [^] # Re: Intel 845G

                Posté par . Évalué à 2.

                HP-Compaq, ça sent la carte-mère sur-mesure donc c'est probablement cuit.

                Sinon avec ta distro Debian-based, t'as pas moyen de compiler d'anciennes versions ? Après j'ai pas testé et il y a peut-être eu de gros changements de syntaxe dans les libs ou le compilateur C++. Mais bon le soft c'est pas trop mon rayon.

                • [^] # Re: Intel 845G

                  Posté par (page perso) . Évalué à 2.

                  Je vais voir ce que je peux faire, mais compiler, c'est un métier, ce n'est pas facile (sauf quand tout va bien du premier coup)

  • # distrib plus recente ?

    Posté par . Évalué à 2.

    Debian/Sparky Linux 5.7, j'ai les driver Mesa Intel DRI 845G x86/MMX/SSE2 de The Xorg Foundation version 1.3 18.3.4.

    et qu'est ce qui t'empeche de mettre un debian plus recent, pour avoir les paquets qui vont gerer opengl1.1, opengl1.2, fournir un pilote intel plus recent ?

    de memoire pour la carte Intel845 on peut utiliser le pilote de cette carte, ou forcer l'usage du pilote i915 (qui supporte en fait presque toutes les cartes intel)

    • [^] # Re: distrib plus recente ?

      Posté par (page perso) . Évalué à 2.

      La Debian/Sparky Linux 5.7 date de 2018, donc c'est déjà très récente. Par contre, forcer l'usage du i915, je pourrais essayer.

      • [^] # Re: distrib plus recente ?

        Posté par . Évalué à 2.

        meaculpa, j'ai cru que c'etait une vieille variante de Debian comme on a eu Debian/squeeze, Debian/wheezy, Debian/Stretch…
        et qu'on est deja à Debian 9 (Jessie)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.