Forum Linux.debian/ubuntu Problème avec mon serveur mail (mails externes entrants)

Posté par .
Tags : aucun
0
5
juin
2008
Bonjour,

Possédant mon propre serveur (Debian 4.0 avec apache2, ftp ...) derrière une freebox, j'étais depuis longtemps tenté par un serveur mail.
Je me suis lancé avec le tutoriel présent à cette adresse : http://www.starbridge.org/spip/spip.php?article12&artsuite=0


Problèmes :

Envoi de mails : ok, en local comme en externe

Réception de mails : ok en local, mais rien en externe ...


Mes routages (freebox, blocage SMTP sortant désactivé) :

21 tcp
80 tcp
443 tcp
993 tcp



Ma config DNS (nom de domaine chez GANDI) :

@ 10800 IN A 88.160.92.148
* 10800 IN A 88.160.92.148
@ 10800 IN MX 5 88.160.92.148.
* 10800 IN MX 5 88.160.92.148.



Le mail d'erreur lorsque j'envoi un mail à admin@yent.eu :

Reporting-MTA: dns; orange.fr
X-SMTP-Server-Queue-ID: 6B8E8700018E
X-SMTP-Server-Sender: rfc822; yent666@wanadoo.fr
Arrival-Date: Thu, 5 Jun 2008 15:02:57 +0200 (CEST)

Final-Recipient: rfc822; admin@yent.eu
Action: failed
Status: 5.0.0
Diagnostic-Code: X-SMTP-Server; host spool.mail.gandi.net[217.70.184.6] said:
554 5.7.1 : Relay access denied (in reply to RCPT TO
command)


N'ayant pas beaucoup de connaissance de ce coté, je me demandais si quelqu'un pouvait m'aider à comprendre le problème (routage, MX, autre ... ?)

Merci d'avance.
  • # alors alors ....

    Posté par . Évalué à 1.

    1°) il faut ouvrir le port 25 et le redirigé depuis ta freebox vers ton serveur de mail (si tu utilises la config standard pour recevoir tes emails

    2°) free bloque par defaut le port 25 en SORTIE, afin d'eviter les PCs zombies utilisés pour envoyer des Spams et des Virus,
    il te faut donc desactiver ce blocage dans ta console de gestion de la freebox

    3°) enfin, il te faudra
    - configurer le serveur de mail pour accepter les emails detinés à un domaine donné (le tiens)
    - configurer le DNS pour dire que le MX de ton domaine c'est ton IP free
    (en fait il te faudra configurer un nom à ton IP, puis un MX vers ce nom)
    ex :
    mail.mondomaine.com IN A IP_de_ta_freebox
    mondomaine.com IN MX mail.mondomaine.com


    le MX servant à dire à qui envoyer les mails @mondomaine.com
    • [^] # Re: alors alors ....

      Posté par . Évalué à 1.

      Bon,

      - j'ai ouvert le port 25 ... en effet petit oubli génant.

      - à prioris configuré le serveur mail pour mon domaine :
      Le debut de mon fichier de config :
      smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
      biff = no
      append_dot_mydomain = no
      myhostname = mail.yent.eu
      alias_maps = hash:/etc/aliases
      alias_database = hash:/etc/aliases
      myorigin = $mydomain
      mydestination = $myhostname, localhost.$mydomain, localhost
      mynetworks = 127.0.0.0/8
      recipient_delimiter = +
      home_mailbox = Maildir/
      notify_classes = 2bounce, bounce, delay, policy, protocol, resource, software
      smtpd_helo_required = yes
      strict_rfc821_envelopes = yes


      - mis mes DNS à jour :
      * 10800 IN A 88.160.92.148
      @ 10800 IN A 88.160.92.148
      mail.yent.eu 10800 IN A 88.160.92.148
      yent.eu 10800 IN MX 5 mail.yent.eu.


      Mais ... rien, j'obtiens le même message d'erreur qu'avant ...

      Ou alors le domaine que je donne au serveur mail est pas bon ... (est-ce yent.eu, domaine de base, ou alors mail.yent.eu, défini dans les DNS ... ???)
      • [^] # Re: alors alors ....

        Posté par (page perso) . Évalué à 1.

        rajoute dans ton fichier de conf mydomain=yent.eu

        je plussoie et je paie ma tournée !!!!

        • [^] # Re: alors alors ....

          Posté par (page perso) . Évalué à 1.

          rajoute aussi $mydomain dans mydestination

          mydestination=.......,$mydomain

          désoler j'avais oublié

          a+

          je plussoie et je paie ma tournée !!!!

          • [^] # Re: alors alors ....

            Posté par . Évalué à 1.

            C'est encore moi ...

            Alors coté "main.cf", j'en suis là :
            smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
            biff = no
            append_dot_mydomain = no
            myhostname = mail.yent.eu
            mydomain = yent.eu
            alias_maps = hash:/etc/aliases
            alias_database = hash:/etc/aliases
            myorigin = $mydomain
            mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
            mynetworks = 127.0.0.0/8
            recipient_delimiter = +
            home_mailbox = Maildir/
            notify_classes = 2bounce, bounce, delay, policy, protocol, resource, software
            smtpd_helo_required = yes
            strict_rfc821_envelopes = yes
            virtual_alias_maps = proxy:mysql:/etc/postfix/mysql_virtual_alias_maps.cf
            virtual_gid_maps = static:20001
            virtual_mailbox_base = /home/virtual
            virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql_virtual_domains_maps.cf
            virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql_virtual_mailbox_maps.cf
            virtual_minimum_uid = 20001
            virtual_uid_maps = static:20001
            proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $smtpd_recipient_restrictions $smtpd_sender_login_maps proxy:mysql:/etc/postfix/mysql-hello.cf proxy:mysql:/etc/postfix/mysql-sender.cf proxy:mysql:/etc/postfix/mysql-client.cf
            message_size_limit = 50240000
            smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql-sasl-sender-check.cf

            smtpd_sender_restrictions =
            reject_authenticated_sender_login_mismatch

            smtpd_reject_unlisted_sender = yes

            smtpd_restriction_classes =
            has_our_domain_as_sender

            has_our_domain_as_sender =
            check_sender_access hash:/etc/postfix/our_domain_as_sender,
            rejectsmtpd_recipient_restrictions =
            reject_non_fqdn_recipient,
            reject_unknown_sender_domain,
            reject_non_fqdn_sender,
            reject_unknown_recipient_domain,
            reject_invalid_helo_hostname,
            reject_unlisted_recipient,
            reject_unlisted_sender,
            permit_mynetworks,
            permit_sasl_authenticated,
            reject_non_fqdn_helo_hostname,
            reject_unauth_destination,
            check_client_access hash:/etc/postfix/internal_networks,
            check_sender_access hash:/etc/postfix/not_our_domain_as_sender,
            check_helo_access proxy:mysql:/etc/postfix/mysql-hello.cf,
            check_sender_access proxy:mysql:/etc/postfix/mysql-sender.cf,
            check_client_access proxy:mysql:/etc/postfix/mysql-client.cf,
            reject_rbl_client list.dsbl.org,
            reject_rbl_client zen.spamhaus.org,
            permitsmtpd_data_restrictions =
            reject_unauth_pipelining,
            permit
            virtual_transport = maildrop
            maildrop_destination_recipient_limit = 1
            smtpd_sasl_auth_enable = yes
            smtpd_sasl_security_options = noanonymous
            smtpd_sasl_local_domain =
            broken_sasl_auth_clients = yes
            smtpd_sasl_authenticated_header = yes
            smtp_tls_CAfile = /etc/postfix/tls/cacert.pem
            smtp_tls_security_level = may
            smtp_tls_session_cache_database = btree:${queue_directory}/smtp_tls_session_cache
            smtpd_tls_security_level = may
            smtpd_tls_auth_only = yes
            smtpd_tls_key_file = /etc/postfix/tls/yent-key.pem
            smtpd_tls_cert_file = /etc/postfix/tls/yent-cert.pem
            smtpd_tls_CAfile = /etc/postfix/tls/cacert.pem
            smtpd_tls_loglevel = 1
            smtpd_tls_received_header = yes
            smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_tls_session_cache
            tls_random_source = dev:/dev/urandom
            header_checks = regexp:/etc/postfix/header_checks.cf
            body_checks = regexp:/etc/postfix/body_checks.cf
            mime_header_checks = regexp:/etc/postfix/mime_headers_checks.cf
            content_filter = smtp-amavis:[127.0.0.1]:10024



            J'ai du ajouter les trois dernières inscriptions à "proxy_read_maps" car postfix me les demandais (malgré le fait qu'elles n'étaient pas mise dans le tuto ...)

            Le problème c'est que maintenant j'ai une erreur de ce style :
            YenTserver:~# more /var/log/mail.log
            Jun 5 17:18:03 YenTserver postfix/smtpd[10845]: connect from smtp15.orange.fr[1
            93.252.23.84]
            Jun 5 17:18:03 YenTserver postfix/trivial-rewrite[10849]: warning: do not list
            domain yent.eu in BOTH mydestination and virtual_mailbox_domains
            Jun 5 17:18:03 YenTserver postfix/smtpd[10845]: 6111C43856F: client=smtp15.oran
            ge.fr[193.252.23.84]
            Jun 5 17:18:03 YenTserver postfix/cleanup[10850]: 6111C43856F: message-id=<3314
            5621.3096951212676140673.JavaMail.www@wwinf1535>
            Jun 5 17:18:03 YenTserver postfix/smtpd[10845]: disconnect from smtp15.orange.f
            r[193.252.23.84]
            Jun 5 17:18:03 YenTserver postfix/qmgr[10837]: 6111C43856F: from=<yent666@wanad
            oo.fr>, size=1433, nrcpt=1 (queue active)
            Jun 5 17:18:03 YenTserver postfix/smtp[10851]: connect to 127.0.0.1[127.0.0.1]:
            Connection refused (port 10024)
            Jun 5 17:18:03 YenTserver postfix/smtp[10851]: 6111C43856F: to=<admin@yent.eu>,
            relay=none, delay=0.2, delays=0.17/0.03/0/0, dsn=4.4.1, status=deferred (connec
            t to 127.0.0.1[127.0.0.1]: Connection refused)


            Donc :
            - mydomain = yent.eu lui plait pas car cette valeur est aussi fournie par la requète MySQL des domaines virtuels ...
            - il y a une histoire de connexion refusée sur le port 10024, rapport avec l'antivirus amavis je pense (main.cf : "content_filter = smtp-amavis:[127.0.0.1]:10024").

            Maintenant les mails arrivent, c'est juste qu'ils passent pas ... Grrr ...
            • [^] # Re: alors alors ....

              Posté par . Évalué à 1.

              Non zut, je me suis planté, c'est sur mydestination = $mydomain que ca plante visiblement.
              • [^] # Re: alors alors ....

                Posté par . Évalué à 1.

                Bon j'ai viré l'inscription $mydomain dans mydestination et il me plante plus, il ne reste que le problème de l'antivirus, qui en fait ne tourne pas donc ça marche pas, logique ...

                Ce qui est moins logique c'est qu'il ne tourne pas ...

                J'y retourne, merci pour votre aide ...
                • [^] # Re: alors alors ....

                  Posté par . Évalué à 1.

                  C'est bon, bug réglé ...

                  Merci à vous pour votre aide ...
  • # MTA

    Posté par (page perso) . Évalué à 1.

    quel MTA utilises tu ??

    je plussoie et je paie ma tournée !!!!

    • [^] # Re: MTA

      Posté par . Évalué à 1.

      J'utilise postfix
      • [^] # Re: MTA

        Posté par (page perso) . Évalué à 1.

        Dans ton fichier de conf postfix (/etc/postfix/main.cf) tu as une option (mydomain de tete) ou tu dois lui renseigner ton nom de domaine:

        mydomain=tonnomdedom.fr

        ensuite restart de postfix et ca devrais cristaliser

        a+

        je plussoie et je paie ma tournée !!!!

        • [^] # Re: MTA

          Posté par . Évalué à 1.

          Comme je viens de poste pour NeoX, je me demmande si ce nom doit être "yent.eu" (domaine de base) ou alors "mail.yent.eu" comme défini dans les DNS ... ???
          • [^] # Re: MTA

            Posté par (page perso) . Évalué à 1.

            ton nom de domaine, celui que tu veux utiliser est celui qui est déposer chez gandi,
            mail est censé etre le nom de la machine qui gere les mails du domaine

            je plussoie et je paie ma tournée !!!!

            • [^] # Re: MTA

              Posté par . Évalué à 1.

              Le soucis c'est que c'est la même machine ...

              Alors je doit avoir dans "main.cf" :

              myhostname = yent.eu
              mydomain = yent.eu


              Est-ce correct ?
              • [^] # Re: MTA

                Posté par (page perso) . Évalué à 1.

                le hostname est ton nom de machine par consequent mail.yent.eu

                je plussoie et je paie ma tournée !!!!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.