Forum Linux.debian/ubuntu Problème de passage à Bionic Beaver (depuis Xenial)

Posté par . Licence CC by-sa.
0
25
août
2018

Salut,

J'ai quelques soucis pour passer sur Bionic Beaver en architecture armv7.

Le retour de la commande "sudo do-release-upgrade"

        Checking for a new Ubuntu release
        Prendre :1 Upgrade tool signature [819 B]
        Prendre :2 Upgrade tool [1 258 kB]
        1 258 k o réceptionnés en 0s (0  o/s)
        authenticate 'bionic.tar.gz' against 'bionic.tar.gz.gpg'
        extracting 'bionic.tar.gz'

        Lecture du cache
        pcilib: Cannot open /proc/bus/pci
        lspci: Cannot find any working access method.

        Vérification du gestionnaire de paquets
        Lecture des listes de paquets… Terminé
        Construction de l'arbre des dépendances
        Lecture des informations d'état… Terminé
        Att http://ports.ubuntu.com/ubuntu-ports xenial InRelease
        Att http://ports.ubuntu.com/ubuntu-ports xenial-updates InRelease
        Att http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease
        0  o réceptionnés en 0s (0  o/s)
        Lecture des listes de paquets… Terminé
        Construction de l'arbre des dépendances
        Lecture des informations d'état… Terminé

        Mise à jour des informations sur les dépôts
        Att http://ports.ubuntu.com/ubuntu-ports bionic InRelease
        Att http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease
        Att http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease
        0  o réceptionnés en 0s (0  o/s)

        Vérification du gestionnaire de paquets
        Lecture des listes de paquets… Terminé
        Construction de l'arbre des dépendances
        Lecture des informations d'état… Terminé

        Calcul des modifications en cours

        Calcul des modifications en cours

        Impossible d'évaluer la mise à niveau

        Un problème insoluble est survenu lors de la préparation de la mise à
        niveau.

        Ceci peut-être dû à :
        * la mise à niveau vers une version de développement d'Ubuntu ;
        * la version de développement d'Ubuntu est actuellement utilisée ;
        * des paquets logiciels non officiels, non fournis par Ubuntu.

        Si rien de tout cela ne s'applique, veuillez signaler ce bogue en
        utilisant la commande « ubuntu-bug ubuntu-release-upgrader-core »
        dans un terminal.


        Restauration du système dans son état d'origine

        Annulation
        Lecture des listes de paquets… Terminé
        Construction de l'arbre des dépendances
        Lecture des informations d'état… Terminé+    

Voici les logs contenus dans /var/log/dist-upgrade/main.log

        2018-08-25 20:07:24,902 INFO Using config files '['./DistUpgrade.cfg.xenial']'
        2018-08-25 20:07:24,903 INFO uname information: 'Linux XXX 4.4.38-v7+ #938 SMP Thu Dec 15 15:22:21 GMT 2016 armv7l'
        2018-08-25 20:07:25,145 INFO apt version: '1.2.27'
        2018-08-25 20:07:25,145 INFO python version: '3.5.2 (default, Nov 23 2017, 16:37:01)
        [GCC 5.4.0 20160609]'
        2018-08-25 20:07:25,149 INFO release-upgrader version '18.04.24' started
        2018-08-25 20:07:25,204 INFO locale: 'fr_FR' 'UTF-8'
        2018-08-25 20:07:25,511 INFO screen could not be run
        2018-08-25 20:07:25,621 WARNING estimate_kernel_initrd_size_in_boot() returned '0' for kernel?
        2018-08-25 20:07:25,622 WARNING estimate_kernel_initrd_size_in_boot() returned '0' for initrd?
        2018-08-25 20:07:26,225 DEBUG Using 'DistUpgradeViewText' view
        2018-08-25 20:07:26,487 DEBUG enable dpkg --force-overwrite
        2018-08-25 20:07:26,628 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
        2018-08-25 20:07:33,780 DEBUG lsb-release: 'xenial'
        2018-08-25 20:07:33,781 DEBUG _pythonSymlinkCheck run
        2018-08-25 20:07:33,783 DEBUG openCache()
        2018-08-25 20:07:33,784 DEBUG No such plugin directory: ./plugins
        2018-08-25 20:07:33,784 DEBUG plugins for condition 'PreCacheOpen' are '[]'
        2018-08-25 20:07:33,784 DEBUG plugins for condition 'bionicPreCacheOpen' are '[]'
        2018-08-25 20:07:33,784 DEBUG plugins for condition 'from_xenialPreCacheOpen' are '[]'
        2018-08-25 20:07:33,785 DEBUG quirks: running PreCacheOpen
        2018-08-25 20:07:33,785 DEBUG running Quirks.PreCacheOpen
        2018-08-25 20:07:34,181 DEBUG /openCache(), new cache size 8812
        2018-08-25 20:07:34,184 DEBUG need_server_mode(): run in 'desktop' mode, (because of key deps for 'ubuntu-mate-core')
        2018-08-25 20:07:34,185 DEBUG checkViewDepends()
        2018-08-25 20:07:34,186 DEBUG running doUpdate() (showErrors=False)
        2018-08-25 20:07:37,763 DEBUG openCache()
        2018-08-25 20:07:38,191 DEBUG /openCache(), new cache size 8812
        2018-08-25 20:07:38,191 DEBUG doPostInitialUpdate
        2018-08-25 20:07:38,192 DEBUG plugins for condition 'PostInitialUpdate' are '[]'
        2018-08-25 20:07:38,192 DEBUG plugins for condition 'bionicPostInitialUpdate' are '[]'
        2018-08-25 20:07:38,192 DEBUG plugins for condition 'from_xenialPostInitialUpdate' are '[]'
        2018-08-25 20:07:38,193 DEBUG quirks: running bionicPostInitialUpdate
        2018-08-25 20:07:38,193 DEBUG running Quirks.bionicPostInitialUpdate
        2018-08-25 20:07:40,605 DEBUG MetaPkgs:
        2018-08-25 20:07:45,437 DEBUG Foreign:
        2018-08-25 20:07:45,439 DEBUG Obsolete: atril atril-common avahi-discover avahi-dnsconfd blueman bluez-firmware brasero brasero-cdrkit brasero-common brltty-x11 caja caja-common caja-extensions-common caja-gksu caja-open-terminal caja-sendto caja-wallpaper chkrootkit compton dconf-editor deja-dup-backend-cloudfiles deja-dup-backend-gvfs deja-dup-backend-s3 deja-dup-caja dhcpcd5 dialog dnsmasq dvd+rw-tools engrampa engrampa-common eom eom-common exfat-fuse exfat-utils ffmpeg ffmpegthumbnailer folder-color-caja folder-color-common fonts-mathjax fonts-noto fonts-noto-hinted fonts-noto-mono fonts-noto-unhinted fonts-opendyslexic galculator gamin gdebi gir1.2-caja gir1.2-javascriptcoregtk-3.0 gir1.2-keybinder-0.0 gir1.2-mate-panel gir1.2-webkit-3.0 gir1.2-wnck-1.0 gksu gnome-icon-theme gnome-icon-theme-symbolic gnome-system-tools growisofs gstreamer1.0-nice gtk2-engines gtk2-engines-pixbuf gufw hddtemp hexchat hexchat-common i2c-tools ideviceinstaller ifuse indicator-application-gtk2 indicator-sound-gtk2 inxi iperf jackd jackd2 liba52-0.7.4 libaacs0 libasm4-java libass5 libatrildocument3 libatrilview3 libavcodec-ffmpeg56 libavcodec57 libavdevice57 libavfilter6 libavformat-ffmpeg56 libavformat57 libavresample3 libavutil-ffmpeg54 libavutil55 libbasicusageenvironment1 libbdplus0 libbluray-bdj libbluray-bin libbluray1 libbrasero-media3-1 libbs2b0 libburn4 libbytes-random-secure-perl libcaja-extension1 libcddb2 libchromaprint0 libconfig9 libconfuse-common libconfuse0 libcpufreq0 libcrypt-random-seed-perl libcrypt-ssleay-perl libdc1394-22 libdca0 libdirectfb-1.2-9 libdvbpsi10 libdvdnav4 libdvdread4 libebml4v5 libebur128-1 libegl1-mesa-drivers libfaad2 libfakekey0 libfarstream-0.2-5 libffmpegthumbnailer4v5 libflite1 libfluidsynth1 libgamin0 libgit2-24 libgksu2-0 libgme0 libgroupsock8 libgsm1 libgssdp-1.0-3 libgtksourceview2.0-0 libgtksourceview2.0-common libgupnp-1.0-4 libgupnp-igd-1.0-4 libhttp-parser2.1 libidn2-0 libido-0.1-0 libimobiledevice-utils libiso9660-8 libisofs6 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libjs-jquery-ui libjs-mathjax libjs-prototype libkate1 libkeybinder-3.0-0 libkeybinder0 liblchown-perl liblivemedia50 liblwp-useragent-determined-perl libmad0 libmarco-private0 libmate-desktop-2-17 libmate-menu2 libmate-panel-applet-4-1 libmate-sensors-applet-plugin0 libmate-slab0 libmate-window-settings1 libmatedict6 libmatekbd-common libmatekbd4 libmatemixer-common libmatemixer0 libmateweather-common libmateweather1 libmath-random-isaac-perl libmath-random-isaac-xs-perl libmatroska6v5 libmcrypt4 libmeanwhile1 libmikmod3 libmodplug1 libmp3lame0 libmpcdec6 libmpeg2-4 libnghttp2-14 libnice10 liboobs-1-5 libopenal-data libopenal1 libopencv-core2.4v5 libopencv-imgproc2.4v5 libopenjp2-7 libopenjpeg5 libotr5 libperl5.24 libplank-common libplank1 libplist-utils libportmidi0 libpostproc-ffmpeg53 libpostproc54 libproxy-tools libpsl5 libqt5libqgtk2 libqt5scintilla2-12v5 libqt5scintilla2-l10n libqt5x11extras5 libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc libraspberrypi0 libreoffice-style-human libresid-builder0c2a librtaudio4v5 librtimulib-utils librtimulib7 librtmidi2v5 librubberband2v5 libschroedinger-1.0-0 libscsynth1 libsdl-image1.2 libsdl-mixer1.2 libsdl-ttf2.0-0 libsdl2-2.0-0 libshine3 libsidplay2v5 libsmpeg0 libsndio6.1 libsodium18 libsoxr0 libssh2-1 libssl1.0.2 libssl1.1 libstk-4.5.0 libswresample-ffmpeg1 libswresample2 libswscale-ffmpeg3 libswscale4 libterm-readkey-perl libterm-readline-perl-perl libtopmenu-client-gtk2-0 libtopmenu-client-gtk3-0 libtopmenu-server-gtk2-0 libtopmenu-server-gtk3-0 libtwolame0 libunique-1.0-0 libupnp6 libusageenvironment3 libva-drm1 libva-x11-1 libva1 libvcdinfo0 libvlc5 libvlccore8 libvte-common libvte9 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwnck-common libwnck22 libwxbase3.0-0v5 libwxgtk3.0-0v5 libx264-148 libx265-79 libxvidcore4 libzephyr4 libzip4 libzmq5 libzvbi-common libzvbi0 lightdm-gtk-greeter lightdm-gtk-greeter-settings lighttpd lua5.1 lynis marco marco-common mate-accessibility-profiles mate-applet-topmenu mate-applets mate-applets-common mate-backgrounds mate-control-center mate-control-center-common mate-desktop mate-desktop-common mate-desktop-environment-core mate-dock-applet mate-gnome-main-menu-applet mate-icon-theme mate-icon-theme-faenza mate-indicator-applet mate-indicator-applet-common mate-media mate-media-common mate-menu mate-menus mate-netbook mate-netbook-common mate-notification-daemon mate-notification-daemon-common mate-optimus mate-panel mate-panel-common mate-polkit mate-polkit-common mate-power-manager mate-power-manager-common mate-screensaver mate-screensaver-common mate-sensors-applet mate-sensors-applet-common mate-session-manager mate-settings-daemon mate-settings-daemon-common mate-system-monitor mate-system-monitor-common mate-terminal mate-terminal-common mate-themes mate-tweak mate-user-guide mate-utils mate-utils-common menu menu-xdg mesa-utils minecraft-pi mozo musescore-soundfont-gm netcat netcat-traditional nuscratch omxplayer p7zip-full perl-modules-5.24 perl-openssl-defaults php-bcmath php-mbstring php-xml php7.0-bcmath php7.0-mbstring php7.0-mcrypt php7.0-zip pi-bluetooth pidgin-data pidgin-otr pigpio pinentry-gtk2 plank pluma pluma-common plymouth-theme-ubuntu-mate-logo plymouth-theme-ubuntu-mate-text ppa-purge publicsuffix python-astropi python-avahi python-caja python-caja-common python-cap1xxx python-cloudfiles python-distutils-extra python-drumhat python-envirophat python-explorerhat python-gobject python-gpiozero python-gtksourceview2 python-mate-menu python-microdotphat python-minecraftpi python-mote python-motephat python-pantilthat python-pianohat python-picamera python-picraft python-piglow python-pigpio python-pip python-pip-whl python-pygame python-rainbowhat python-rpi.gpio python-rtimulib python-scrollphat python-sense-emu python-sense-hat python-smbus python-sn3218 python-spidev python-st7036 python-wheel python-wnck python-wxgtk3.0 python-wxversion python-xdg python-xlib python3-astropi python3-cap1xxx python3-decorator python3-drumhat python3-envirophat python3-explorerhat python3-gpiozero python3-microdotphat python3-minecraftpi python3-mote python3-motephat python3-pantilthat python3-pianohat python3-picamera python3-picraft python3-piglow python3-pigpio python3-pip python3-rainbowhat python3-rpi.gpio python3-rtimulib python3-scipy python3-scrollphat python3-sense-emu python3-sense-hat python3-setproctitle python3-smbus python3-sn3218 python3-spidev python3-st7036 python3-wheel qjackctl qt4-qtconfig raspberrypi-bootloader raspberrypi-kernel raspberrypi-sys-mods raspi-config raspi-copies-and-fills raspi-gpio read-edid rhythmbox-plugin-cdrecorder rkhunter rng-tools rpi-update rsnapshot rtmpdump ruby-activesupport ruby-afm ruby-ascii85 ruby-atomic ruby-coderay ruby-concurrent ruby-hamster ruby-hashery ruby-i18n ruby-json ruby-kramdown ruby-multi-json ruby-oj ruby-pdf-core ruby-pdf-reader ruby-prawn ruby-prawn-table ruby-rc4 ruby-rouge ruby-rugged ruby-stringex ruby-thread-safe ruby-ttfunk ruby-tzinfo ruby-wavefile sc3-plugins-server scratch sense-emu-tools smistrip snmp-mibs-downloader sonic-pi sonic-pi-samples sonic-pi-server squeak-plugins-scratch squeak-vm sshguard supercollider-server synapse system-tools-backends tilda timgm6mb-soundfont tlp tlp-rdw topmenu-gtk-common topmenu-gtk2 topmenu-gtk3 traceroute triggerhappy ttf-dejavu-core ubuntu-mate-artwork ubuntu-mate-default-settings ubuntu-mate-icon-themes ubuntu-mate-libreoffice-draw-icons ubuntu-mate-lightdm-theme ubuntu-mate-themes ubuntu-mate-wallpapers ubuntu-mate-wallpapers-common ubuntu-mate-wallpapers-xenial ubuntu-mate-welcome unhide unhide.rb vlc vlc-data vlc-nox vlc-plugin-notify wiringpi wodim xul-ext-calendar-timezones xul-ext-gdata-provider xul-ext-lightning xzoom youtube-dl youtube-dlg zabbix-agent zabbix-frontend-php zabbix-release
        2018-08-25 20:07:45,440 DEBUG updateSourcesList()
        2018-08-25 20:07:45,992 DEBUG rewriteSourcesList() with mirror_check
        2018-08-25 20:07:45,993 DEBUG ['ubuntu-minimal', 'ubuntu-standard']
        2018-08-25 20:07:45,993 DEBUG Checking pkg: ubuntu-minimal
        2018-08-25 20:07:45,996 DEBUG Checking pkg: ubuntu-standard
        2018-08-25 20:07:46,003 DEBUG examining: 'deb http://ports.ubuntu.com/ubuntu-ports xenial main restricted'
        2018-08-25 20:07:46,004 DEBUG entry 'deb http://ports.ubuntu.com/ubuntu-ports bionic main restricted' updated to new dist
        2018-08-25 20:07:46,004 DEBUG examining: 'deb http://ports.ubuntu.com/ubuntu-ports xenial-updates main restricted'
        2018-08-25 20:07:46,005 DEBUG entry 'deb http://ports.ubuntu.com/ubuntu-ports bionic-updates main restricted' updated to new dist
        2018-08-25 20:07:46,005 DEBUG examining: 'deb http://ports.ubuntu.com/ubuntu-ports xenial-security main restricted'
        2018-08-25 20:07:46,006 DEBUG entry 'deb http://ports.ubuntu.com/ubuntu-ports bionic-security main restricted' updated to new dist
        2018-08-25 20:07:46,008 DEBUG running doUpdate() (showErrors=True)
        2018-08-25 20:08:09,567 DEBUG openCache()
        2018-08-25 20:08:09,568 DEBUG failed to SystemUnLock() (E:Non verrouillé)
        2018-08-25 20:08:09,946 DEBUG /openCache(), new cache size 6946
        **2018-08-25 20:08:09,949 DEBUG need_server_mode(): run in 'desktop' mode, (because of key deps for 'ubuntu-mate-core')**
        2018-08-25 20:08:11,775 DEBUG Running KeepInstalledSection rules
        2018-08-25 20:08:12,732 DEBUG Kernel uname: '4.4.38-v7+'
        **2018-08-25 20:08:12,732 WARNING Can't parse kernel uname: 'not enough values to unpack (expected 3, got 2)' (self compiled?)**
        2018-08-25 20:08:12,732 DEBUG nvidiaUpdate()
        2018-08-25 20:08:13,751 INFO no old nvidia driver installed, installing no new
        2018-08-25 20:08:13,753 DEBUG plugins for condition 'PostDistUpgradeCache' are '[]'
        2018-08-25 20:08:13,754 DEBUG plugins for condition 'bionicPostDistUpgradeCache' are '[]'
        2018-08-25 20:08:13,754 DEBUG plugins for condition 'from_xenialPostDistUpgradeCache' are '[]'
        2018-08-25 20:08:13,754 DEBUG quirks: running PostDistUpgradeCache
        2018-08-25 20:08:13,755 DEBUG running Quirks.PostDistUpgradeCache
        2018-08-25 20:08:14,357 INFO linux metapackage () not available
        **2018-08-25 20:08:23,397 ERROR Dist-upgrade failed: 'E:Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».'**
        2018-08-25 20:08:23,401 DEBUG abort called
        2018-08-25 20:08:23,404 DEBUG openCache()
        2018-08-25 20:08:23,405 DEBUG failed to SystemUnLock() (E:Non verrouillé)
        2018-08-25 20:08:25,240 DEBUG /openCache(), new cache size 8812    

Je pense à un problème de paquets corrompus, mais je ne saurai pas comment régler. J'ai déjà essayé les commandes du genre, autoclean, clean, autoremove, dist-upgrade, update etc …

Merci pour toute aide.

Bonne soirée.

  • # armv7 pas pret ?

    Posté par . Évalué à 3 (+1/-0).

    j'ai pas lu tout le log,
    mais c'est peut-etre que le support en ARMv7 est encore experimentale

    du coup certains outils ne sont pas pret,
    ou certains paquets n'existent plus en bionic

    • [^] # Re: armv7 pas pret ?

      Posté par . Évalué à 1 (+0/-0).

      Salut,

      Bah, en théorie, sur le site de Canonical, la version d'ubuntu pour ARM est dispo. Donc normalement ca devrait fonctionner … Je pense que c'est un problème de paquets, mais je sais pas comment le résoudre ni ou regarder.

  • # Paquet bloqué

    Posté par . Évalué à 2 (+1/-0).

    Si je lis bien, l'erreur est indiquée ici :
    **2018-08-25 20:08:23,397 ERROR Dist-upgrade failed: 'E:Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».'**

    As-tu utilisé le pinning pour bloquer un paquet ?
    Si c'est le cas, tu dois pouvoir le retrouver avec :

    dpkg -l | grep ^h
    (enfin, je suis pas trop sûr, sinon cherche avec dpkg --get-selections)
    puis un coup de
    sudo apt-mark unhold les_paquets_marques_hold

    Et un problème peut peut-être aussi venir de là :
    2018-08-25 20:08:12,732 DEBUG Kernel uname: '4.4.38-v7+'
    2018-08-25 20:08:12,732 WARNING Can't parse kernel uname: 'not enough values to unpack (expected 3, got 2)' (self compiled?)

    C'est quoi comme machine précisément, et comment as-tu installé xenial dessus ?

    • [^] # Re: Paquet bloqué

      Posté par . Évalué à 1 (+0/-0).

      Salut,

      Oui, en effet, j'avais mis en gras les lignes que je pensais être les plus pertinentes, mais je vois que cela n'a pas fonctionné. C'est quoi le "pinning" ? Donc avec cette commande je devrais pouvoir vérifier si j'ai des paquets bloqués, c'est ça ?

      Oui… J'avais remarqué cette ligne aussi, mais bon là aussi je sais pas l'interpréter … Je sais que juste avant, j'ai fait un upgrade et que il y a eu un update du micro-logiciel, mais j'en saurais pas plus …

      C'est un Raspberry pi 3. J'ai téléchargé l'image sur Canonical et décompressée sur carte SD.

      Dépaquetage de linux-firmware (1.157.20) sur (1.157.19) ...
      Voilà,

      Merci pour les réponses.

      • [^] # Re: Paquet bloqué

        Posté par . Évalué à 3 (+1/-0).

        C'est un Raspberry pi 3. J'ai téléchargé l'image sur Canonical et décompressée sur carte SD.

        le meilleur upgrade c'est peut-etre de sauvegarder ce qu'il y a sur ton PI
        et de refaire la carte SD avec la nouvelle version d'ubuntu.

        • [^] # Re: Paquet bloqué

          Posté par . Évalué à 1 (+0/-0).

          Je plussoie.
          Cette réponse n'est peut-être pas celle que tu attendait, mais sur un raspberry, je pense que c'est la meilleure méthode : pour une mise à niveau, il va en effet devoir télécharger et décompresser tous les paquets. C'est long et tu n'as peut être simplement pas assez de place sur ta carte SD pour faire cela.
          Il y a une commande pour lister les paquets que tu as installé manuellement sous Xenial : tu sauvegarde cette liste, tu la "nettoie" et tu pourra ré-installer sur Bionic. Cherches sur la doc ubuntu.fr

          • [^] # Re: Paquet bloqué

            Posté par . Évalué à 1 (+0/-0).

            Je dirais même d'effacer les partitions elles-mêmes parce qu'une SD a un algo de wear-leveling assez mauvais. Comme une clé USB, c'est vraiment pas un bon support pour un système d'exploitation qui n'est pas en lecture seule.

          • [^] # Re: Paquet bloqué

            Posté par . Évalué à 1 (+0/-0). Dernière modification le 27/08/18 à 23:07.

            Salut,

            Ouais en effet lol … Niveau espace libre je suis tranquille à mon avis :

            /dev/root 29G 4,2G 25G 15% /
            OK merci, je vais vérifier.

            • [^] # Re: Paquet bloqué

              Posté par . Évalué à 3 (+2/-0). Dernière modification le 28/08/18 à 09:57.

              D'après la doc :
              https://wiki.ubuntu.com/ARM/RaspberryPi

              Il n'y a pas de support officiel. Et d'une rapide recherche, je te confirme qu'il ne semble pas y avoir (au 19/08) d'image pour le raspberry3 :

              The Raspberry Pi 3 does not (yet) work with official Ubuntu images out of the box, but unofficial images are available.

              et :

              Raspberry Pi 3: The official Raspberry Pi 2 images can be used with a Pi 3B/3B+ after minor changes (see instructions below).

              Le process d'upgrade ne doit pas fonctionner car il ne met pas correctement à jour le firmware, le noyau et/ou le chargeur d'amorçage qui est spécifique au Pi3 : l'image officielle ne fonctionne que sur le Pi2. Donc pour le moment, tu dois attendre ou faire les manip indiquées mais à partir d'un image précompilée, et par par un upgrade

              • [^] # Re: Paquet bloqué

                Posté par . Évalué à 0 (+0/-1). Dernière modification le 28/08/18 à 13:24.

                Salut,

                Pourtant, j'ai bien téléchargé l'image sur le site officiel.

                arm64
                
                    The generic arm64 ISO images can be used with the Raspberry Pi 3. Instructions for booting these are below. 
                

                Hm?

                https://www.ubuntu.com/download/server/arm

                • [^] # Re: Paquet bloqué

                  Posté par . Évalué à 1 (+0/-1).

                  si tu as chargé l'image telle que tu le dis, tu es deja en bionic beaver (18.04 LTS) tu n'as donc pas besoin de faire le do-release-upgrade

                  • [^] # Re: Paquet bloqué

                    Posté par . Évalué à 1 (+0/-0).

                    Non … mais mon installation date de plus d'un an. Je suis bien en 16.04 et je souhaite passer en 18.04.

                • [^] # Re: Paquet bloqué

                  Posté par . Évalué à 2 (+1/-0).

                  Ok…
                  Tu comprends bien la différence entre : "can be used" et "supported" ?

                  Ta citation précise :

                  "Instructions for booting these are below. "

                  Donc il y a une (ou des) manip supplémentaire(s) qui sont spécifiques à cette carte, comme c'est très souvent le cas avec les cartes ARM.

                  A+

                  • [^] # Re: Paquet bloqué

                    Posté par . Évalué à 1 (+0/-0).

                    Certainement. Les instructions pour booter l'image, mais mon image est bootée depuis un moment déjà …

                    • [^] # Re: Paquet bloqué

                      Posté par . Évalué à 4 (+2/-0).

                      Certainement. Les instructions pour booter l'image, mais mon image est bootée depuis un moment déjà …

                      ton image 16.04
                      pas ton image 18.04

                      la mise à jour des paquets va chercher à changer des parametres systemes, la maniere de demarrer, charger des firmwares,
                      ce qui echoue puisque ce n'est pas la procédure officielle pour installer 18.04 LTS-ARM

                      il ne te reste plus que la mise à jour par une reinstallation de la carte en 18.04

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.