Forum Linux.debian/ubuntu Problème de performances avec un Crossfire sous Debian

Posté par  . Licence CC By‑SA.
Étiquettes :
0
4
jan.
2016

Bonjour à tous, et excellente année 2016.

J'ai des problèmes pour faire tourner un Crossfire de 7970, que ce soit sur une debian stable (install fraîche), une LMDE ou une xubuntu (testé avec branche 14.* et 15.*).

Je me suis fortement inspiré de ce thread (en particulier l'usage en ligne de commande de aticonfig).

J'ai fais plusieurs essais, tous infructueux, que ce soit avec les pilotes proprios Crimson (15+) ou les derniers pilotes de la branche 14.*. Sur xubuntu, j'ai essayé les trois pilotes proposés (libre et les deux non-libres).

Premier problème: toutes les commandes avec aticonfig passent bien, la chaîne CF est correctement créée, aticonfig --lscs m'indique que le CF est activé, mais aucune application (jeu en fait) en plein écran ne tire parti de la deuxième carte (je le sais grâce à la commande watch -n10 aticonfig --adapter=all --odgt --odgc). Par ailleurs, même aux niveaux de détails minimaux, le framerate est désespérément bas (comme si le rendu était software en fait).

Avec l'outil graphique (amdcccle), je vois que le CF est activé, mais pas sur le bon écran (j'oubliais, en plus du CF, j'ai trois écrans, mais pas de eyefinity). Je ne sais pas si c'est important, étant donné que même si je lance le jeu sur l'écran où le CF est supposé être actif, la deuxième carte reste de marbre.

Deuxième problème: si je reboote, je perds mes réglages.

Troisième problème: ça n'a peut être rien à voir, mais quelque soit le pilote et quelque soit l'application (firefox, chrome, l'explorateur de fichiers), le scroll vertical n'est pas soft. Il y a un déchirement, comme si l'option éponyme n'était pas activée.

Alors, je sais, je cumule: AMD, Crossfire, triple-head, je pars pas gagnant. Mais je n'ai pas trop les moyens de remplacer les deux cartes par du nvidia, et j'ai peine à croire que mon setup soit si rare que personne n'ait eu le problème avant moi sans l'avoir résolu !

Étant ma machine principale, j'ai du réinstaller Windows 8.1 pour pouvoir jouer mais surtout bosser (pas trop le temps de trifouiller avec la reprise). Mais je me suis dis que j'allais tenter le coup et poser la question…

  • # faire simple

    Posté par  . Évalué à 2.

    quand tu veux jouer, desactive les 2 autres ecrans, sauf à jouer en triple-head à des simulateurs de vols ou de courses, le triple head ne te sert à rien pendant le jeu.

    ca peut simplifier les problemes.

    ensuite, il me semble que certains pilotes reclament d'avoir le tout dernier noyau ou presque, à verifier donc.
    et enfin, il me semble qu'ATI fournit 2 pilotes fglrx et amdgpu et qu'il faut blacklister l'un d'entre eux suivant la generation de la carte graphique pour etre sur que l'autre se charge correctement.

    • [^] # Re: faire simple

      Posté par  . Évalué à 1.

      Merci de ta réponse. Je teste ça.

    • [^] # Re: faire simple

      Posté par  . Évalué à 1.

      Bon on progresse.

      En fait, c'était le pilote proprio qui cassait libgl. La réinstallation des pilotes résout ce problème. Maintenant j'ai bien un rendu hardware selon glxinfo. Du coup, ça résout aussi mon problème de performances en plein écran. Par la même occasion, le crossfire est bien activé et les applis plein écran en profitent.

      Par contre, bien que ton astuce de désactiver les autres écrans m'ait conduit sur la bonne voie, ce n'est pas utilisable pour moi. J'ai besoin de mes trois écrans pour bosser. Je me vois mal désactiver les deux autres écrans, redémarrer, jouer, redémarrer, réactiver les écrans, redémarrer, bosser… Par ailleurs, il peut m'être utile d'avoir au moins un écran supplémentaire en cours de jeu (pour mes mails ou une console par exemple).

      En réactivant les deux écrans, le crossfire est désactivé, et je ne peux plus le réactiver sans désactiver les écrans… Donc j'ai au choix soit trois écrans, soit le crossfire mais pas les deux.

      • [^] # Re: faire simple

        Posté par  . Évalué à 1.

        Par ailleurs, le scroll est toujours haché, en particulier sur firefox… Comprends pas…

      • [^] # Re: faire simple

        Posté par  . Évalué à 1.

        J'ai dis une connerie: j'ai toujours un problème de perf. La deuxième carte reste inactive.

        Pourtant:

        # aticonfig --lscc
        
        Master adapter:  0. 03:00.0 AMD Radeon HD 7900 Series
            Candidates:  1. 04:00.0 AMD Radeon HD 7900 Series
        
        # aticonfig --lscs
            Candidate Combination: 
            Master: 3:0:0 
            Slave: 4:0:0 
            CrossFire is enabled on current device
            CrossFire Diagnostics:
            There is CrossFire Side port connection between GPUs
            CrossFire can work with P2P write through peer aperture
            Dongle Capabilities: support PASSTHROUGH |INTERLINK_SW_AFR | INTERLINK_AUTO_AFR | INTERLINK_BLACKING | INTERLINK_SUPERAA
        
        # aticonfig --lsch
        
        Multiple GPU chain for adapter 0, status: Crossfire is enabled
          0. 03:00.0 AMD Radeon HD 7900 Series
          1. 04:00.0 AMD Radeon HD 7900 Series
        
        # glxinfo
        name of display: :0
        display: :0  screen: 0
        direct rendering: Yes
        server glx vendor string: ATI
        server glx version string: 1.4
        [...]
        
        # cat /etc/X11/xorg.conf
        Section "ServerLayout"
            Identifier     "aticonfig Layout"
            Screen      0  "aticonfig-Screen[0]-0" 0 0
        EndSection
        
        Section "Module"
        EndSection
        
        Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
        EndSection
        
        Section "Monitor"
            Identifier   "0-DFP5"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
            Option      "PreferredMode" "1920x1080"
            Option      "TargetRefresh" "120"
            Option      "Position" "0 0"
            Option      "Rotate" "normal"
            Option      "Disable" "false"
        EndSection
        
        Section "Monitor"
            Identifier   "0-DFP10"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
            Option      "Disable" "true"
        EndSection
        
        Section "Monitor"
            Identifier   "0-DFP11"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
            Option      "Disable" "true"
        EndSection
        
        Section "Device"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            Option      "Monitor-DFP5" "0-DFP5"
            Option      "Monitor-DFP10" "0-DFP10"
            Option      "Monitor-DFP11" "0-DFP11"
            BusID       "PCI:3:0:0"
        EndSection
        
        Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            DefaultDepth     24
            SubSection "Display"
                Viewport   0 0
                Depth     24
            EndSubSection
        EndSection
        
      • [^] # Re: faire simple

        Posté par  . Évalué à 1.

        En fait je suis repassé sur le pilote libre.

        Je dois faire l'impasse sur le crossfire et j'ai toujours un soucis de fluidité du scroll dans firefox, mais je suis très agréablement surpris des performances en jeux (Civ 5 notamment et 7DTD).

        • [^] # Re: faire simple

          Posté par  . Évalué à 1.

          J'ai résolu le problème de scrolling en jouant avec les options du compositeur de fenêtres.

      • [^] # Re: faire simple

        Posté par  . Évalué à 2.

        En réactivant les deux écrans, le crossfire est désactivé, et je ne peux plus le réactiver sans désactiver les écrans… Donc j'ai au choix soit trois écrans, soit le crossfire mais pas les deux.

        si tu as une carte graphique integrée à la carte mere tu peux essayer de faire un triple head avec 2 ATI et 1 CPU

        Je me vois mal désactiver les deux autres écrans, redémarrer, jouer, redémarrer, réactiver les écrans, redémarrer, bosser

        pourquoi rebooter ?
        il existe des outils comme arender ou le gestionnaire fournit par ta distrib pour choisir l'ecran actif, desactiver les autres,
        puis reactiver les ecrans.

        • [^] # Re: faire simple

          Posté par  . Évalué à 2.

          pourquoi rebooter ?

          Parce qu'amdcccle veut rebooter chaque fois que tu coche une case…
          Evidemment, avec le pilote libre, le probleme ne se pose pas.

  • # hors sujet

    Posté par  . Évalué à 1.

    Salut,
    J'ai une carte graphique hd 7950, pour savoir s'il est limité par mon alimentation ou par mon processeur j'aurais aimer savoir:
    - quel processeur tu possède ?
    - ton alimentation est de combien watt ?
    - résultat de: fgl_glxgears (si possible avec un seul écran)

    Ça pourrait m'éviter une ou deux centaine d'euros.

    Merci d'avance.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.