Forum Linux.debian/ubuntu Problèmes virtualhost Apache Debian Jessie

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
0
29
mai
2015

Bonjour à tous,

Bénéficiaire d'un second nom de domaine j'ai décidé de créer un hôte virutel sur mon serveur web.

ServerAdmin moi@exemaple.com
ServerName www.example.com
ServerAlias example.com
DocumentRoot /home/example/www/

Je rends ce site disponible, je l'autorise je recharge ma configuration apache et j'obtiens une erreur 403 :
Forbidden

You don't have permission to access / on this server.

En revanche si j'indique DocumentRoot /var/www/example/ cela marche.

Je pense avoir un problème de droit sur mon répertoire /home/example/www/
ls -al www: drwxr-xr-x 2 nitchevo2 nitchevo2 4096 mai 29 10:31 www

Voilà je vous remercie de vos conseils.

  • # droits sur les dossiers parents

    Posté par  . Évalué à 3.

    Il faut que le compte qui fait tourner apache (généralement apache ou www-data) puisse traverser (droit +x) les dossiers parents /home et /home/example

    Il y a bien une page d'index dans /home/example/www ? Parce que sinon, ça va te renvoyer une 403 aussi s'il n'y a pas l'option Indexes dans la conf apache.

    • [^] # Re: droits sur les dossiers parents

      Posté par  . Évalué à 3. Dernière modification le 29/05/15 à 14:25.

      tu dois avoir un problème de droits en terme de config, pas en terme de FS.

      si apache sur jessie est bien un 2.4, essaie d'ajouter ceci :

      <Directory "/home/example/www">
      Require all granted
      </Directory>

      plus de détails ici : http://httpd.apache.org/docs/2.4/fr/mod/mod_authz_host.html

      et comme dit par kna, vérifie aussi le DirectoryIndex ;)

      • [^] # Re: droits sur les dossiers parents

        Posté par  (site Web personnel) . Évalué à 2. Dernière modification le 29/05/15 à 15:19.

        Merci pour vos remarques qui correspondaient à mes recherches.

        chmod +x sur home puis example n'ont rien donné et j'avais ajouté la directive Require all granted ce matin.

        Bilan je sèche

        Si si ça marche j'avais juste en tâtonnant modifié le document root qui du coup ne correspondait plus à celui dont j'avais modifié les droits d'accès, merci encore.

        Vincent

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.