Forum Linux.debian/ubuntu Statut des services sous debian sarge

Posté par  .
Étiquettes : aucune
0
10
avr.
2006
Bonjour,
J'ai une debian Sarge et je souhaiterai connaître l'état de mes services sans avoir a faire un start ou stop, (avant sous mandrake un simple "/etc/init.d/service status" suffisait) comment faire de même avec debian?
merci.
  • # Commentaire supprimé

    Posté par  . Évalué à 3.

    Ce commentaire a été supprimé par l’équipe de modération.

    • [^] # Re: Un peu de bash

      Posté par  . Évalué à 2.

      détail : '*.pid' au lieu de *.pid

      donc :
      for i in `find /var/run/ -name '*.pid'`; do echo -ne `basename $i | cut -d '.' -f 1` "\t\t"; pid=`cat $i`; if [[ -z `ps -e | grep $pid` ]] ; then echo "DOWN"; else echo "UP"; fi; done
      • [^] # Re: Un peu de bash

        Posté par  . Évalué à 1.

        Merci beaucoup !!
        cette solution fonctionne et je t'en remercie cependant elle affiche que WEBMIN est en down alors qu'il est demarré, as-tu une réponse?
        • [^] # Commentaire supprimé

          Posté par  . Évalué à 1.

          Ce commentaire a été supprimé par l’équipe de modération.

          • [^] # Re: Un peu de bash

            Posté par  . Évalué à 1.

            Oui il y a un process qui se lance (webmin.pid) mais apparement d'apres mes tests il ne se met pas a jour lorsqu'il y a un arret/relance de webmin donc le numero de PID dans le fichier ne correspond plus a celui lancé et il remonte webmin en DOWN avec ton script.
            j'ai rentré le PID a la main dans le fichier et la ton script le remonte bien en UP.
            Donc comment corriger le fait que le fichier webmin.pid ne se mette pas a jour?
            merci
        • [^] # Re: Un peu de bash

          Posté par  . Évalué à 2.

          Chez-moi-ca-marche.
          Webmin est bien indiqué UP avec son script.
          • [^] # Re: Un peu de bash

            Posté par  . Évalué à 1.

            C'est bon j'ai trouvé le probleme :)!!
            En fait le soucis se situe au niveau de fichier webmin.pid, il ne se met pas à jour (j'espère que vous savez pourquoi parce que moi non) le numero du PID dans le fichier ne correspond pas à celui du processus webmin qui est en cours mais lorsque je le rentre à la main dans le fichier, ton script le remonte bien en UP.
            Savez-vous pourquoi le numero de PID n'est pas a jour dans le fichier?
            • [^] # Re: Un peu de bash

              Posté par  . Évalué à 2.

              Non, je sais pas vraiment ...
              Chez moi c'est sur une debian Sarge aussi.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.