Forum Linux.debian/ubuntu Stellarium dit : "GLSL un peu ancien" - quelles options ?

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
2
29
avr.
2020

Bonsoir à toutes et à tous,

Sur Debian 10 Buster,
(lspci)
01:00.0 VGA compatible controller: NVIDIA Corporation NV40 GeForce 6800

Après avoir installé et démarré Stellarium, celui-ci s'est plaint :
(./.stellarium/log.txt)
GLSL Version Number detected: 1.2
This is not enough: we need GLSL1.30 or later.

Autres infos :
Detected: OpenGL "2.1"
et :
MESA Version Number detected: 18.3
Mesa version is fine, we should not see a graphics problem.

Dans Stellarium, je ne vois qu'un seul défaut : quand je mets le réglage "Atmosphère", je vois des "poeles à frire de profil" sur la partie gauche de l'écran (sauf sur le "sol")…
Bizarrement, avec le réglage de lancement ("LIBGL_ALWAYS_SOFTWARE=1 stellarium"), ça ne le faisait pas, mais c'était beaucoup moins fluide.

J'ai cherché de ci, de là, sur le site et plus généralement, et je crains le pire…

Mais il me reste une question à laquelle je n'ai pas directement trouvé de réponse (je la pose ici pour la première fois ;-) ) : est-ce que je peux résoudre mon problème de version (pour OpenGL et tout ce qui en dépend) en remplaçant le pilote "nouveau" par un pilote propriétaire nvidia ?

Merci d'avance de vos éclaircissements.

Ludo0565

  • # version carte graphique

    Posté par  . Évalué à 3.

    en mode software, ca fonctionne mais ce n'est pas fluide, car c'est ton CPU qui fait le calcul, et envoie le résultat à la carte graphique

    en mode hardware, c'est le GPU qui doit faire le calcul, et il va utiliser certaines fonctionnalités en hardware, c'est là que le GLSL1.2 va poser souci, c'est que la carte graphique (Geforce 6800) ne supporte pas au dela d'une certaine version openGL/GLSL

    tu peux le verifier dans la fiche technique de la carte
    https://www.nvidia.com/en-us/drivers/geforce6-techspecs/

    on y voit que ta carte est compatible openGL v2

    et d'apres la liste suivante
    https://en.wikipedia.org/wiki/OpenGL_Shading_Language#Versions

    GLSL 1.3 arrive avec openGL v3

    du coup je doute qu'un passage aux pilotes propriétaires permettent à ta vieille carte, d'avoir l'openGL v3

    • [^] # Re: version carte graphique

      Posté par  . Évalué à 2. Dernière modification le 29/04/20 à 09:59.

      C'est même sûr. La solution fluide est de se passer de l'effet que ton matériel - 14 ans d'âge - ne sait pas faire.

      ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # ça se tente

    Posté par  . Évalué à 2. Dernière modification le 29/04/20 à 10:09.

    en remplaçant le pilote "nouveau" par un pilote propriétaire nvidia ?

    Pour avoir testé les deux avec le même vieux jeu (Brütal Legend) sur une carte de génération Fermi (donc très bien supportée par le pilote libre), il n'y a clairement pas photo : le pilote proprio s'en sort beaucoup mieux au niveau performances et ce sans aucun artefact ou problème de textures manquantes.

    Mais la 6800 est de toute façon officiellement indiquée pour OpenGL 2.1 donc t'auras sans doute pas de compatibilité supérieure.

    Si c'est un PC fixe, tu peux tenter de trouver une carte graphique plus récente. Même en port AGP il y a eu des modèles tardifs comme la Radeon 3850 ou la Gigabyte HD4650 (j'en ai une si t'as besoin) supportant OpenGL 3.3 et qui devraient bien fonctionner avec le pilote libre radeon.

  • # Stellarium dit : "GLSL un peu ancien" - quelles options ? Pas trop ... :-(

    Posté par  . Évalué à 2.

    Re-bonjour à toutes et à tous,

    Et merci de vos réponses !… Ça fait plaisir de voir qu'on est bien renseigné !…

    Je me doutais que c'était un peu compromis… vu que à la fin des fins, comme vous l'avez confirmé, OpenGl dépend de la carte… C'est bien ce que montre le lien, envoyé par NeoX, vers les pages de nvidia…

    Et en plus c'est vrai que, rien n'étant éternel (surtout en matériel info), l'AGP n'a plus fait de vieux jours après le début du 21e siècle…

    Je vais donc commencer à regarder de ci, de là… Autant rester sur du logiciel libre… et voir un autre matériel…

    Cordialement

    Ludo0565

  • # Stellarium en ligne

    Posté par  . Évalué à 3. Dernière modification le 29/04/20 à 19:26.

    Peut être que la version en ligne de Stellarium pourrait te convenir ?

    https://stellarium-web.org/

    (sur un tout vieux tout petit atom, avec 2g de ram et Falkon comme navigateur == super fluide, tout le temps)

    • [^] # Re: Stellarium en ligne

      Posté par  . Évalué à 3.

      Bonjour à toutes et à tous, bonjour tankey,

      Oups, ça n'a pas plu du tout à la config de l'ordi… :-))
      Avec le "feu d'artifice" que ça a fait, j'ai bien vite refermé mon navigateur !…

      Pas de souci !
      Dans un premier temps, j'ai décidé de ne rien changer.
      La seule concession de configuration que j'ai faite, c'est de garder l'affichage sans "Atmosphère", c'est-à-dire que c'est la "nuit" tout le temps [comme ça, je vois des étoiles dès le matin ! :-)) ].

      Cordialement

      ludo0565

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.